summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-07-27 19:48:20 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-07-27 19:48:20 +0000
commit45028e818ef94b48c2b10ee974e8ad7bf9f7b564 (patch)
tree62d030a765ad962065ac4fbe88dab64e50f05cb0 /app-i18n
parent QA: Get rid of deprecated qt_min_version(). Fix broken inheritance of kde-fu... (diff)
downloadgentoo-2-45028e818ef94b48c2b10ee974e8ad7bf9f7b564.tar.gz
gentoo-2-45028e818ef94b48c2b10ee974e8ad7bf9f7b564.tar.bz2
gentoo-2-45028e818ef94b48c2b10ee974e8ad7bf9f7b564.zip
QA: Get rid of deprecated qt_min_version(). Quoting issues.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/qimhangul/ChangeLog8
-rw-r--r--app-i18n/qimhangul/qimhangul-0.0.2.ebuild18
-rw-r--r--app-i18n/qimhangul/qimhangul-0.0.3.ebuild14
3 files changed, 24 insertions, 16 deletions
diff --git a/app-i18n/qimhangul/ChangeLog b/app-i18n/qimhangul/ChangeLog
index 05a379045c25..7781cec291d6 100644
--- a/app-i18n/qimhangul/ChangeLog
+++ b/app-i18n/qimhangul/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/qimhangul
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/qimhangul/ChangeLog,v 1.7 2007/02/21 22:10:36 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/qimhangul/ChangeLog,v 1.8 2008/07/27 19:48:20 carlo Exp $
+
+ 27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> qimhangul-0.0.2.ebuild,
+ qimhangul-0.0.3.ebuild:
+ QA: Get rid of deprecated qt_min_version(). Quoting issues.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-i18n/qimhangul/qimhangul-0.0.2.ebuild b/app-i18n/qimhangul/qimhangul-0.0.2.ebuild
index f45cb1e4256a..a95607069959 100644
--- a/app-i18n/qimhangul/qimhangul-0.0.2.ebuild
+++ b/app-i18n/qimhangul/qimhangul-0.0.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/qimhangul/qimhangul-0.0.2.ebuild,v 1.3 2007/01/05 16:22:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/qimhangul/qimhangul-0.0.2.ebuild,v 1.4 2008/07/27 19:48:20 carlo Exp $
+
+EAPI=1
inherit qt3 eutils
@@ -13,27 +15,27 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="$(qt_min_version 3.3.4)"
+DEPEND="x11-libs/qt:3"
pkg_setup() {
- if [ ! -e /usr/qt/3/plugins/inputmethods/libqimsw-none.so ] ; then
+ if [ ! -e "${QTDIR}"/plugins/inputmethods/libqimsw-none.so ] ; then
die "You need to rebuild >=x11-libs/qt-3.3.3-r1 with immqt-bc or immqt USE flag enabled."
fi
}
src_compile() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
}
src_compile() {
- ${QTDIR}/bin/qmake -makefile || die "qmake failed"
+ "${QTDIR}"/bin/qmake -makefile || die "qmake failed"
emake -j1 || die "make failed."
}
src_install() {
- make INSTALL_ROOT=${D} install || die
+ make INSTALL_ROOT="${D}" install || die
dodoc ChangeLog
}
diff --git a/app-i18n/qimhangul/qimhangul-0.0.3.ebuild b/app-i18n/qimhangul/qimhangul-0.0.3.ebuild
index 8e9b6b10a709..4cb5c36868e8 100644
--- a/app-i18n/qimhangul/qimhangul-0.0.3.ebuild
+++ b/app-i18n/qimhangul/qimhangul-0.0.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/qimhangul/qimhangul-0.0.3.ebuild,v 1.2 2007/01/05 16:22:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/qimhangul/qimhangul-0.0.3.ebuild,v 1.3 2008/07/27 19:48:20 carlo Exp $
+
+EAPI=1
inherit qt3
@@ -13,21 +15,21 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="$(qt_min_version 3.3.4)"
+DEPEND="x11-libs/qt:3"
pkg_setup() {
- if [ ! -e /usr/qt/3/plugins/inputmethods/libqimsw-none.so ] ; then
+ if [ ! -e "${QTDIR}"/plugins/inputmethods/libqimsw-none.so ] ; then
die "You need to rebuild >=x11-libs/qt-3.3.3-r1 with immqt-bc or immqt USE flag enabled."
fi
}
src_compile() {
- ${QTDIR}/bin/qmake -makefile || die "qmake failed"
+ "${QTDIR}"/bin/qmake -makefile || die "qmake failed"
emake -j1 || die "make failed."
}
src_install() {
- make INSTALL_ROOT=${D} install || die
+ make INSTALL_ROOT="${D}" install || die
dodoc ChangeLog
}