summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-29 19:52:48 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-29 19:52:48 +0000
commit72a88b95718bc9c140967054505ecbd4d1ef399c (patch)
treeac57e1fa376a5eda6195e039ee05809948e195d3 /app-i18n
parentold wrt #218479 (diff)
downloadgentoo-2-72a88b95718bc9c140967054505ecbd4d1ef399c.tar.gz
gentoo-2-72a88b95718bc9c140967054505ecbd4d1ef399c.tar.bz2
gentoo-2-72a88b95718bc9c140967054505ecbd4d1ef399c.zip
Version bump wrt #219348 using ebuild by Peter Alfredsen.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/libtabe/ChangeLog10
-rw-r--r--app-i18n/libtabe/files/libtabe-0.2.6-fabs.patch24
-rw-r--r--app-i18n/libtabe/libtabe-0.2.6.ebuild52
3 files changed, 84 insertions, 2 deletions
diff --git a/app-i18n/libtabe/ChangeLog b/app-i18n/libtabe/ChangeLog
index d557ea73d121..caba43bafb45 100644
--- a/app-i18n/libtabe/ChangeLog
+++ b/app-i18n/libtabe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/libtabe
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtabe/ChangeLog,v 1.9 2007/02/09 07:14:07 flameeyes Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtabe/ChangeLog,v 1.10 2008/04/29 19:52:47 drac Exp $
+
+*libtabe-0.2.6 (29 Apr 2008)
+
+ 29 Apr 2008; Samuli Suominen <drac@gentoo.org>
+ +files/libtabe-0.2.6-fabs.patch, +libtabe-0.2.6.ebuild:
+ Version bump wrt #219348 using ebuild by Peter Alfredsen.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/app-i18n/libtabe/files/libtabe-0.2.6-fabs.patch b/app-i18n/libtabe/files/libtabe-0.2.6-fabs.patch
new file mode 100644
index 000000000000..2f16c275ea95
--- /dev/null
+++ b/app-i18n/libtabe/files/libtabe-0.2.6-fabs.patch
@@ -0,0 +1,24 @@
+ * QA Notice: Package has poor programming practices which may compile
+ * fine but exhibit random runtime failures.
+ * tabe_tsi.c:385: warning: incompatible implicit declaration of built-in function ‘fabs’
+ * tabe_tsi.c:437: warning: incompatible implicit declaration of built-in function ‘fabs’
+ * tabe_tsi.c:496: warning: incompatible implicit declaration of built-in function ‘fabs’
+ * Please do not file a Gentoo bug and instead report the above QA
+ * issues directly to the upstream developers of this software.
+ * Homepage: http://packages.qa.debian.org/libt/libtabe.html
+
+diff -NrU5 libtabe-0.2.6.orig.really/src/tabe_tsi.c libtabe-0.2.6.orig/src/tabe_tsi.c
+--- libtabe-0.2.6.orig.really/src/tabe_tsi.c 2008-04-20 01:35:56.000000000 +0200
++++ libtabe-0.2.6.orig/src/tabe_tsi.c 2008-04-20 01:36:46.000000000 +0200
+@@ -12,10 +12,11 @@
+ #endif
+
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <math.h>
+
+ #include "tabe.h"
+
+ struct TsiInfo *
+ tabeTsiInfoNew(char *str)
diff --git a/app-i18n/libtabe/libtabe-0.2.6.ebuild b/app-i18n/libtabe/libtabe-0.2.6.ebuild
new file mode 100644
index 000000000000..4a45a0d3c672
--- /dev/null
+++ b/app-i18n/libtabe/libtabe-0.2.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtabe/libtabe-0.2.6.ebuild,v 1.1 2008/04/29 19:52:47 drac Exp $
+
+inherit eutils libtool autotools multilib
+
+DESCRIPTION="Libtabe provides bimsphone support for xcin-2.5+"
+HOMEPAGE="http://packages.qa.debian.org/libt/libtabe.html"
+SRC_URI="mirror://debian/pool/main/libt/libtabe/${P/-/_}.orig.tar.gz
+ mirror://debian/pool/main/libt/libtabe/${P/-/_}-1.1.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/db-4.5
+ x11-libs/libX11"
+
+S=${WORKDIR}/${P}.orig
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P/-/_}-1.1.diff
+ epatch "${FILESDIR}"/${P}-fabs.patch
+ rm -f configure
+ elibtoolize
+ cd script
+ eautoreconf
+ cp script/* ./
+ cp configure ../
+ cd ..
+}
+
+src_compile() {
+ myconf="--with-db-inc=/usr/include
+ --with-db-lib=/usr/$(get_libdir)
+ --with-db-bin=/usr/bin
+ --with-db-name=db
+ --enable-shared
+ --disable-static
+ $(use_enable debug)"
+
+ econf ${myconf}
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc doc/*
+}