summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-10-10 10:45:12 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-10-10 10:45:12 +0000
commit76c5021c057ebadc08c7040b46ec5dec3b7e7bdf (patch)
tree27612c083b43ddb30ce8e9284ccf4702d714c510 /app-i18n
parentStable on Alpha + ia64, bug 138178. (diff)
downloadgentoo-2-76c5021c057ebadc08c7040b46ec5dec3b7e7bdf.tar.gz
gentoo-2-76c5021c057ebadc08c7040b46ec5dec3b7e7bdf.tar.bz2
gentoo-2-76c5021c057ebadc08c7040b46ec5dec3b7e7bdf.zip
Version bumped. Cleanup ebuild.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim/ChangeLog8
-rw-r--r--app-i18n/scim/files/digest-scim-1.4.32
-rw-r--r--app-i18n/scim/files/digest-scim-1.4.53
-rw-r--r--app-i18n/scim/scim-1.4.5.ebuild93
4 files changed, 105 insertions, 1 deletions
diff --git a/app-i18n/scim/ChangeLog b/app-i18n/scim/ChangeLog
index 7839833eec96..d61f5234f093 100644
--- a/app-i18n/scim/ChangeLog
+++ b/app-i18n/scim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/scim
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.98 2006/10/10 01:11:27 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.99 2006/10/10 10:45:11 matsuu Exp $
+
+*scim-1.4.5 (10 Oct 2006)
+
+ 10 Oct 2006; MATSUU Takuto <matsuu@gentoo.org> +scim-1.4.5.ebuild:
+ Version bumped.
+ Cleanup ebuild.
10 Oct 2006; Jason Huebel <jhuebel@gentoo.org> scim-1.4.3.ebuild,
scim-1.4.4.ebuild:
diff --git a/app-i18n/scim/files/digest-scim-1.4.3 b/app-i18n/scim/files/digest-scim-1.4.3
index 4b6e7b774854..a0136c2a591a 100644
--- a/app-i18n/scim/files/digest-scim-1.4.3
+++ b/app-i18n/scim/files/digest-scim-1.4.3
@@ -1 +1,3 @@
MD5 504d43c56710e574be11320f3b0a2b2d scim-1.4.3.tar.gz 2608572
+RMD160 3c7dbe33896cede20858e9414966a28fef194765 scim-1.4.3.tar.gz 2608572
+SHA256 b8587b45d841b559e9b36c6b1db034a5f4223643dbdb9e0a2ba02c493b5c6bca scim-1.4.3.tar.gz 2608572
diff --git a/app-i18n/scim/files/digest-scim-1.4.5 b/app-i18n/scim/files/digest-scim-1.4.5
new file mode 100644
index 000000000000..5433c60176e2
--- /dev/null
+++ b/app-i18n/scim/files/digest-scim-1.4.5
@@ -0,0 +1,3 @@
+MD5 e2c71f9f54eda65cc1a515863a1839d2 scim-1.4.5.tar.gz 3157124
+RMD160 c4ea3c3bb06cdedb29ec32f8cabb0d32330dd6f6 scim-1.4.5.tar.gz 3157124
+SHA256 3565ecbe7f093254179d8fd216e6a54644859b59a5e5daf48a6c9cff3d5be481 scim-1.4.5.tar.gz 3157124
diff --git a/app-i18n/scim/scim-1.4.5.ebuild b/app-i18n/scim/scim-1.4.5.ebuild
new file mode 100644
index 000000000000..a20739c26faa
--- /dev/null
+++ b/app-i18n/scim/scim-1.4.5.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-1.4.5.ebuild,v 1.1 2006/10/10 10:45:11 matsuu Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gtk kde qt3"
+
+RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
+ gtk? ( >=x11-libs/gtk+-2
+ >=dev-libs/atk-1
+ >=x11-libs/pango-1
+ >=dev-libs/glib-2 )
+ !app-i18n/scim-cvs"
+DEPEND="${RDEPEND}
+ || ( x11-libs/libXt virtual/x11 )
+ doc? ( app-doc/doxygen )
+ dev-lang/perl
+ >=dev-util/intltool-0.33"
+
+PDEPEND="!alpha? ( !hppa? ( kde? ( app-i18n/skim ) ) )
+ !alpha? ( !hppa? ( !ppc64? ( !sparc? ( qt3? ( app-i18n/scim-qtimm ) ) ) ) )"
+
+get_gtk_confdir() {
+ if useq amd64 || ( [ "${CONF_LIBDIR}" == "lib32" ] && useq x86 ) ; then
+ echo "/etc/gtk-2.0/${CHOST}"
+ else
+ echo "/etc/gtk-2.0"
+ fi
+}
+
+src_compile() {
+ # bug #83625
+ filter-flags -fvisibility-inlines-hidden
+ filter-flags -fvisibility=hidden
+
+ econf \
+ $(use_with doc doxygen) \
+ $(use_enable gtk panel-gtk) \
+ $(use_enable gtk setup-ui) \
+ $(use_enable gtk gtk2-immodule) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README AUTHORS ChangeLog docs/developers docs/scim.cfg
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM with both GTK2 and XIM, you should use the following"
+ einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo "export GTK_IM_MODULE=\"scim\""
+ einfo "export QT_IM_MODULE=\"scim\""
+ einfo
+ einfo "where 'your_language' can be zh_CN, zh_TW, ja_JP.eucJP or any other"
+ einfo "UTF-8 locale such as en_US.UTF-8 or ja_JP.UTF-8"
+ einfo
+ einfo "If you prefer KDE/Qt interface, try emerge app-i18n/skim."
+ einfo
+ einfo "To use Chinese input methods:"
+ einfo " # emerge app-i18n/scim-tables app-i18n/scim-pinyin"
+ einfo "To use Korean input methods:"
+ einfo " # emerge app-i18n/scim-hangul"
+ einfo "To use Japanese input methods:"
+ einfo " # emerge app-i18n/scim-anthy"
+ einfo "To use various input methods (more than 30 languages):"
+ einfo " # emerge app-i18n/scim-m17n"
+ einfo
+ ewarn
+ ewarn "If you upgraded from scim-1.2.x or scim-1.0.x, you should remerge all SCIM modules."
+ ewarn
+ epause 10
+
+ [ -x /usr/bin/gtk-query-immodules-2.0 ] && gtk-query-immodules-2.0 > ${ROOT}$(get_gtk_confdir)/gtk.immodules
+}
+
+pkg_postrm() {
+
+ [ -x /usr/bin/gtk-query-immodules-2.0 ] && gtk-query-immodules-2.0 > ${ROOT}$(get_gtk_confdir)/gtk.immodules
+}