summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-12-06 13:53:04 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-12-06 13:53:04 +0000
commit7752122897bd8f85cab4dd7495b153f64c9eb91b (patch)
tree4325bf18f652c9e0cc415c6016086dca4cea6b68 /app-i18n
parentCall econf with --disable-maintainer-mode option. Replace remaining echo comm... (diff)
downloadgentoo-2-7752122897bd8f85cab4dd7495b153f64c9eb91b.tar.gz
gentoo-2-7752122897bd8f85cab4dd7495b153f64c9eb91b.tar.bz2
gentoo-2-7752122897bd8f85cab4dd7495b153f64c9eb91b.zip
Completely port ebuild to autotools-utils.eclass, bug 392085. Thanks to Stas
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/enca/ChangeLog7
-rw-r--r--app-i18n/enca/enca-1.13-r2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-i18n/enca/ChangeLog b/app-i18n/enca/ChangeLog
index 306da6e255bb..d60002bb26ba 100644
--- a/app-i18n/enca/ChangeLog
+++ b/app-i18n/enca/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/enca
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/ChangeLog,v 1.70 2011/10/04 15:56:27 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/ChangeLog,v 1.71 2011/12/06 13:53:04 maksbotan Exp $
+
+*enca-1.13-r2 (06 Dec 2011)
+
+ 06 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> +enca-1.13-r2.ebuild:
+ Completely port ebuild to autotools-utils.eclass, bug 392085. Thanks to Stas
*enca-1.13-r1 (04 Oct 2011)
diff --git a/app-i18n/enca/enca-1.13-r2.ebuild b/app-i18n/enca/enca-1.13-r2.ebuild
new file mode 100644
index 000000000000..45aab5b085f3
--- /dev/null
+++ b/app-i18n/enca/enca-1.13-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/enca-1.13-r2.ebuild,v 1.1 2011/12/06 13:53:04 maksbotan Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs autotools-utils
+
+DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
+HOMEPAGE="http://gitorious.org/enca"
+SRC_URI="http://dl.cihar.com/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc +recode"
+
+DEPEND="recode? ( >=app-text/recode-3.6_p15 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-external
+ --disable-static
+ $(use_with recode librecode "${EPREFIX}"/usr)
+ $(use_enable doc gtk-doc)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ if tc-is-cross-compiler; then
+ pushd tools > /dev/null
+ $(tc-getBUILD_CC) -o make_hash make_hash.c || die "native make_hash failed"
+ popd > /dev/null
+ fi
+ autotools-utils_src_compile
+}
+
+src_install() {
+ autotools-utils_src_install
+}