summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-04-11 22:43:30 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-04-11 22:43:30 +0000
commitbcd23f287ed21e3f408524f89df38320e42b0c3c (patch)
treea0c01c9fbdd0843fec64e122f39b3d96a1988a51 /app-i18n
parentversion bump (diff)
downloadgentoo-2-bcd23f287ed21e3f408524f89df38320e42b0c3c.tar.gz
gentoo-2-bcd23f287ed21e3f408524f89df38320e42b0c3c.tar.bz2
gentoo-2-bcd23f287ed21e3f408524f89df38320e42b0c3c.zip
Version bumped.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/nkf/ChangeLog7
-rw-r--r--app-i18n/nkf/Manifest6
-rw-r--r--app-i18n/nkf/files/digest-nkf-2.0.51
-rw-r--r--app-i18n/nkf/nkf-2.0.5.ebuild44
4 files changed, 55 insertions, 3 deletions
diff --git a/app-i18n/nkf/ChangeLog b/app-i18n/nkf/ChangeLog
index d1abe8ecf828..62c463778cb3 100644
--- a/app-i18n/nkf/ChangeLog
+++ b/app-i18n/nkf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/nkf
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.21 2005/01/01 14:36:38 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.22 2005/04/11 22:43:30 matsuu Exp $
+
+*nkf-2.0.5 (11 Apr 2005)
+
+ 11 Apr 2005; MATSUU Takuto <matsuu@gentoo.org> +nkf-2.0.5.ebuild:
+ Version bumped.
23 Nov 2004; Akinori Hattori <hattya@gentoo.org> nkf-2.0.4.ebuild:
stable on ia64.
diff --git a/app-i18n/nkf/Manifest b/app-i18n/nkf/Manifest
index c268344f9cef..6605127d13e6 100644
--- a/app-i18n/nkf/Manifest
+++ b/app-i18n/nkf/Manifest
@@ -1,6 +1,8 @@
+MD5 45ef483a748c2ea6333098ab54cc8eaa nkf-2.0.4.ebuild 1019
+MD5 cc6f9b15d524cd51b550a4b06396727d nkf-2.0.2-r1.ebuild 1013
+MD5 e252e42e0a02b323f534a8373db3207d nkf-2.0.5.ebuild 1026
MD5 6809f81b3d3aba46afd4ea864d1449d6 ChangeLog 2235
MD5 e92a48548554c80cf90e18df17ff6a82 metadata.xml 156
-MD5 cc6f9b15d524cd51b550a4b06396727d nkf-2.0.2-r1.ebuild 1013
-MD5 45ef483a748c2ea6333098ab54cc8eaa nkf-2.0.4.ebuild 1019
MD5 846425777c3e9f5dcb205262a1548d7a files/digest-nkf-2.0.4 58
+MD5 36914cd105ffe822ba5703b3c521be30 files/digest-nkf-2.0.5 58
MD5 9cb8e05b1ef22ec8e3e5e7ad852e0f9c files/digest-nkf-2.0.2-r1 57
diff --git a/app-i18n/nkf/files/digest-nkf-2.0.5 b/app-i18n/nkf/files/digest-nkf-2.0.5
new file mode 100644
index 000000000000..47552ab72d5e
--- /dev/null
+++ b/app-i18n/nkf/files/digest-nkf-2.0.5
@@ -0,0 +1 @@
+MD5 e34d936b20aaf581da5759fbaf0438f3 nkf205.tar.gz 149809
diff --git a/app-i18n/nkf/nkf-2.0.5.ebuild b/app-i18n/nkf/nkf-2.0.5.ebuild
new file mode 100644
index 000000000000..adbdae0901ee
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.5.ebuild,v 1.1 2005/04/11 22:43:30 matsuu Exp $
+
+inherit gcc perl-module
+
+MY_P="${PN}${PV//./}"
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+SRC_URI="http://www01.tcp-ip.or.jp/~furukawa/nkf_utf8/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc64 ~ia64"
+IUSE="perl cjk"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" nkf || die
+ if use perl; then
+ cd ${S}/NKF.mod
+ perl-module_src_compile
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ dobin nkf || die
+ doman nkf.1
+ if use cjk; then
+ dodir /usr/share/man/ja/man1
+ insinto /usr/share/man/ja/man1
+ ./nkf -e nkf.1j > nkf.1
+ doins nkf.1
+ fi
+ dodoc INSTALL* nkf.doc
+ if use perl; then
+ cd ${S}/NKF.mod
+ perl-module_src_install
+ fi
+}