summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-10-15 16:03:27 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-10-15 16:03:27 +0000
commitdb213d4226973a18b28f3ea555f278cf2e042e14 (patch)
treed79766825981a1fd83e72a629c60327f191c16e9 /app-i18n
parentStabilizing on ia64 as part of new Java system, bug #147254. (diff)
downloadgentoo-2-db213d4226973a18b28f3ea555f278cf2e042e14.tar.gz
gentoo-2-db213d4226973a18b28f3ea555f278cf2e042e14.tar.bz2
gentoo-2-db213d4226973a18b28f3ea555f278cf2e042e14.zip
Version bumped.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-anthy/ChangeLog7
-rw-r--r--app-i18n/scim-anthy/files/digest-scim-anthy-1.2.13
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild56
3 files changed, 65 insertions, 1 deletions
diff --git a/app-i18n/scim-anthy/ChangeLog b/app-i18n/scim-anthy/ChangeLog
index 158cf45cb098..bf04b8710d4b 100644
--- a/app-i18n/scim-anthy/ChangeLog
+++ b/app-i18n/scim-anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim-anthy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.33 2006/08/06 16:10:06 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.34 2006/10/15 16:03:27 matsuu Exp $
+
+*scim-anthy-1.2.1 (15 Oct 2006)
+
+ 15 Oct 2006; MATSUU Takuto <matsuu@gentoo.org> +scim-anthy-1.2.1.ebuild:
+ Version bumped.
*scim-anthy-1.2.0 (06 Aug 2006)
diff --git a/app-i18n/scim-anthy/files/digest-scim-anthy-1.2.1 b/app-i18n/scim-anthy/files/digest-scim-anthy-1.2.1
new file mode 100644
index 000000000000..87b9c98df985
--- /dev/null
+++ b/app-i18n/scim-anthy/files/digest-scim-anthy-1.2.1
@@ -0,0 +1,3 @@
+MD5 e66e4b85de97fa421d79893d226aeb44 scim-anthy-1.2.1.tar.gz 643824
+RMD160 0eba8daa92f6c972de39a5084f5d11298835e73d scim-anthy-1.2.1.tar.gz 643824
+SHA256 4732dba156b38f9c7f2171dc16118a79bfc6f50e99dbe4efb3b24e731bbe8fe2 scim-anthy-1.2.1.tar.gz 643824
diff --git a/app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild b/app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild
new file mode 100644
index 000000000000..874adb7c6b13
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild,v 1.1 2006/10/15 16:03:27 matsuu Exp $
+
+inherit libtool
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/21967/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+DEPEND="|| ( >=app-i18n/scim-1.2 >=app-i18n/scim-cvs-1.2 )
+ || ( >=app-i18n/anthy-5900 >=app-i18n/anthy-ss-5911 )
+ nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}
+ app-dicts/kasumi"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS THANKS README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM, you should use the following in your user startup scripts"
+ einfo "such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo "export GTK_IM_MODULE=scim"
+ einfo "export QT_IM_MODULE=scim"
+ einfo
+}