summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-12-08 11:31:57 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-12-08 11:31:57 +0000
commite8dc79f31b398ccfd10f6d43f02530e010b21b8b (patch)
tree65a6891dd48ce5b6b3d8153f7f48c03db705c1fe /app-i18n
parentVersion bump. (diff)
downloadgentoo-2-e8dc79f31b398ccfd10f6d43f02530e010b21b8b.tar.gz
gentoo-2-e8dc79f31b398ccfd10f6d43f02530e010b21b8b.tar.bz2
gentoo-2-e8dc79f31b398ccfd10f6d43f02530e010b21b8b.zip
Fixed gcc-4.3 issue, bug #295733. clean up.
(Portage version: 2.1.7.11/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-wnn/ChangeLog10
-rw-r--r--app-i18n/scim-wnn/files/scim-wnn-1.0.0-gcc43.patch22
-rw-r--r--app-i18n/scim-wnn/scim-wnn-1.0.0-r1.ebuild58
3 files changed, 88 insertions, 2 deletions
diff --git a/app-i18n/scim-wnn/ChangeLog b/app-i18n/scim-wnn/ChangeLog
index 050c816e3ab0..8ab1232b0d89 100644
--- a/app-i18n/scim-wnn/ChangeLog
+++ b/app-i18n/scim-wnn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/scim-wnn
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wnn/ChangeLog,v 1.10 2007/01/05 16:32:48 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wnn/ChangeLog,v 1.11 2009/12/08 11:31:57 matsuu Exp $
+
+*scim-wnn-1.0.0-r1 (08 Dec 2009)
+
+ 08 Dec 2009; MATSUU Takuto <matsuu@gentoo.org> +scim-wnn-1.0.0-r1.ebuild,
+ +files/scim-wnn-1.0.0-gcc43.patch:
+ Fixed gcc-4.3 issue, bug #295733. clean up.
05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> scim-wnn-0.2.4.ebuild,
scim-wnn-1.0.0.ebuild:
diff --git a/app-i18n/scim-wnn/files/scim-wnn-1.0.0-gcc43.patch b/app-i18n/scim-wnn/files/scim-wnn-1.0.0-gcc43.patch
new file mode 100644
index 000000000000..489f2d9064e2
--- /dev/null
+++ b/app-i18n/scim-wnn/files/scim-wnn-1.0.0-gcc43.patch
@@ -0,0 +1,22 @@
+diff -Naur scim-wnn-1.0.0.orig/src/scim_wnn_imengine_setup.cpp scim-wnn-1.0.0/src/scim_wnn_imengine_setup.cpp
+--- scim-wnn-1.0.0.orig/src/scim_wnn_imengine_setup.cpp 2006-03-28 12:07:31.000000000 +0900
++++ scim-wnn-1.0.0/src/scim_wnn_imengine_setup.cpp 2009-12-08 19:32:27.000000000 +0900
+@@ -26,6 +26,7 @@
+
+ #define Uses_SCIM_CONFIG_BASE
+
++#include <cstring>
+ #include <gtk/gtk.h>
+
+ #ifdef HAVE_CONFIG_H
+diff -Naur scim-wnn-1.0.0.orig/src/wnnconversion.cpp scim-wnn-1.0.0/src/wnnconversion.cpp
+--- scim-wnn-1.0.0.orig/src/wnnconversion.cpp 2006-03-28 11:34:46.000000000 +0900
++++ scim-wnn-1.0.0/src/wnnconversion.cpp 2009-12-08 19:50:26.000000000 +0900
+@@ -17,6 +17,7 @@
+ * Free Software Foundation, Inc., *
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
++#include <cstring>
+ #include "wnnconversion.h"
+ #include <scim_wnn_def.h>
+
diff --git a/app-i18n/scim-wnn/scim-wnn-1.0.0-r1.ebuild b/app-i18n/scim-wnn/scim-wnn-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..0f6bd6d7a3ce
--- /dev/null
+++ b/app-i18n/scim-wnn/scim-wnn-1.0.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wnn/scim-wnn-1.0.0-r1.ebuild,v 1.1 2009/12/08 11:31:57 matsuu Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Japanese input method Wnn IMEngine for SCIM"
+HOMEPAGE="http://nop.net-p.org/modules/pukiwiki/index.php?%5B%5Bscim-wnn%5D%5D"
+SRC_URI="http://nop.net-p.org/files/scim-wnn/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+freewnn"
+
+RDEPEND=">=app-i18n/scim-1.4
+ dev-libs/wnn7sdk
+ freewnn? ( app-i18n/freewnn )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ # bug #140794
+ sed -i -e 's:$LDFLAGS conftest.$ac_ext $LIBS:conftest.$ac_ext $LIBS $LDFLAGS:g' \
+ configure || die "ldflags sed failed"
+
+# sed -i -e "s:/usr/lib/wnn7:/usr/$(get_libdir)/wnn:g" \
+ sed -i -e "s:/usr/lib/wnn7:/usr/lib/wnn:g" \
+ src/scim_wnn_def.h src/wnnconversion.cpp || die "sed failed"
+
+ # bug #295733
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog
+ if ! use freewnn ; then
+ ewarn
+ ewarn "You disabled freewnn USE flag."
+ ewarn "Please make sure you have wnnenvrc visible to scim-wnn."
+ ewarn
+ fi
+}