summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-01 11:03:09 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-01 11:03:09 +0000
commit3a4912d7de226d300eaac37006f889c4e1ab8d6f (patch)
tree2e9d926f1231c250efd07df0840e62ca5b204a35 /app-laptop/i8kutils
parentBumping to 5.0.0 (diff)
downloadgentoo-2-3a4912d7de226d300eaac37006f889c4e1ab8d6f.tar.gz
gentoo-2-3a4912d7de226d300eaac37006f889c4e1ab8d6f.tar.bz2
gentoo-2-3a4912d7de226d300eaac37006f889c4e1ab8d6f.zip
app-laptop/i8kutils: Version BUmp, Correct HOMEPAGE, correct SRC_URI; respect CFLAGS, #240015; respect LDFLAGS, #337349; respect CC, #243602; handle examples installation through USE; move to EAPI=4
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop/i8kutils')
-rw-r--r--app-laptop/i8kutils/ChangeLog11
-rw-r--r--app-laptop/i8kutils/i8kutils-1.25-r1.ebuild43
-rw-r--r--app-laptop/i8kutils/i8kutils-1.25.ebuild22
-rw-r--r--app-laptop/i8kutils/i8kutils-1.33.ebuild54
4 files changed, 104 insertions, 26 deletions
diff --git a/app-laptop/i8kutils/ChangeLog b/app-laptop/i8kutils/ChangeLog
index 69284364b08b..dcebb564b174 100644
--- a/app-laptop/i8kutils/ChangeLog
+++ b/app-laptop/i8kutils/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for app-laptop/i8kutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/ChangeLog,v 1.18 2012/07/01 10:42:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/ChangeLog,v 1.19 2012/07/01 11:03:09 jlec Exp $
+
+*i8kutils-1.33 (01 Jul 2012)
+
+ 01 Jul 2012; Justin Lecher <jlec@gentoo.org> i8kutils-1.25.ebuild,
+ i8kutils-1.25-r1.ebuild, +i8kutils-1.33.ebuild:
+ Version BUmp, Correct HOMEPAGE, correct SRC_URI; respect CFLAGS, #240015;
+ respect LDFLAGS, #337349; respect CC, #243602; handle examples installation
+ through USE; move to EAPI=4
01 Jul 2012; Justin Lecher <jlec@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
-
also needs to contain m-needed@g.o.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> i8kutils-1.25.ebuild,
diff --git a/app-laptop/i8kutils/i8kutils-1.25-r1.ebuild b/app-laptop/i8kutils/i8kutils-1.25-r1.ebuild
index 4767f0cbe02b..0b196effe7bc 100644
--- a/app-laptop/i8kutils/i8kutils-1.25-r1.ebuild
+++ b/app-laptop/i8kutils/i8kutils-1.25-r1.ebuild
@@ -1,17 +1,34 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/i8kutils-1.25-r1.ebuild,v 1.3 2010/01/01 21:09:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/i8kutils-1.25-r1.ebuild,v 1.4 2012/07/01 11:03:09 jlec Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
DESCRIPTION="Dell Inspiron and Latitude utilities"
-HOMEPAGE="http://people.debian.org/~dz/i8k/"
+HOMEPAGE="http://packages.debian.org/sid/i8kutils"
SRC_URI="http://people.debian.org/~dz/i8k/${P/-/_}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE="tk"
+IUSE="examples tk"
+
+DEPEND="tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.i8kutils )
-DEPEND="tk? ( >=dev-lang/tk-8.3.3 )"
+src_prepare() {
+ sed \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/d' \
+ -e 's: -g : $(LDFLAGS) :g' \
+ -i Makefile || die
+
+ tc-export CC
+}
src_compile() {
make all || die
@@ -21,23 +38,21 @@ src_install() {
dobin i8kbuttons i8kctl
doman i8kbuttons.1 i8kctl.1
dosym /usr/bin/i8kctl /usr/bin/i8kfan
- dodoc README.i8kutils
- docinto examples/
- dodoc examples/*
+
+ use examples && dodoc -r examples
newinitd "${FILESDIR}"/i8k.init-r1 i8k
newconfd "${FILESDIR}"/i8k.conf i8k
- if use tk
- then
+ if use tk; then
dobin i8kmon
doman i8kmon.1
- docinto /
dodoc i8kmon.conf
else
- echo >> ${D}/etc/conf.d/i8k
- echo '# i8kmon disabled because the package was installed without USE=tk' >> ${D}/etc/conf.d/i8k
- echo 'NOMON=1' >> ${D}/etc/conf.d/i8k
+ cat >> "${ED}"/etc/conf.d/i8k <<- EOF
+ # i8kmon disabled because the package was installed without USE=tk
+ NOMON=1
+ EOF
fi
}
diff --git a/app-laptop/i8kutils/i8kutils-1.25.ebuild b/app-laptop/i8kutils/i8kutils-1.25.ebuild
index de500093eda4..3e308560b71c 100644
--- a/app-laptop/i8kutils/i8kutils-1.25.ebuild
+++ b/app-laptop/i8kutils/i8kutils-1.25.ebuild
@@ -1,17 +1,20 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/i8kutils-1.25.ebuild,v 1.13 2010/01/01 21:09:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/i8kutils-1.25.ebuild,v 1.14 2012/07/01 11:03:09 jlec Exp $
+
+EAPI=4
DESCRIPTION="Dell Inspiron and Latitude utilities"
-HOMEPAGE="http://people.debian.org/~dz/i8k/"
+HOMEPAGE="http://packages.debian.org/sid/i8kutils"
SRC_URI="http://people.debian.org/~dz/i8k/${P/-/_}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-* x86 amd64"
+KEYWORDS="-* amd64 x86"
IUSE="tk"
-DEPEND="tk? ( >=dev-lang/tk-8.3.3 )"
+DEPEND="tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}"
src_compile() {
make all || die
@@ -28,16 +31,15 @@ src_install() {
newinitd "${FILESDIR}"/i8k.init i8k
newconfd "${FILESDIR}"/i8k.conf i8k
- if use tk
- then
+ if use tk; then
dobin i8kmon
doman i8kmon.1
docinto /
dodoc i8kmon.conf
else
- echo >> ${D}/etc/conf.d/i8k
- echo '# i8kmon disabled because the package was installed without USE=tk' >> ${D}/etc/conf.d/i8k
- echo 'NOMON=1' >> ${D}/etc/conf.d/i8k
+ echo >> "${ED}"/etc/conf.d/i8k
+ echo '# i8kmon disabled because the package was installed without USE=tk' >> "${ED}"/etc/conf.d/i8k
+ echo 'NOMON=1' >> "${ED}"/etc/conf.d/i8k
fi
}
diff --git a/app-laptop/i8kutils/i8kutils-1.33.ebuild b/app-laptop/i8kutils/i8kutils-1.33.ebuild
new file mode 100644
index 000000000000..22e598a95f3d
--- /dev/null
+++ b/app-laptop/i8kutils/i8kutils-1.33.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/i8kutils-1.33.ebuild,v 1.1 2012/07/01 11:03:09 jlec Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Dell Inspiron and Latitude utilities"
+HOMEPAGE="http://packages.debian.org/sid/i8kutils"
+SRC_URI="mirror://debian/pool/main/i/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="examples tk"
+
+DEPEND="tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.i8kutils )
+
+src_prepare() {
+ sed \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/d' \
+ -e 's: -g : $(LDFLAGS) :g' \
+ -i Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin i8kbuttons i8kctl
+ doman i8kbuttons.1 i8kctl.1
+ dosym /usr/bin/i8kctl /usr/bin/i8kfan
+
+ use examples && dodoc -r examples
+
+ newinitd "${FILESDIR}"/i8k.init-r1 i8k
+ newconfd "${FILESDIR}"/i8k.conf i8k
+
+ if use tk; then
+ dobin i8kmon
+ doman i8kmon.1
+ dodoc i8kmon.conf
+ else
+ cat >> "${ED}"/etc/conf.d/i8k <<- EOF
+ # i8kmon disabled because the package was installed without USE=tk
+ NOMON=1
+ EOF
+ fi
+
+}