summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-07-19 18:36:33 +0000
committerChristoph Mende <angelos@gentoo.org>2011-07-19 18:36:33 +0000
commite0c188e4bfe5a0edd8485bd9bce5f750ea07b6f0 (patch)
treea61ef03e340718fb4e5fd46647b001619d52251c /app-laptop/nvidiabl
parentMissing dev-util/pkgconfig DEPEND wrt #373617 by Malte Starostik (diff)
downloadgentoo-2-e0c188e4bfe5a0edd8485bd9bce5f750ea07b6f0.tar.gz
gentoo-2-e0c188e4bfe5a0edd8485bd9bce5f750ea07b6f0.tar.bz2
gentoo-2-e0c188e4bfe5a0edd8485bd9bce5f750ea07b6f0.zip
Version bump
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop/nvidiabl')
-rw-r--r--app-laptop/nvidiabl/ChangeLog7
-rw-r--r--app-laptop/nvidiabl/nvidiabl-0.70.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/app-laptop/nvidiabl/ChangeLog b/app-laptop/nvidiabl/ChangeLog
index 64bce2ba3ad5..40ac85d9acf3 100644
--- a/app-laptop/nvidiabl/ChangeLog
+++ b/app-laptop/nvidiabl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/nvidiabl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/nvidiabl/ChangeLog,v 1.4 2011/04/30 15:37:40 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/nvidiabl/ChangeLog,v 1.5 2011/07/19 18:36:33 angelos Exp $
+
+*nvidiabl-0.70 (19 Jul 2011)
+
+ 19 Jul 2011; Christoph Mende <angelos@gentoo.org> +nvidiabl-0.70.ebuild:
+ Version bump
30 Apr 2011; Christoph Mende <angelos@gentoo.org> -nvidiabl-0.67.ebuild:
Remove old
diff --git a/app-laptop/nvidiabl/nvidiabl-0.70.ebuild b/app-laptop/nvidiabl/nvidiabl-0.70.ebuild
new file mode 100644
index 000000000000..a301909d94c7
--- /dev/null
+++ b/app-laptop/nvidiabl/nvidiabl-0.70.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/nvidiabl/nvidiabl-0.70.ebuild,v 1.1 2011/07/19 18:36:33 angelos Exp $
+
+EAPI=3
+inherit linux-mod
+
+DESCRIPTION="Linux driver for setting the backlight brightness on laptops using
+NVIDIA GPU"
+HOMEPAGE="https://github.com/guillaumezin/nvidiabl"
+SRC_URI="https://github.com/downloads/guillaumezin/${PN}/${P}-source-only.dkms.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+BUILD_TARGETS="modules"
+MODULE_NAMES="nvidiabl()"
+CONFIG_CHECK="FB_BACKLIGHT"
+
+S=${WORKDIR}/dkms_source_tree
+
+src_compile() {
+ BUILD_PARAMS="KVER=${KV_FULL}"
+ linux-mod_src_compile
+}