summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2005-08-11 00:59:09 +0000
committerOlivier Crête <tester@gentoo.org>2005-08-11 00:59:09 +0000
commitdfa0feb6b4e7a136ecbe51ce03bdb97c7c6598a4 (patch)
tree0ac1352d7c78a046c0e28c53825de23e51c583f3 /app-laptop/pbbuttonsd
parentstable on alpha (diff)
downloadgentoo-2-dfa0feb6b4e7a136ecbe51ce03bdb97c7c6598a4.tar.gz
gentoo-2-dfa0feb6b4e7a136ecbe51ce03bdb97c7c6598a4.tar.bz2
gentoo-2-dfa0feb6b4e7a136ecbe51ce03bdb97c7c6598a4.zip
Added acpi use flag for x86 and added ~x86 keywords, bug #87222 and #86566
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog5
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild20
2 files changed, 20 insertions, 5 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index b6eb2096b964..cd85d6bf96ae 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.29 2005/07/19 18:14:51 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.30 2005/08/11 00:59:09 tester Exp $
+
+ 11 Aug 2005; Olivier Crête <tester@gentoo.org> pbbuttonsd-0.7.1.ebuild:
+ Added acpi use flag for x86 and added ~x86 keywords, bug #87222 and #86566
*pbbuttonsd-0.7.1 (19 Jul 2005)
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild
index 08b50b2be1a5..e9e99229ef53 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild,v 1.1 2005/07/19 18:14:51 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild,v 1.2 2005/08/11 00:59:09 tester Exp $
inherit eutils linux-info
@@ -10,8 +10,8 @@ SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc"
-IUSE=""
+KEYWORDS="~ppc ~x86"
+IUSE="acpi"
DEPEND="virtual/libc
>=sys-apps/baselayout-1.8.6.12-r1"
@@ -24,7 +24,17 @@ src_compile() {
die "Kernel not compiled with CONFIG_INPUT_EVDEV support"
fi
- econf || die "Sorry, failed to configure pbbuttonsd"
+ if use x86; then
+ if use acpi; then
+ laptop=acpi
+ else
+ laptop=i386
+ fi
+ else
+ laptop=powerbook
+ fi
+
+ econf laptop=$laptop || die "Sorry, failed to configure pbbuttonsd"
emake || die "Sorry, failed to compile pbbuttonsd"
}
@@ -42,10 +52,12 @@ pkg_postinst() {
ewarn "pbbuttonsd won't work."
fi
+ if use ppc; then
einfo
einfo "This version of pbbuttonsd can replace PMUD functionality."
einfo "If you want PMUD installed and running, you should set"
einfo "replace_pmud=no in /etc/pbbuttonsd.conf. Otherwise you can"
einfo "try setting replace_pmud=yes in /etc/pbbuttonsd.conf and"
einfo "disabling PMUD"
+ fi
}