summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-12-21 13:24:00 +0000
committerCédric Krier <cedk@gentoo.org>2008-12-21 13:24:00 +0000
commit2b3471e3279fa0f6947221419dd2aca76b863e59 (patch)
tree6303f42f7da281ad94dda36c3dc4e6632fc8767a /app-laptop/pommed
parentRemove unnecessary GTK+-2 defines, and add a missing one for bug 247725, than... (diff)
downloadgentoo-2-2b3471e3279fa0f6947221419dd2aca76b863e59.tar.gz
gentoo-2-2b3471e3279fa0f6947221419dd2aca76b863e59.tar.bz2
gentoo-2-2b3471e3279fa0f6947221419dd2aca76b863e59.zip
Fix build with --as-needed for bug #246900
(Portage version: 2.1.4.5)
Diffstat (limited to 'app-laptop/pommed')
-rw-r--r--app-laptop/pommed/ChangeLog8
-rw-r--r--app-laptop/pommed/files/pommed-1.21-r1.patch75
-rw-r--r--app-laptop/pommed/pommed-1.21-r1.ebuild101
3 files changed, 183 insertions, 1 deletions
diff --git a/app-laptop/pommed/ChangeLog b/app-laptop/pommed/ChangeLog
index 14ea54925956..60cff94c003e 100644
--- a/app-laptop/pommed/ChangeLog
+++ b/app-laptop/pommed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/pommed
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pommed/ChangeLog,v 1.36 2008/11/01 18:41:42 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pommed/ChangeLog,v 1.37 2008/12/21 13:23:59 cedk Exp $
+
+*pommed-1.21-r1 (21 Dec 2008)
+
+ 21 Dec 2008; Cédric Krier <cedk@gentoo.org> +files/pommed-1.21-r1.patch,
+ +pommed-1.21-r1.ebuild:
+ Fix build with --as-needed for bug #246900
01 Nov 2008; nixnut <nixnut@gentoo.org> pommed-1.21.ebuild:
Stable on ppc wrt bug 244531
diff --git a/app-laptop/pommed/files/pommed-1.21-r1.patch b/app-laptop/pommed/files/pommed-1.21-r1.patch
new file mode 100644
index 000000000000..5b899a369f1b
--- /dev/null
+++ b/app-laptop/pommed/files/pommed-1.21-r1.patch
@@ -0,0 +1,75 @@
+diff -ru pommed-1.21~/gpomme/Makefile pommed-1.21/gpomme/Makefile
+--- pommed-1.21~/gpomme/Makefile 2008-12-21 13:38:27.000000000 +0100
++++ pommed-1.21/gpomme/Makefile 2008-12-21 14:06:46.000000000 +0100
+@@ -17,8 +17,8 @@
+
+ INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
+-LDFLAGS = -lpthread $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS) $(GLADE_LIBS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
++LDFLAGS += -lpthread $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS) $(GLADE_LIBS)
+
+ SOURCES = gpomme.c theme.c conffile.c \
+ ../client-common/dbus-client.c \
+@@ -33,6 +33,7 @@
+ mo: $(MOFILES)
+
+ gpomme: $(OBJS) $(LIBS)
++ ${CC} -o $@ ${OBJS} ${LIBS} ${LDFLAGS}
+
+ gpomme.o: gpomme.c gpomme.h theme.h ../client-common/dbus-client.h ../client-common/video-client.h
+
+diff -ru pommed-1.21~/pommed/Makefile pommed-1.21/pommed/Makefile
+--- pommed-1.21~/pommed/Makefile 2008-12-21 13:38:27.000000000 +0100
++++ pommed-1.21/pommed/Makefile 2008-12-21 14:04:52.000000000 +0100
+@@ -16,9 +16,9 @@
+
+ INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS)
+
+-LDFLAGS = -pthread -lrt $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
++LDFLAGS += -pthread -lrt $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
+
+ ifneq (, $(findstring ppc, $(ARCH)))
+ OFLIB ?=
+@@ -50,6 +50,7 @@
+
+ CFLAGS += $(LIBPCI_CFLAGS)
+ LDFLAGS += $(LIBPCI_LIBS)
++ LIBS = $(LIBPCI_LIBS)
+ else
+ LIBS = /usr/lib/libpci.a
+ LDFLAGS += -lz
+@@ -66,6 +67,7 @@
+
+
+ pommed: $(OBJS) $(LIBS)
++ ${CC} -o $@ ${OBJS} ${LIBS} ${LDFLAGS}
+
+ pommed.o: pommed.c pommed.h evloop.h kbd_backlight.h lcd_backlight.h cd_eject.h evdev.h conffile.h audio.h dbus.h beep.h
+
+diff -ru pommed-1.21~/wmpomme/Makefile pommed-1.21/wmpomme/Makefile
+--- pommed-1.21~/wmpomme/Makefile 2008-12-21 13:38:27.000000000 +0100
++++ pommed-1.21/wmpomme/Makefile 2008-12-21 14:07:09.000000000 +0100
+@@ -3,8 +3,8 @@
+ DBUS_CFLAGS = $(shell pkg-config dbus-1 --cflags) -DDBUS_API_SUBJECT_TO_CHANGE
+ DBUS_LIBS = $(shell pkg-config dbus-1 --libs)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS)
+-LDFLAGS = -lXpm -lXext -lX11 $(DBUS_LIBS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS)
++LDFLAGS += -lXpm -lXext -lX11 $(DBUS_LIBS)
+
+ SOURCES = wmgeneral.c wmpomme.c \
+ ../client-common/dbus-client.c \
+@@ -13,6 +13,7 @@
+ OBJS = $(SOURCES:%.c=%.o)
+
+ wmpomme: $(OBJS)
++ ${CC} -o $@ ${OBJS} ${LDFLAGS}
+
+ wmpomme.o: wmpomme.c wmgeneral.h wmpomme-master.xpm ../client-common/dbus-client.h
+
diff --git a/app-laptop/pommed/pommed-1.21-r1.ebuild b/app-laptop/pommed/pommed-1.21-r1.ebuild
new file mode 100644
index 000000000000..bfa0b097a156
--- /dev/null
+++ b/app-laptop/pommed/pommed-1.21-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pommed/pommed-1.21-r1.ebuild,v 1.1 2008/12/21 13:23:59 cedk Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Manage special features such as screen and keyboard backlight on Apple MacBook Pro/PowerBook"
+HOMEPAGE="http://technologeek.org/projects/pommed/index.html"
+ALIOTH_NUMBER="2499"
+SRC_URI="http://alioth.debian.org/frs/download.php/${ALIOTH_NUMBER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk X"
+
+COMMON_DEPEND="media-libs/alsa-lib
+ x86? ( sys-apps/pciutils )
+ amd64? ( sys-apps/pciutils )
+ dev-libs/confuse
+ >=sys-apps/dbus-1.1
+ sys-libs/zlib
+ media-libs/audiofile
+ gtk? ( >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2 )
+ X? ( x11-libs/libX11
+ x11-libs/libXpm )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ media-sound/alsa-utils
+ virtual/eject"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-r1.patch"
+}
+
+src_compile() {
+ cd "${S}"/pommed
+ emake CC="$(tc-getCC)" OFLIB=1 || die "emake pommed failed"
+
+ if use gtk; then
+ cd "${S}"/gpomme
+ local POFILES=""
+ for LANG in ${LINGUAS}; do
+ if [ -f po/${LANG}.po ]; then
+ POFILES="${POFILES} po/${LANG}.po"
+ fi
+ done
+ emake CC="$(tc-getCC)" POFILES="${POFILES}" || die "emake gpomme failed"
+ fi
+ if use X; then
+ cd "${S}"/wmpomme
+ emake CC="$(tc-getCC)" || die "emake wmpomme failed"
+ fi
+}
+
+src_install() {
+ insinto /etc
+ if use x86 || use amd64; then
+ newins pommed.conf.mactel pommed.conf
+ elif use ppc; then
+ newins pommed.conf.pmac pommed.conf
+ fi
+
+ insinto /etc/dbus-1/system.d
+ newins dbus-policy.conf pommed.conf
+
+ insinto /usr/share/pommed
+ doins pommed/data/*.wav
+
+ dobin pommed/pommed
+
+ newinitd "${FILESDIR}"/pommed.rc pommed
+
+ dodoc AUTHORS ChangeLog README TODO
+
+ if use gtk ; then
+ dobin gpomme/gpomme
+ for LANG in ${LINGUAS}; do
+ if [ -f gpomme/po/${LANG}.mo ]; then
+ einfo "Installing lang ${LANG}"
+ insinto /usr/share/locale/${LANG}/LC_MESSAGES/
+ doins gpomme/po/${LANG}.mo
+ fi
+ done
+
+ insinto /usr/share/applications
+ doins gpomme/gpomme.desktop
+ doins gpomme/gpomme-c.desktop
+ insinto /usr/share/gpomme/
+ doins -r gpomme/themes
+ doins gpomme/gpomme.glade
+ fi
+
+ if use X ; then
+ dobin wmpomme/wmpomme
+ fi
+}