summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2006-03-25 11:57:08 +0000
committerStephen Klimaszewski <steev@gentoo.org>2006-03-25 11:57:08 +0000
commit7480e4ffd89c922d051d9ca2f911c5839259ebf2 (patch)
tree93a8e9838d60bb8a73fc79ce1eed18d3888ce727 /app-laptop/thinkpad/thinkpad-5.9-r1.ebuild
parentMark 3.5.1 ~ia64 (diff)
downloadgentoo-2-7480e4ffd89c922d051d9ca2f911c5839259ebf2.tar.gz
gentoo-2-7480e4ffd89c922d051d9ca2f911c5839259ebf2.tar.bz2
gentoo-2-7480e4ffd89c922d051d9ca2f911c5839259ebf2.zip
Revision bump of thinkpad, with patches from TGL <degrenier@easyconnect.fr> to allow compilation with kernel 2.6.16. Closes bug #127453
(Portage version: 2.1_pre6-r6)
Diffstat (limited to 'app-laptop/thinkpad/thinkpad-5.9-r1.ebuild')
-rw-r--r--app-laptop/thinkpad/thinkpad-5.9-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild b/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild
new file mode 100644
index 000000000000..b13764205a3f
--- /dev/null
+++ b/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild,v 1.1 2006/03/25 11:57:08 steev Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Thinkpad system control kernel modules"
+
+HOMEPAGE="http://tpctl.sourceforge.net"
+SRC_URI="mirror://sourceforge/tpctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+BUILD_PARAMS="KSRC=${KV_DIR}"
+
+MODULESD_THINKPAD_DOCS="README"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ case ${KV_MINOR} in
+ 4)
+ BUILD_TARGETS="all"
+ ;;
+ 6)
+ BUILD_TARGETS="default"
+ ;;
+ *)
+ die "Unsupported kernel version."
+ ;;
+ esac
+
+ MODULE_NAMES="thinkpad(thinkpad:${S}/${KV_MAJOR}.${KV_MINOR}/drivers)
+ smapi(thinkpad:${S}/${KV_MAJOR}.${KV_MINOR}/drivers)
+ superio(thinkpad:${S}/${KV_MAJOR}.${KV_MINOR}/drivers)
+ rtcmosram(thinkpad:${S}/${KV_MAJOR}.${KV_MINOR}/drivers)"
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}"/${PN}-5.9-remove-thinkpadapm-argument.patch
+ epatch "${FILESDIR}"/${PN}-5.9-remove-inter_module.patch
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc AUTHORS ChangeLog SUPPORTED-MODELS TECHNOTES
+
+ doman man/*
+}