summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-07-05 12:29:17 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-07-05 12:29:17 +0000
commit05aa0a87622c1a3510b9168a27d087dec7e52ed7 (patch)
tree84e9d23d74971deaa4685e590a1515f0aa9a1902 /app-leechcraft
parentAdd perl-5.20 version (diff)
downloadgentoo-2-05aa0a87622c1a3510b9168a27d087dec7e52ed7.tar.gz
gentoo-2-05aa0a87622c1a3510b9168a27d087dec7e52ed7.tar.bz2
gentoo-2-05aa0a87622c1a3510b9168a27d087dec7e52ed7.zip
Fix dependencies, rename spectre use flag. Thanks to 0xd34df00d.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-monocle/ChangeLog6
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-9999.ebuild30
-rw-r--r--app-leechcraft/lc-monocle/metadata.xml1
3 files changed, 21 insertions, 16 deletions
diff --git a/app-leechcraft/lc-monocle/ChangeLog b/app-leechcraft/lc-monocle/ChangeLog
index e538a1f84c1a..0efa757200f7 100644
--- a/app-leechcraft/lc-monocle/ChangeLog
+++ b/app-leechcraft/lc-monocle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-leechcraft/lc-monocle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.13 2014/04/10 17:58:44 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.14 2014/07/05 12:29:17 maksbotan Exp $
+
+ 05 Jul 2014; Maxim Koltsov <maksbotan@gentoo.org> lc-monocle-9999.ebuild,
+ metadata.xml:
+ Fix dependencies, rename spectre use flag. Thanks to 0xd34df00d.
*lc-monocle-0.6.65 (10 Apr 2014)
diff --git a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
index fe62a29af7d3..2e61a8a38aa2 100644
--- a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
+++ b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild,v 1.3 2013/10/02 09:49:30 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild,v 1.4 2014/07/05 12:29:17 maksbotan Exp $
EAPI="5"
@@ -10,19 +10,18 @@ DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
SLOT="0"
KEYWORDS=""
-IUSE="debug +djvu doc +fb2 +pdf +spectre"
+IUSE="debug +djvu doc +fb2 +mobi +pdf +postscript"
-RDEPEND="~app-leechcraft/lc-core-${PV}
+REQUIRED_USE="postscript? ( pdf )"
+
+CDEPEND="~app-leechcraft/lc-core-${PV}
pdf? ( app-text/poppler[qt4] )
- djvu? ( app-text/djvu )
- spectre? (
- app-text/libspectre
- || (
- app-text/poppler[-lcms]
- <app-text/ghostscript-gpl-9.07
- )
- )"
-DEPEND="${RDEPEND}
+ djvu? ( app-text/djvu )"
+
+RDEPEND="${CDEPEND}
+ postscript? ( app-text/ghostscript-gpl )"
+
+DEPEND="${CDEPEND}
doc? ( app-doc/doxygen[dot] )"
src_configure() {
@@ -30,8 +29,9 @@ src_configure() {
$(cmake-utils_use_enable djvu MONOCLE_SEEN)
$(cmake-utils_use_with doc DOCS)
$(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable mobi MONOCLE_DIK)
$(cmake-utils_use_enable pdf MONOCLE_PDF)
- $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)
+ $(cmake-utils_use_enable postscript MONOCLE_POSTRUS)
)
cmake-utils_src_configure
}
@@ -39,4 +39,4 @@ src_configure() {
src_install() {
cmake-utils_src_install
use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
-}
+} \ No newline at end of file
diff --git a/app-leechcraft/lc-monocle/metadata.xml b/app-leechcraft/lc-monocle/metadata.xml
index 3d219d285c14..9ff1a0285cda 100644
--- a/app-leechcraft/lc-monocle/metadata.xml
+++ b/app-leechcraft/lc-monocle/metadata.xml
@@ -4,6 +4,7 @@
<herd>leechcraft</herd>
<use>
<flag name="fb2">Enable support for FictionBook format</flag>
+ <flag name="mobi">Enable support for MOBI format</flag>
<flag name="spectre">Enable PostScript backend for Monocle using the <pkg>app-text/libspectre</pkg></flag>
</use>
</pkgmetadata>