summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-01-28 12:56:14 +0000
committerSimon Stelling <blubb@gentoo.org>2006-01-28 12:56:14 +0000
commit52d37d1e41c4f94deb7bb14d9e127a504f4456b6 (patch)
tree7f0be7b444f67c52bad5310b70901b144a0f2836 /app-misc/cdctl
parentVervion bump (0.96). Also changing ebuild 0.96b-r1 into 0.96_beta (diff)
downloadgentoo-2-52d37d1e41c4f94deb7bb14d9e127a504f4456b6.tar.gz
gentoo-2-52d37d1e41c4f94deb7bb14d9e127a504f4456b6.tar.bz2
gentoo-2-52d37d1e41c4f94deb7bb14d9e127a504f4456b6.zip
no need to have a bzipped patch in portage
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-misc/cdctl')
-rw-r--r--app-misc/cdctl/ChangeLog9
-rw-r--r--app-misc/cdctl/cdctl-0.15.ebuild7
-rw-r--r--app-misc/cdctl/files/00_all_Makefile.in.patch.bz2bin672 -> 0 bytes
-rw-r--r--app-misc/cdctl/files/cdctl-0.15-Makefile.in.patch56
4 files changed, 66 insertions, 6 deletions
diff --git a/app-misc/cdctl/ChangeLog b/app-misc/cdctl/ChangeLog
index 0655cf54b01d..e8a2267b003b 100644
--- a/app-misc/cdctl/ChangeLog
+++ b/app-misc/cdctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/cdctl
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cdctl/ChangeLog,v 1.7 2005/04/21 19:05:12 blubb Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdctl/ChangeLog,v 1.8 2006/01/28 12:56:14 blubb Exp $
+
+ 28 Jan 2006; Simon Stelling <blubb@gentoo.org>
+ +files/cdctl-0.15-Makefile.in.patch, -files/00_all_Makefile.in.patch.bz2,
+ cdctl-0.15.ebuild:
+ no need to have a bzipped patch in portage
21 Apr 2005; Simon Stelling <blubb@gentoo.org> cdctl-0.15.ebuild:
stable on amd64
diff --git a/app-misc/cdctl/cdctl-0.15.ebuild b/app-misc/cdctl/cdctl-0.15.ebuild
index 279fd2969f15..5a7381444a6f 100644
--- a/app-misc/cdctl/cdctl-0.15.ebuild
+++ b/app-misc/cdctl/cdctl-0.15.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cdctl/cdctl-0.15.ebuild,v 1.15 2005/04/21 19:05:12 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdctl/cdctl-0.15.ebuild,v 1.16 2006/01/28 12:56:14 blubb Exp $
inherit eutils
-EPATCH_SOURCE=${FILESDIR}
DESCRIPTION="Utility to control your cd/dvd drive"
HOMEPAGE="http://cdctl.sourceforge.net/"
@@ -19,7 +18,7 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
- epatch
+ epatch ${FILESDIR}/${P}-Makefile.in.patch
}
src_install() {
diff --git a/app-misc/cdctl/files/00_all_Makefile.in.patch.bz2 b/app-misc/cdctl/files/00_all_Makefile.in.patch.bz2
deleted file mode 100644
index a0ba05ee3e0a..000000000000
--- a/app-misc/cdctl/files/00_all_Makefile.in.patch.bz2
+++ /dev/null
Binary files differ
diff --git a/app-misc/cdctl/files/cdctl-0.15-Makefile.in.patch b/app-misc/cdctl/files/cdctl-0.15-Makefile.in.patch
new file mode 100644
index 000000000000..6d8e11502fcc
--- /dev/null
+++ b/app-misc/cdctl/files/cdctl-0.15-Makefile.in.patch
@@ -0,0 +1,56 @@
+--- Makefile.in.orig 2003-02-20 21:57:38.000000000 -0800
++++ Makefile.in 2003-02-20 22:27:10.000000000 -0800
+@@ -2,10 +2,12 @@
+ CFLAGS=-Wall -g
+ BINS=cdctl sndreset
+ OBJS=cdctl.o version.o ioctls.o iso_header.o
+-DOCS=NEWS NUTSANDBOLTS LICENSE PUBLICKEY README SEGFAULTS
++DOCS=NEWS NUTSANDBOLTS LICENSE PUBLICKEY README
+ MANS=cdctl.1
+ MOS=cdctl.mo
+
++prefix = @prefix@
++exec_prefix = @exec_prefix@
+ bindir = @bindir@
+ mandir = @mandir@
+ datadir = @datadir@
+@@ -16,6 +18,10 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = $(INSTALL) -m 644
+
++DESTDIR =
++
++man1dir = $(mandir)/man1
++
+ all: $(BINS)
+
+ cdctl: $(OBJS)
+@@ -26,21 +32,21 @@
+ version.o: version.c
+ iso_header.o: iso_header.c
+
+-install: install-bins install-docs install-mans install-mos
++install: install-bins install-mans install-mos
+
+ install-bins: $(BINS)
+- $(INSTALL) -s $(BINS) $(bindir)
+-
+-install-docs: $(DOCS)
+- $(INSTALL_DATA) $(DOCS) $(datadir)
++ $(INSTALL) -d $(DESTDIR)$(bindir)
++ $(INSTALL) $(BINS) $(DESTDIR)$(bindir)
+
+ install-mans: $(MANS)
+- $(INSTALL_DATA) $(MANS) $(mandir)
++ $(INSTALL) -d $(DESTDIR)$(man1dir)
++ $(INSTALL_DATA) $(MANS) $(DESTDIR)$(man1dir)
+
+ # FIXME: need to deal with other languages besides German
+
+ install-mos: cdctl.mo
+- $(INSTALL_DATA) $(MOS) $(localedir)/de/LC_MESSAGES
++ $(INSTALL) -d $(DESTDIR)$(localedir)/de/LC_MESSAGES
++ $(INSTALL_DATA) $(MOS) $(DESTDIR)$(localedir)/de/LC_MESSAGES
+
+ cdctl.mo: cdctl.po
+ msgfmt cdctl.po -o cdctl.mo