summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-07-15 07:44:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-07-15 07:44:37 +0000
commit3255c2e57a7c24147aa50ca7cf9603211e790e9a (patch)
tree41ce8300dc987da3d099c6f3fe1b5cac1a96eb2f /app-misc/ddccontrol
parentwhitespace (diff)
downloadgentoo-2-3255c2e57a7c24147aa50ca7cf9603211e790e9a.tar.gz
gentoo-2-3255c2e57a7c24147aa50ca7cf9603211e790e9a.tar.bz2
gentoo-2-3255c2e57a7c24147aa50ca7cf9603211e790e9a.zip
Bug #163057 - compile fix for zlib'd pciutils. Also fix compile on ppc for in/out/ioperm usage.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-misc/ddccontrol')
-rw-r--r--app-misc/ddccontrol/ChangeLog7
-rw-r--r--app-misc/ddccontrol/ddccontrol-0.4.2.ebuild24
-rw-r--r--app-misc/ddccontrol/files/ddccontrol-0.4.2-pciutils-libz.patch19
3 files changed, 47 insertions, 3 deletions
diff --git a/app-misc/ddccontrol/ChangeLog b/app-misc/ddccontrol/ChangeLog
index 31e76ce7f469..cb8ff4d40f6f 100644
--- a/app-misc/ddccontrol/ChangeLog
+++ b/app-misc/ddccontrol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/ddccontrol
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ddccontrol/ChangeLog,v 1.16 2007/03/01 15:24:14 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ddccontrol/ChangeLog,v 1.17 2007/07/15 07:44:37 robbat2 Exp $
+
+ 15 Jul 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/ddccontrol-0.4.2-pciutils-libz.patch, ddccontrol-0.4.2.ebuild:
+ Bug #163057 - compile fix for zlib'd pciutils. Also fix compile on ppc for
+ in/out/ioperm usage.
01 Mar 2007; Robin H. Johnson <robbat2@gentoo.org> metadata.xml:
Add metadata.xml note that upstream wishes to be CCd on all bugs for this
diff --git a/app-misc/ddccontrol/ddccontrol-0.4.2.ebuild b/app-misc/ddccontrol/ddccontrol-0.4.2.ebuild
index ff8d7afddc32..0a8d087a3323 100644
--- a/app-misc/ddccontrol/ddccontrol-0.4.2.ebuild
+++ b/app-misc/ddccontrol/ddccontrol-0.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ddccontrol/ddccontrol-0.4.2.ebuild,v 1.2 2007/01/04 08:27:14 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ddccontrol/ddccontrol-0.4.2.ebuild,v 1.3 2007/07/15 07:44:37 robbat2 Exp $
inherit eutils autotools
@@ -30,6 +30,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${P}-pciutils-libz.patch
# Fix sandbox violation
for i in Makefile.am Makefile.in; do
@@ -38,8 +39,27 @@ src_unpack() {
|| die "Failed to fix DESTDIR"
done
+ # ppc/ppc64 do not have inb/outb/ioperm
+ # they also do not have (sys|asm)/io.h
+ if [ "${ARCH/64}" == "ppc" ]; then
+ for card in sis intel810 ; do
+ sed -r -i \
+ -e "/${card}.Po/d" \
+ -e "s~${card}[^[:space:]]*~ ~g" \
+ src/ddcpci/Makefile.in
+ sed -r -i \
+ -e "/${card}.Po/d" \
+ -e "s~${card}[^[:space:]]*~ ~g" \
+ src/ddcpci/Makefile.am
+ done
+ sed -i \
+ -e '/sis_/d' \
+ -e '/i810_/d' \
+ src/ddcpci/main.c
+ fi
+
## Save for a rainy day or future patching
- ##eautoreconf || die "eautoreconf failed"
+ eautoreconf || die "eautoreconf failed"
}
src_compile() {
diff --git a/app-misc/ddccontrol/files/ddccontrol-0.4.2-pciutils-libz.patch b/app-misc/ddccontrol/files/ddccontrol-0.4.2-pciutils-libz.patch
new file mode 100644
index 000000000000..8fb602000335
--- /dev/null
+++ b/app-misc/ddccontrol/files/ddccontrol-0.4.2-pciutils-libz.patch
@@ -0,0 +1,19 @@
+Index: configure.ac
+===================================================================
+RCS file: /cvsroot/ddccontrol/ddccontrol/configure.ac,v
+retrieving revision 1.40
+diff -u -r1.40 configure.ac
+--- configure.ac 26 Jul 2006 22:02:15 -0000 1.40
++++ configure.ac 1 Mar 2007 14:49:35 -0000
+@@ -101,7 +101,10 @@
+ DDCPCI=
+ if test x$support_ddcpci = xyes; then
+ AC_CHECK_HEADERS([pci/pci.h], [], [AC_MSG_ERROR([PCI utils headers not found, please install pci-utils.], [1])], [])
+- AC_CHECK_LIB([pci], [pci_alloc], [], [AC_MSG_ERROR([PCI utils library not found, please install pci-utils.], [1])])
++ AC_CHECK_LIB([pci], [pci_alloc], [], [
++ AC_CHECK_LIB([z], [gzopen], [], [AC_MSG_ERROR([PCI utils library not found, please install pci-utils.], [1])])
++ AC_CHECK_LIB([pci], [pci_fill_info], [], [AC_MSG_ERROR([PCI utils library not found, please install pci-utils.], [1])], [-lz])
++ ])
+ DDCPCI=ddcpci
+ AC_DEFINE_UNQUOTED(HAVE_DDCPCI, 1, [Define if ddccontrol is built with ddcpci support.])
+ fi