summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-22 07:27:04 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-22 07:27:04 +0000
commite5e99ee12699c42618e239676fa8b468ec97121b (patch)
tree06ccdd709b051af0a08f1dcd7e8d6febf1a084cc /app-misc/devtodo
parentRemove old. Clean up some patches. (diff)
downloadgentoo-2-e5e99ee12699c42618e239676fa8b468ec97121b.tar.gz
gentoo-2-e5e99ee12699c42618e239676fa8b468ec97121b.tar.bz2
gentoo-2-e5e99ee12699c42618e239676fa8b468ec97121b.zip
app-misc/devtodo: Correctly install bashcompletions, #526250
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-misc/devtodo')
-rw-r--r--app-misc/devtodo/ChangeLog8
-rw-r--r--app-misc/devtodo/devtodo-0.1.20-r1.ebuild4
-rw-r--r--app-misc/devtodo/devtodo-0.1.20-r2.ebuild68
3 files changed, 78 insertions, 2 deletions
diff --git a/app-misc/devtodo/ChangeLog b/app-misc/devtodo/ChangeLog
index 2c56439d4bab..eea62b631bfe 100644
--- a/app-misc/devtodo/ChangeLog
+++ b/app-misc/devtodo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/devtodo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/ChangeLog,v 1.97 2014/03/19 16:40:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/ChangeLog,v 1.98 2014/10/22 07:27:04 jlec Exp $
+
+*devtodo-0.1.20-r2 (22 Oct 2014)
+
+ 22 Oct 2014; Justin Lecher <jlec@gentoo.org> devtodo-0.1.20-r1.ebuild,
+ +devtodo-0.1.20-r2.ebuild:
+ Correctly install bashcompletions, #526250
19 Mar 2014; Justin Lecher <jlec@gentoo.org> -devtodo-0.1.20.ebuild:
Drop old
diff --git a/app-misc/devtodo/devtodo-0.1.20-r1.ebuild b/app-misc/devtodo/devtodo-0.1.20-r1.ebuild
index 1b99319a359b..6a9b249233c2 100644
--- a/app-misc/devtodo/devtodo-0.1.20-r1.ebuild
+++ b/app-misc/devtodo/devtodo-0.1.20-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.20-r1.ebuild,v 1.11 2014/03/19 16:12:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.20-r1.ebuild,v 1.12 2014/10/22 07:27:04 jlec Exp $
EAPI="5"
@@ -57,6 +57,8 @@ src_install() {
newbashcomp contrib/${PN}.bash-completion ${PN}
rm contrib/${PN}.bash-completion || die 'rm failed'
+ bashcomp_alias devtodo tda tdd tde tdr todo
+
dodoc -r contrib
}
diff --git a/app-misc/devtodo/devtodo-0.1.20-r2.ebuild b/app-misc/devtodo/devtodo-0.1.20-r2.ebuild
new file mode 100644
index 000000000000..01f00df63cdf
--- /dev/null
+++ b/app-misc/devtodo/devtodo-0.1.20-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.20-r2.ebuild,v 1.1 2014/10/22 07:27:04 jlec Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils bash-completion-r1 eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A nice command line todo list for developers"
+HOMEPAGE="http://swapoff.org/DevTodo"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog QuickStart README doc/scripts.sh doc/scripts.tcsh doc/todorc.example )
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo.diff"
+ "${FILESDIR}/${P}-gcc43.patch"
+)
+
+src_prepare() {
+ # fix regex.h issue on case-insensitive file-systems #332235
+ sed \
+ -e 's/Regex.h/DTRegex.h/' \
+ -i util/Lexer.h util/Makefile.{am,in} util/Regex.cc || die
+ mv util/{,DT}Regex.h || die
+
+ sed \
+ -e "/^LIBS/s:$: $($(tc-getPKG_CONFIG) --libs ncursesw):g" \
+ -i src/Makefile.am || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ replace-flags -O[23] -O1
+
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}/etc/devtodo"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newbashcomp contrib/${PN}.bash-completion ${PN}
+ rm contrib/${PN}.bash-completion || die 'rm failed'
+
+ bashcomp_alias devtodo tda tdd tde tdr todo
+
+ dodoc -r contrib
+}
+
+pkg_postinst() {
+ elog "Because of a conflict with app-misc/tdl, the tdl symbolic link"
+ elog "and manual page have been removed."
+}