summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-11-26 10:40:22 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-11-26 10:40:22 +0000
commitdd90eb6278e9d4269ecd06ea2b921b050ca8c4ff (patch)
tree1fac44cef592a2ed5ef34f885fd1930647a91603 /app-misc/dnetc/dnetc-2.9001.478.ebuild
parentNew clients and fixes (diff)
downloadgentoo-2-dd90eb6278e9d4269ecd06ea2b921b050ca8c4ff.tar.gz
gentoo-2-dd90eb6278e9d4269ecd06ea2b921b050ca8c4ff.tar.bz2
gentoo-2-dd90eb6278e9d4269ecd06ea2b921b050ca8c4ff.zip
New clients and fixes
Diffstat (limited to 'app-misc/dnetc/dnetc-2.9001.478.ebuild')
-rw-r--r--app-misc/dnetc/dnetc-2.9001.478.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/dnetc/dnetc-2.9001.478.ebuild b/app-misc/dnetc/dnetc-2.9001.478.ebuild
new file mode 100644
index 000000000000..e7dad8fc3631
--- /dev/null
+++ b/app-misc/dnetc/dnetc-2.9001.478.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9001.478.ebuild,v 1.9 2003/11/26 10:40:18 aliz Exp $
+
+MAJ_PV=${PV:0:6}
+MIN_PV=${PV:7:9}
+
+DESCRIPTION="distributed.net client"
+HOMEPAGE="http://www.distributed.net"
+SRC_URI="mips? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}b-ps2linux-mipsel.tar.gz )"
+LICENSE="distributed.net"
+SLOT="0"
+KEYWORDS="~mips"
+IUSE=""
+DEPEND=""
+RDEPEND="net-misc/host"
+if [ `use mips` ]; then
+ S="${WORKDIR}/dnetc${MIN_PV}-ps2linux-mipsel"
+fi
+
+RESTRICT="nomirror"
+
+pkg_preinst() {
+ if [ -e /opt/distributed.net/dnetc ] && [ -e /etc/init.d/dnetc ]; then
+ einfo "flushing old buffers"
+ /opt/distributed.net/dnetc -quiet -flush
+ einfo "removing old buffer files"
+ rm -f /opt/distributed.net/buff*
+ fi
+}
+
+src_install() {
+ exeinto /opt/distributed.net
+ doexe dnetc
+
+ doman dnetc.1
+ dodoc CHANGES.txt dnetc.txt readme.*
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dnetc.init dnetc
+ insinto /etc/conf.d ; newins ${FILESDIR}/dnetc.conf dnetc
+}
+
+pkg_postinst() {
+ einfo "Either configure your email adress in /etc/conf.d/dnetc"
+ einfo "or create the configuration file /opt/distributed.net/dnetc.ini"
+}
+
+pkg_postrm() {
+ if [ -d /opt/distributed.net ]; then
+ einfo "All files has not been removed from /opt/distributed.net"
+ fi
+}