summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-10-12 20:22:20 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-10-12 20:22:20 +0000
commitb147d645eccdc2e168bea8defe130eb72e07c43b (patch)
tree1c126a5a5a865fcdfd1bfeb4500c1bf17ecea472 /app-misc/g15daemon
parentBump to have a live version, needed for G510 keyboard support. (diff)
downloadgentoo-2-b147d645eccdc2e168bea8defe130eb72e07c43b.tar.gz
gentoo-2-b147d645eccdc2e168bea8defe130eb72e07c43b.tar.bz2
gentoo-2-b147d645eccdc2e168bea8defe130eb72e07c43b.zip
More g510 fun. 1.9.5.3-r6 will give you partial support, 9999 will give you full support.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/g15daemon')
-rw-r--r--app-misc/g15daemon/ChangeLog12
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.9.5.3-g510-keys.patch340
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild179
-rw-r--r--app-misc/g15daemon/g15daemon-9999.ebuild191
4 files changed, 720 insertions, 2 deletions
diff --git a/app-misc/g15daemon/ChangeLog b/app-misc/g15daemon/ChangeLog
index 93695377d137..4dec2d581937 100644
--- a/app-misc/g15daemon/ChangeLog
+++ b/app-misc/g15daemon/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/g15daemon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.41 2012/03/08 15:17:35 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.42 2012/10/12 20:22:20 robbat2 Exp $
+
+*g15daemon-1.9.5.3-r6 (12 Oct 2012)
+*g15daemon-9999 (12 Oct 2012)
+
+ 12 Oct 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +files/g15daemon-1.9.5.3-g510-keys.patch, +g15daemon-1.9.5.3-r6.ebuild,
+ +g15daemon-9999.ebuild:
+ More g510 fun. 1.9.5.3-r6 will give you partial support, 9999 will give you
+ full support.
08 Mar 2012; Brent Baude <ranger@gentoo.org> g15daemon-1.9.5.3-r5.ebuild:
Marking g15daemon-1.9.5.3-r5 ppc64 for bug 399941
@@ -220,4 +229,3 @@
+metadata.xml, +g15daemon-1.2.1.ebuild:
Initial import, thanks to Alessio Cassibba in bug #148769 for providing an
ebuild
-
diff --git a/app-misc/g15daemon/files/g15daemon-1.9.5.3-g510-keys.patch b/app-misc/g15daemon/files/g15daemon-1.9.5.3-g510-keys.patch
new file mode 100644
index 000000000000..240f21c385aa
--- /dev/null
+++ b/app-misc/g15daemon/files/g15daemon-1.9.5.3-g510-keys.patch
@@ -0,0 +1,340 @@
+From http://sourceforge.net/tracker/?func=detail&aid=3152167&group_id=167869&atid=844658
+
+diff -aNru trunk/g15daemon-wip/plugins/g15_plugin_uinput.c mod/g15daemon-wip/plugins/g15_plugin_uinput.c
+--- trunk/g15daemon-wip/plugins/g15_plugin_uinput.c 2011-06-26 06:50:50.000000000 +0000
++++ mod/g15daemon-wip/plugins/g15_plugin_uinput.c 2011-06-26 06:51:42.000000000 +0000
+@@ -164,146 +164,195 @@
+
+ static void g15_process_keys(g15daemon_t *masterlist, unsigned int currentkeys, unsigned int lastkeys)
+ {
+- /* 'G' keys */
+- if((currentkeys & G15_KEY_G1) && !(lastkeys & G15_KEY_G1))
+- keydown(GKEY_OFFSET);
+- else if(!(currentkeys & G15_KEY_G1) && (lastkeys & G15_KEY_G1))
+- keyup(GKEY_OFFSET);
+-
+- if((currentkeys & G15_KEY_G2) && !(lastkeys & G15_KEY_G2))
+- keydown(GKEY_OFFSET+1);
+- else if(!(currentkeys & G15_KEY_G2) && (lastkeys & G15_KEY_G2))
+- keyup(GKEY_OFFSET+1);
+-
+- if((currentkeys & G15_KEY_G3) && !(lastkeys & G15_KEY_G3))
+- keydown(GKEY_OFFSET+2);
+- else if(!(currentkeys & G15_KEY_G3) && (lastkeys & G15_KEY_G3))
+- keyup(GKEY_OFFSET+2);
+-
+- if((currentkeys & G15_KEY_G4) && !(lastkeys & G15_KEY_G4))
+- keydown(GKEY_OFFSET+3);
+- else if(!(currentkeys & G15_KEY_G4) && (lastkeys & G15_KEY_G4))
+- keyup(GKEY_OFFSET+3);
+-
+- if((currentkeys & G15_KEY_G5) && !(lastkeys & G15_KEY_G5))
+- keydown(GKEY_OFFSET+4);
+- else if(!(currentkeys & G15_KEY_G5) && (lastkeys & G15_KEY_G5))
+- keyup(GKEY_OFFSET+4);
+-
+- if((currentkeys & G15_KEY_G6) && !(lastkeys & G15_KEY_G6))
+- keydown(GKEY_OFFSET+5);
+- else if(!(currentkeys & G15_KEY_G6) && (lastkeys & G15_KEY_G6))
+- keyup(GKEY_OFFSET+5);
+-
+- if((currentkeys & G15_KEY_G7) && !(lastkeys & G15_KEY_G7))
+- keydown(GKEY_OFFSET+6);
+- else if(!(currentkeys & G15_KEY_G7) && (lastkeys & G15_KEY_G7))
+- keyup(GKEY_OFFSET+6);
+-
+- if((currentkeys & G15_KEY_G8) && !(lastkeys & G15_KEY_G8))
+- keydown(GKEY_OFFSET+7);
+- else if(!(currentkeys & G15_KEY_G8) && (lastkeys & G15_KEY_G8))
+- keyup(GKEY_OFFSET+7);
+-
+- if((currentkeys & G15_KEY_G9) && !(lastkeys & G15_KEY_G9))
+- keydown(GKEY_OFFSET+8);
+- else if(!(currentkeys & G15_KEY_G9) && (lastkeys & G15_KEY_G9))
+- keyup(GKEY_OFFSET+8);
+-
+- if((currentkeys & G15_KEY_G10) && !(lastkeys & G15_KEY_G10))
+- keydown(GKEY_OFFSET+9);
+- else if(!(currentkeys & G15_KEY_G10) && (lastkeys & G15_KEY_G10))
+- keyup(GKEY_OFFSET+9);
+-
+- if((currentkeys & G15_KEY_G11) && !(lastkeys & G15_KEY_G11))
+- keydown(GKEY_OFFSET+10);
+- else if(!(currentkeys & G15_KEY_G11) && (lastkeys & G15_KEY_G11))
+- keyup(GKEY_OFFSET+10);
+-
+- if((currentkeys & G15_KEY_G12) && !(lastkeys & G15_KEY_G12))
+- keydown(GKEY_OFFSET+11);
+- else if(!(currentkeys & G15_KEY_G12) && (lastkeys & G15_KEY_G12))
+- keyup(GKEY_OFFSET+11);
+-
+- if((currentkeys & G15_KEY_G13) && !(lastkeys & G15_KEY_G13))
+- keydown(GKEY_OFFSET+12);
+- else if(!(currentkeys & G15_KEY_G13) && (lastkeys & G15_KEY_G13))
+- keyup(GKEY_OFFSET+12);
+-
+- if((currentkeys & G15_KEY_G14) && !(lastkeys & G15_KEY_G14))
+- keydown(GKEY_OFFSET+13);
+- else if(!(currentkeys & G15_KEY_G14) && (lastkeys & G15_KEY_G14))
+- keyup(GKEY_OFFSET+13);
+-
+- if((currentkeys & G15_KEY_G15) && !(lastkeys & G15_KEY_G15))
+- keydown(GKEY_OFFSET+14);
+- else if(!(currentkeys & G15_KEY_G15) && (lastkeys & G15_KEY_G15))
+- keyup(GKEY_OFFSET+14);
+-
+- if((currentkeys & G15_KEY_G16) && !(lastkeys & G15_KEY_G16))
+- keydown(GKEY_OFFSET+15);
+- else if(!(currentkeys & G15_KEY_G16) && (lastkeys & G15_KEY_G16))
+- keyup(GKEY_OFFSET+15);
+-
+- if((currentkeys & G15_KEY_G17) && !(lastkeys & G15_KEY_G17))
+- keydown(GKEY_OFFSET+16);
+- else if(!(currentkeys & G15_KEY_G17) && (lastkeys & G15_KEY_G17))
+- keyup(GKEY_OFFSET+16);
+-
+- if((currentkeys & G15_KEY_G18) && !(lastkeys & G15_KEY_G18))
+- keydown(GKEY_OFFSET+17);
+- else if(!(currentkeys & G15_KEY_G18) && (lastkeys & G15_KEY_G18))
+- keyup(GKEY_OFFSET+17);
+-
+- /* 'M' keys */
+-
+- if((currentkeys & G15_KEY_M1) && !(lastkeys & G15_KEY_M1))
+- keydown(MKEY_OFFSET);
+- else if(!(currentkeys & G15_KEY_M1) && (lastkeys & G15_KEY_M1))
+- keyup(MKEY_OFFSET);
+-
+- if((currentkeys & G15_KEY_M2) && !(lastkeys & G15_KEY_M2))
+- keydown(MKEY_OFFSET+1);
+- else if(!(currentkeys & G15_KEY_M2) && (lastkeys & G15_KEY_M2))
+- keyup(MKEY_OFFSET+1);
+-
+- if((currentkeys & G15_KEY_M3) && !(lastkeys & G15_KEY_M3))
+- keydown(MKEY_OFFSET+2);
+- else if(!(currentkeys & G15_KEY_M3) && (lastkeys & G15_KEY_M3))
+- keyup(MKEY_OFFSET+2);
+-
+- if((currentkeys & G15_KEY_MR) && !(lastkeys & G15_KEY_MR))
+- keydown(MKEY_OFFSET+3);
+- else if(!(currentkeys & G15_KEY_MR) && (lastkeys & G15_KEY_MR))
+- keyup(MKEY_OFFSET+3);
+-
+- if(map_Lkeys){
+- /* 'L' keys... */
+- if((currentkeys & G15_KEY_L1) && !(lastkeys & G15_KEY_L1))
+- keydown(LKEY_OFFSET);
+- else if(!(currentkeys & G15_KEY_L1) && (lastkeys & G15_KEY_L1))
+- keyup(LKEY_OFFSET);
+-
+- if((currentkeys & G15_KEY_L2) && !(lastkeys & G15_KEY_L2))
+- keydown(LKEY_OFFSET+1);
+- else if(!(currentkeys & G15_KEY_L2) && (lastkeys & G15_KEY_L2))
+- keyup(LKEY_OFFSET+1);
+-
+- if((currentkeys & G15_KEY_L3) && !(lastkeys & G15_KEY_L3))
+- keydown(LKEY_OFFSET+2);
+- else if(!(currentkeys & G15_KEY_L3) && (lastkeys & G15_KEY_L3))
+- keyup(LKEY_OFFSET+2);
+-
+- if((currentkeys & G15_KEY_L4) && !(lastkeys & G15_KEY_L4))
+- keydown(LKEY_OFFSET+3);
+- else if(!(currentkeys & G15_KEY_L4) && (lastkeys & G15_KEY_L4))
+- keyup(LKEY_OFFSET+3);
+-
+- if((currentkeys & G15_KEY_L5) && !(lastkeys & G15_KEY_L5))
+- keydown(LKEY_OFFSET+4);
+- else if(!(currentkeys & G15_KEY_L5) && (lastkeys & G15_KEY_L5))
+- keyup(LKEY_OFFSET+4);
++ if(!(currentkeys & G15_KEY_LIGHT))
++ {
++ /* 'G' keys */
++ if((currentkeys & G15_KEY_G1) && !(lastkeys & G15_KEY_G1))
++ keydown(GKEY_OFFSET);
++ else if(!(currentkeys & G15_KEY_G1) && (lastkeys & G15_KEY_G1))
++ keyup(GKEY_OFFSET);
++
++ if((currentkeys & G15_KEY_G2) && !(lastkeys & G15_KEY_G2))
++ keydown(GKEY_OFFSET+1);
++ else if(!(currentkeys & G15_KEY_G2) && (lastkeys & G15_KEY_G2))
++ keyup(GKEY_OFFSET+1);
++
++ if((currentkeys & G15_KEY_G3) && !(lastkeys & G15_KEY_G3))
++ keydown(GKEY_OFFSET+2);
++ else if(!(currentkeys & G15_KEY_G3) && (lastkeys & G15_KEY_G3))
++ keyup(GKEY_OFFSET+2);
++
++ if((currentkeys & G15_KEY_G4) && !(lastkeys & G15_KEY_G4))
++ keydown(GKEY_OFFSET+3);
++ else if(!(currentkeys & G15_KEY_G4) && (lastkeys & G15_KEY_G4))
++ keyup(GKEY_OFFSET+3);
++
++ if((currentkeys & G15_KEY_G5) && !(lastkeys & G15_KEY_G5))
++ keydown(GKEY_OFFSET+4);
++ else if(!(currentkeys & G15_KEY_G5) && (lastkeys & G15_KEY_G5))
++ keyup(GKEY_OFFSET+4);
++
++ if((currentkeys & G15_KEY_G6) && !(lastkeys & G15_KEY_G6))
++ keydown(GKEY_OFFSET+5);
++ else if(!(currentkeys & G15_KEY_G6) && (lastkeys & G15_KEY_G6))
++ keyup(GKEY_OFFSET+5);
++
++ if((currentkeys & G15_KEY_G7) && !(lastkeys & G15_KEY_G7))
++ keydown(GKEY_OFFSET+6);
++ else if(!(currentkeys & G15_KEY_G7) && (lastkeys & G15_KEY_G7))
++ keyup(GKEY_OFFSET+6);
++
++ if((currentkeys & G15_KEY_G8) && !(lastkeys & G15_KEY_G8))
++ keydown(GKEY_OFFSET+7);
++ else if(!(currentkeys & G15_KEY_G8) && (lastkeys & G15_KEY_G8))
++ keyup(GKEY_OFFSET+7);
++
++ if((currentkeys & G15_KEY_G9) && !(lastkeys & G15_KEY_G9))
++ keydown(GKEY_OFFSET+8);
++ else if(!(currentkeys & G15_KEY_G9) && (lastkeys & G15_KEY_G9))
++ keyup(GKEY_OFFSET+8);
++
++ if((currentkeys & G15_KEY_G10) && !(lastkeys & G15_KEY_G10))
++ keydown(GKEY_OFFSET+9);
++ else if(!(currentkeys & G15_KEY_G10) && (lastkeys & G15_KEY_G10))
++ keyup(GKEY_OFFSET+9);
++
++ if((currentkeys & G15_KEY_G11) && !(lastkeys & G15_KEY_G11))
++ keydown(GKEY_OFFSET+10);
++ else if(!(currentkeys & G15_KEY_G11) && (lastkeys & G15_KEY_G11))
++ keyup(GKEY_OFFSET+10);
++
++ if((currentkeys & G15_KEY_G12) && !(lastkeys & G15_KEY_G12))
++ keydown(GKEY_OFFSET+11);
++ else if(!(currentkeys & G15_KEY_G12) && (lastkeys & G15_KEY_G12))
++ keyup(GKEY_OFFSET+11);
++
++ if((currentkeys & G15_KEY_G13) && !(lastkeys & G15_KEY_G13))
++ keydown(GKEY_OFFSET+12);
++ else if(!(currentkeys & G15_KEY_G13) && (lastkeys & G15_KEY_G13))
++ keyup(GKEY_OFFSET+12);
++
++ if((currentkeys & G15_KEY_G14) && !(lastkeys & G15_KEY_G14))
++ keydown(GKEY_OFFSET+13);
++ else if(!(currentkeys & G15_KEY_G14) && (lastkeys & G15_KEY_G14))
++ keyup(GKEY_OFFSET+13);
++
++ if((currentkeys & G15_KEY_G15) && !(lastkeys & G15_KEY_G15))
++ keydown(GKEY_OFFSET+14);
++ else if(!(currentkeys & G15_KEY_G15) && (lastkeys & G15_KEY_G15))
++ keyup(GKEY_OFFSET+14);
++
++ if((currentkeys & G15_KEY_G16) && !(lastkeys & G15_KEY_G16))
++ keydown(GKEY_OFFSET+15);
++ else if(!(currentkeys & G15_KEY_G16) && (lastkeys & G15_KEY_G16))
++ keyup(GKEY_OFFSET+15);
++
++ if((currentkeys & G15_KEY_G17) && !(lastkeys & G15_KEY_G17))
++ keydown(GKEY_OFFSET+16);
++ else if(!(currentkeys & G15_KEY_G17) && (lastkeys & G15_KEY_G17))
++ keyup(GKEY_OFFSET+16);
++
++ if((currentkeys & G15_KEY_G18) && !(lastkeys & G15_KEY_G18))
++ keydown(GKEY_OFFSET+17);
++ else if(!(currentkeys & G15_KEY_G18) && (lastkeys & G15_KEY_G18))
++ keyup(GKEY_OFFSET+17);
++
++ /* 'M' keys */
++
++ if((currentkeys & G15_KEY_M1) && !(lastkeys & G15_KEY_M1))
++ keydown(MKEY_OFFSET);
++ else if(!(currentkeys & G15_KEY_M1) && (lastkeys & G15_KEY_M1))
++ keyup(MKEY_OFFSET);
++
++ if((currentkeys & G15_KEY_M2) && !(lastkeys & G15_KEY_M2))
++ keydown(MKEY_OFFSET+1);
++ else if(!(currentkeys & G15_KEY_M2) && (lastkeys & G15_KEY_M2))
++ keyup(MKEY_OFFSET+1);
++
++ if((currentkeys & G15_KEY_M3) && !(lastkeys & G15_KEY_M3))
++ keydown(MKEY_OFFSET+2);
++ else if(!(currentkeys & G15_KEY_M3) && (lastkeys & G15_KEY_M3))
++ keyup(MKEY_OFFSET+2);
++
++ if((currentkeys & G15_KEY_MR) && !(lastkeys & G15_KEY_MR))
++ keydown(MKEY_OFFSET+3);
++ else if(!(currentkeys & G15_KEY_MR) && (lastkeys & G15_KEY_MR))
++ keyup(MKEY_OFFSET+3);
++
++ if(map_Lkeys){
++ /* 'L' keys... */
++ if((currentkeys & G15_KEY_L1) && !(lastkeys & G15_KEY_L1))
++ keydown(LKEY_OFFSET);
++ else if(!(currentkeys & G15_KEY_L1) && (lastkeys & G15_KEY_L1))
++ keyup(LKEY_OFFSET);
++
++ if((currentkeys & G15_KEY_L2) && !(lastkeys & G15_KEY_L2))
++ keydown(LKEY_OFFSET+1);
++ else if(!(currentkeys & G15_KEY_L2) && (lastkeys & G15_KEY_L2))
++ keyup(LKEY_OFFSET+1);
++
++ if((currentkeys & G15_KEY_L3) && !(lastkeys & G15_KEY_L3))
++ keydown(LKEY_OFFSET+2);
++ else if(!(currentkeys & G15_KEY_L3) && (lastkeys & G15_KEY_L3))
++ keyup(LKEY_OFFSET+2);
++
++ if((currentkeys & G15_KEY_L4) && !(lastkeys & G15_KEY_L4))
++ keydown(LKEY_OFFSET+3);
++ else if(!(currentkeys & G15_KEY_L4) && (lastkeys & G15_KEY_L4))
++ keyup(LKEY_OFFSET+3);
++
++ if((currentkeys & G15_KEY_L5) && !(lastkeys & G15_KEY_L5))
++ keydown(LKEY_OFFSET+4);
++ else if(!(currentkeys & G15_KEY_L5) && (lastkeys & G15_KEY_L5))
++ keyup(LKEY_OFFSET+4);
++ }
+ }
++ else
++ {
++ // G15_KEY_LIGHT - Key modifier for Logitech G510 Media Keys implementation
++
++ // XF86AudioPlay
++ if((currentkeys & G15_KEY_G1) && !(lastkeys & G15_KEY_G1))
++ keydown(KEY_PLAYPAUSE);
++ else if(!(currentkeys & G15_KEY_G1) && (lastkeys & G15_KEY_G1))
++ keyup(KEY_PLAYPAUSE);
++
++ // XF86AudioStop
++ if((currentkeys & G15_KEY_G2) && !(lastkeys & G15_KEY_G2))
++ keydown(KEY_STOPCD);
++ else if(!(currentkeys & G15_KEY_G2) && (lastkeys & G15_KEY_G2))
++ keyup(KEY_STOPCD);
++
++ // XF86AudioPrev
++ if((currentkeys & G15_KEY_G3) && !(lastkeys & G15_KEY_G3))
++ keydown(KEY_PREVIOUSSONG);
++ else if(!(currentkeys & G15_KEY_G3) && (lastkeys & G15_KEY_G3))
++ keyup(KEY_PREVIOUSSONG);
++
++ // XF86AudioNext
++ if((currentkeys & G15_KEY_G4) && !(lastkeys & G15_KEY_G4))
++ keydown(KEY_NEXTSONG);
++ else if(!(currentkeys & G15_KEY_G4) && (lastkeys & G15_KEY_G4))
++ keyup(KEY_NEXTSONG);
++
++ // XF86AudioMute
++ if((currentkeys & G15_KEY_G5) && !(lastkeys & G15_KEY_G5))
++ keydown(KEY_MUTE);
++ else if(!(currentkeys & G15_KEY_G5) && (lastkeys & G15_KEY_G5))
++ keyup(KEY_MUTE);
++
++ // XF86AudioRaiseVolume
++ if((currentkeys & G15_KEY_G6) && !(lastkeys & G15_KEY_G6))
++ keydown(KEY_VOLUMEUP);
++ else if(!(currentkeys & G15_KEY_G6) && (lastkeys & G15_KEY_G6))
++ keyup(KEY_VOLUMEUP);
++
++ // XF86AudioLowerVolume
++ if((currentkeys & G15_KEY_G7) && !(lastkeys & G15_KEY_G7))
++ keydown(KEY_VOLUMEDOWN);
++ else if(!(currentkeys & G15_KEY_G7) && (lastkeys & G15_KEY_G7))
++ keyup(KEY_VOLUMEDOWN);
++ }
+ }
+
+
diff --git a/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild b/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild
new file mode 100644
index 000000000000..40e3ade073b0
--- /dev/null
+++ b/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild,v 1.1 2012/10/12 20:22:20 robbat2 Exp $
+
+EAPI=4
+GENTOO_DEPEND_ON_PERL="no"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils linux-info perl-module python base
+
+DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="perl python static-libs"
+
+DEPEND="virtual/libusb:0
+ >=dev-libs/libg15-9999
+ >=dev-libs/libg15render-1.2
+ perl? (
+ dev-lang/perl
+ dev-perl/GDGraph
+ >=dev-perl/Inline-0.4
+ )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-forgotten-open-mode.patch"
+ "${FILESDIR}/${P}-overflow-fix.patch"
+ "${FILESDIR}/${P}-g510-keys.patch"
+)
+
+uinput_check() {
+ ebegin "Checking for uinput support"
+ local rc=1
+ linux_config_exists && linux_chkconfig_present INPUT_UINPUT
+ rc=$?
+
+ if [[ $rc -ne 0 ]] ; then
+ eerror "To use g15daemon, you need to compile your kernel with uinput support."
+ eerror "Please enable uinput support in your kernel config, found at:"
+ eerror
+ eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
+ eerror
+ eerror "Once enabled, you should have the /dev/input/uinput device."
+ eerror "g15daemon will not work without the uinput device."
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ uinput_check
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ if use perl; then
+ unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
+ fi
+ if use python; then
+ unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
+ fi
+}
+
+src_prepare() {
+ if use perl; then
+ perl-module_src_prepare
+ sed -i \
+ -e '1i#!/usr/bin/perl' \
+ "${S}"/contrib/testbindings.pl
+ else
+ # perl-module_src_prepare always calls base_src_prepare
+ base_src_prepare
+ fi
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static)
+
+ if use perl; then
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ # remove odd docs installed my make
+ rm "${ED}/usr/share/doc/${PF}/"{LICENSE,README.usage}
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/xmodmaprc
+ doins contrib/xmodmap.sh
+ if use perl; then
+ doins contrib/testbindings.pl
+ fi
+
+ newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}-1.2.7-r2.initd" ${PN}
+ dobin "${FILESDIR}/g15daemon-hotplug"
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}/99-g15daemon.rules"
+
+ insinto /etc
+ doins "${FILESDIR}"/g15daemon.conf
+
+ # Gentoo bug #301340, debian bug #611649
+ exeinto /usr/lib/pm-utils/sleep.d
+ doexe "${FILESDIR}"/20g15daemon
+
+ if use perl; then
+ ebegin "Installing Perl Bindings (G15Daemon.pm)"
+ cd "${WORKDIR}/G15Daemon-0.2"
+ docinto perl
+ perl-module_src_install
+ fi
+
+ if use python; then
+ ebegin "Installing Python Bindings (g15daemon.py)"
+ cd "${WORKDIR}/pyg15daemon"
+
+ installation() {
+ insinto $(python_get_sitedir)
+ doins g15daemon.py
+ }
+ python_execute_function installation
+
+ docinto python
+ dodoc AUTHORS
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize g15daemon.py
+ echo ""
+ fi
+
+ elog "To use g15daemon, you need to add g15daemon to the default runlevel."
+ elog "This can be done with:"
+ elog "# /sbin/rc-update add g15daemon default"
+ elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
+ elog ""
+ elog "To have all new keys working in X11, you'll need create a "
+ elog "specific xmodmap in your home directory or edit the existent one."
+ elog ""
+ elog "Create the xmodmap:"
+ elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+ elog ""
+ elog "Adding keycodes to an existing xmodmap:"
+ elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup g15daemon.py
+ fi
+}
diff --git a/app-misc/g15daemon/g15daemon-9999.ebuild b/app-misc/g15daemon/g15daemon-9999.ebuild
new file mode 100644
index 000000000000..0bb8fafc6a9b
--- /dev/null
+++ b/app-misc/g15daemon/g15daemon-9999.ebuild
@@ -0,0 +1,191 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-9999.ebuild,v 1.1 2012/10/12 20:22:20 robbat2 Exp $
+
+EAPI=4
+GENTOO_DEPEND_ON_PERL="no"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+ESVN_PROJECT=${PN}/trunk
+ESVN_REPO_URI="https://${PN}.svn.sourceforge.net/svnroot/${ESVN_PROJECT}/${PN}-wip"
+
+inherit eutils linux-info perl-module python base subversion autotools
+
+DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+[[ ${PV} = *9999* ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="perl python static-libs"
+
+DEPEND="virtual/libusb:0
+ >=dev-libs/libg15-9999
+ >=dev-libs/libg15render-9999
+ perl? (
+ dev-lang/perl
+ dev-perl/GDGraph
+ >=dev-perl/Inline-0.4
+ )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.9.5.3-g510-keys.patch"
+)
+# "${FILESDIR}/${PN}-1.9.5.3-forgotten-open-mode.patch"
+# "${FILESDIR}/${PN}-1.9.5.3-overflow-fix.patch"
+
+uinput_check() {
+ ebegin "Checking for uinput support"
+ local rc=1
+ linux_config_exists && linux_chkconfig_present INPUT_UINPUT
+ rc=$?
+
+ if [[ $rc -ne 0 ]] ; then
+ eerror "To use g15daemon, you need to compile your kernel with uinput support."
+ eerror "Please enable uinput support in your kernel config, found at:"
+ eerror
+ eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
+ eerror
+ eerror "Once enabled, you should have the /dev/input/uinput device."
+ eerror "g15daemon will not work without the uinput device."
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ uinput_check
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_unpack() {
+ if [[ ${PV} = *9999* ]]; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+ if use perl; then
+ unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
+ fi
+ if use python; then
+ unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
+ fi
+}
+
+src_prepare() {
+ if [[ ${PV} = *9999* ]]; then
+ subversion_wc_info
+ fi
+ if use perl; then
+ perl-module_src_prepare
+ sed -i \
+ -e '1i#!/usr/bin/perl' \
+ "${S}"/contrib/testbindings.pl
+ else
+ # perl-module_src_prepare always calls base_src_prepare
+ base_src_prepare
+ fi
+ if [[ ${PV} = *9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static)
+
+ if use perl; then
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ # remove odd docs installed my make
+ rm "${ED}/usr/share/doc/${PF}/"{LICENSE,README.usage}
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/xmodmaprc
+ doins contrib/xmodmap.sh
+ if use perl; then
+ doins contrib/testbindings.pl
+ fi
+
+ newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}-1.2.7-r2.initd" ${PN}
+ dobin "${FILESDIR}/g15daemon-hotplug"
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}/99-g15daemon.rules"
+
+ insinto /etc
+ doins "${FILESDIR}"/g15daemon.conf
+
+ # Gentoo bug #301340, debian bug #611649
+ exeinto /usr/lib/pm-utils/sleep.d
+ doexe "${FILESDIR}"/20g15daemon
+
+ if use perl; then
+ ebegin "Installing Perl Bindings (G15Daemon.pm)"
+ cd "${WORKDIR}/G15Daemon-0.2"
+ docinto perl
+ perl-module_src_install
+ fi
+
+ if use python; then
+ ebegin "Installing Python Bindings (g15daemon.py)"
+ cd "${WORKDIR}/pyg15daemon"
+
+ installation() {
+ insinto $(python_get_sitedir)
+ doins g15daemon.py
+ }
+ python_execute_function installation
+
+ docinto python
+ dodoc AUTHORS
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize g15daemon.py
+ echo ""
+ fi
+
+ elog "To use g15daemon, you need to add g15daemon to the default runlevel."
+ elog "This can be done with:"
+ elog "# /sbin/rc-update add g15daemon default"
+ elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
+ elog ""
+ elog "To have all new keys working in X11, you'll need create a "
+ elog "specific xmodmap in your home directory or edit the existent one."
+ elog ""
+ elog "Create the xmodmap:"
+ elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+ elog ""
+ elog "Adding keycodes to an existing xmodmap:"
+ elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup g15daemon.py
+ fi
+}