summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-04-23 15:58:06 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-04-23 15:58:06 +0000
commit87aa45d02025deb3bef2aa1e60e243415b55643a (patch)
tree762ac1dba3f519b608cffa5acca796afd44d8f3f /app-misc/geneweb
parentFix ChangeLog since we have a bug.. (diff)
downloadgentoo-2-87aa45d02025deb3bef2aa1e60e243415b55643a.tar.gz
gentoo-2-87aa45d02025deb3bef2aa1e60e243415b55643a.tar.bz2
gentoo-2-87aa45d02025deb3bef2aa1e60e243415b55643a.zip
Respect nostrip, add gwc2 and minor fixes
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-misc/geneweb')
-rw-r--r--app-misc/geneweb/ChangeLog10
-rw-r--r--app-misc/geneweb/files/geneweb-5.01-gentoo.patch11
-rw-r--r--app-misc/geneweb/geneweb-5.01-r1.ebuild91
3 files changed, 111 insertions, 1 deletions
diff --git a/app-misc/geneweb/ChangeLog b/app-misc/geneweb/ChangeLog
index 98f07d18f48b..9fd73b3cc53d 100644
--- a/app-misc/geneweb/ChangeLog
+++ b/app-misc/geneweb/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/geneweb
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/geneweb/ChangeLog,v 1.3 2008/01/03 22:34:47 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/geneweb/ChangeLog,v 1.4 2008/04/23 15:58:06 tupone Exp $
+
+*geneweb-5.01-r1 (23 Apr 2008)
+
+ 23 Apr 2008; <atupone@gentoo.org> files/geneweb-5.01-gentoo.patch,
+ +geneweb-5.01-r1.ebuild:
+ Respect nostrip
+ Add additional gwc2, contrib/gwdiff.
+ Put html doc in the appropriate place
*geneweb-5.01 (03 Jan 2008)
diff --git a/app-misc/geneweb/files/geneweb-5.01-gentoo.patch b/app-misc/geneweb/files/geneweb-5.01-gentoo.patch
index fa3001aec4b9..9a334ef15a1e 100644
--- a/app-misc/geneweb/files/geneweb-5.01-gentoo.patch
+++ b/app-misc/geneweb/files/geneweb-5.01-gentoo.patch
@@ -11,3 +11,14 @@
value lang_param = ref "";
value only_file = ref "";
+--- tools/Makefile.inc.unix.old 2008-04-23 15:22:50.000000000 +0200
++++ tools/Makefile.inc.unix 2008-04-23 15:23:04.000000000 +0200
+@@ -9,7 +9,7 @@
+ OCAMLOPT=ocamlopt.opt -warn-error A
+ OCAMLI=
+ OCAMLD=
+-STRIP=strip
++STRIP=true
+ RM=/bin/rm -f
+ EXE=
+ STATIC=-ccopt -static
diff --git a/app-misc/geneweb/geneweb-5.01-r1.ebuild b/app-misc/geneweb/geneweb-5.01-r1.ebuild
new file mode 100644
index 000000000000..f3e7179d8fb9
--- /dev/null
+++ b/app-misc/geneweb/geneweb-5.01-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/geneweb/geneweb-5.01-r1.ebuild,v 1.1 2008/04/23 15:58:06 tupone Exp $
+
+inherit eutils
+
+EAPI="1"
+
+DESCRIPTION="Genealogy software program with a Web interface."
+HOMEPAGE="http://cristal.inria.fr/~ddr/GeneWeb/"
+SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/cristal/${PN}/Src/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="dev-lang/ocaml
+ dev-ml/camlp5"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt
+ then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ setup/setup.ml || die "Failed sed for gentoo path"
+ rm -f contrib/gwdiff/.*
+}
+
+src_compile() {
+ econf
+ if use ocamlopt; then
+ emake || die "Compiling native code executables failed"
+ else
+ emake OCAMLC=ocamlc OCAMLOPT=ocamlopt out \
+ || die "Compiling byte code executables failed"
+ # If using bytecode we dont want to strip the binary as it would remove
+ # the bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install() {
+ make distrib || die "Failed making distrib"
+ cd distribution/gw
+ # Install doc
+ dodoc CHANGES.txt
+ # Install binaries
+ dobin gwc gwc2 consang gwd gwu update_nldb ged2gwb gwb2ged gwsetup \
+ || die "Failed installing binaries"
+ insinto /usr/lib/${PN}
+ doins -r gwtp_tmp/* || die "Failed installing CGI program"
+ dodoc a.gwf
+ dohtml -r doc/*
+ insinto /usr/share/${PN}
+ doins -r etc images lang setup gwd.arg only.txt\
+ || die "Failed installing data"
+
+ cd ../..
+
+ # Install binaries
+ dobin src/check_base \
+ || die "Failed installing check_base binaries"
+ # Install manpages
+ doman man/* || die "Failed installing man pages"
+
+ # Install doc
+ dodoc ICHANGES
+ insinto /usr/share/doc/${PF}/contrib
+ doins -r contrib/{gwdiff,misc,templ} \
+ || die "Failed installing contributions"
+
+ newinitd "${FILESDIR}/geneweb.initd" geneweb
+ newconfd "${FILESDIR}/geneweb.confd" geneweb
+}
+
+pkg_postinst() {
+ enewuser geneweb "" "/bin/bash" /var/lib/geneweb
+ einfo "A CGI program has been installed in /usr/lib/${PN}. Follow the"
+ einfo "instructions on the README in that directory to use it"
+}