summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-12-05 19:09:03 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-12-05 19:09:03 +0000
commit1dd461385f6cd5cfb8c34216654e3b11007999c3 (patch)
tree3699a210606f5039cb65126e9f40ca083b1cd6c0 /app-misc/hivex
parentClean old, thanks to slepnoga (diff)
downloadgentoo-2-1dd461385f6cd5cfb8c34216654e3b11007999c3.tar.gz
gentoo-2-1dd461385f6cd5cfb8c34216654e3b11007999c3.tar.bz2
gentoo-2-1dd461385f6cd5cfb8c34216654e3b11007999c3.zip
Bump to 1.3.11, fixes security bug #490990. Thanks to slepnoga.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/ChangeLog7
-rw-r--r--app-misc/hivex/hivex-1.3.11.ebuild115
2 files changed, 121 insertions, 1 deletions
diff --git a/app-misc/hivex/ChangeLog b/app-misc/hivex/ChangeLog
index ae70b35f5561..4f434355deca 100644
--- a/app-misc/hivex/ChangeLog
+++ b/app-misc/hivex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/hivex
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.25 2014/11/18 23:36:10 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.26 2014/12/05 19:09:03 maksbotan Exp $
+
+*hivex-1.3.11 (05 Dec 2014)
+
+ 05 Dec 2014; Maxim Koltsov <maksbotan@gentoo.org> +hivex-1.3.11.ebuild:
+ Bump to 1.3.11, fixes security bug #490990. Thanks to slepnoga.
18 Nov 2014; Andreas K. Huettel <dilfridge@gentoo.org> hivex-1.3.7-r1.ebuild:
Replace perl-module_pkg_setup with perl_set_version
diff --git a/app-misc/hivex/hivex-1.3.11.ebuild b/app-misc/hivex/hivex-1.3.11.ebuild
new file mode 100644
index 000000000000..751af497ac0e
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.11.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.11.ebuild,v 1.1 2014/12/05 19:09:03 maksbotan Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+USE_RUBY="ruby20"
+RUBY_OPTIONAL=yes
+
+PYTHON_COMPAT=(python2_7 python3_{3,4})
+
+inherit base autotools autotools-utils eutils perl-app ruby-ng python-single-r1
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline +perl python test static-libs ruby"
+
+RDEPEND="
+ virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline )
+ perl? ( dev-perl/IO-stringy )
+ ruby? ( $(ruby_implementations_depend) )
+ python? ( ${PYTHON_DEPS} )
+ "
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage )
+ )
+ "
+
+ruby_add_bdepend "ruby? ( dev-ruby/rake )"
+ruby_add_bdepend "ruby? ( virtual/ruby-rdoc )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQ_USE} )"
+
+DOCS=( README )
+S="${WORKDIR}/${P}"
+
+#We are aware of rather poor quality of this ebuild, but the bump is required to fix security bug. We will fix other matters later.
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+ if use perl; then
+ perl-module_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ base_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ $(use_enable python)
+ $(use_enable ruby)
+ --disable-rpath )
+
+ autotools-utils_src_configure
+
+ if use perl; then
+ pushd perl
+ perl-app_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+# Test binding's dont't wok properly in gentoo layout
+#src_test() {
+# if use perl;then
+# pushd perl
+# perl-app_src_install
+# popd
+# fi
+#
+# autotools-utils_src_compile check
+#}
+
+src_install() {
+ strip-linguas -i po
+
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ if use perl; then
+ perl_delete_localpod
+ fi
+}