summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-03-31 09:03:29 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-03-31 09:03:29 +0000
commitb233f7efe8c917adfe47577a8936fabbda866860 (patch)
tree0e0f538a422be4bbf9f79bfb2d65f29b5c90c204 /app-misc/hivex
parentVersion bump. (diff)
downloadgentoo-2-b233f7efe8c917adfe47577a8936fabbda866860.tar.gz
gentoo-2-b233f7efe8c917adfe47577a8936fabbda866860.tar.bz2
gentoo-2-b233f7efe8c917adfe47577a8936fabbda866860.zip
Fix issue with glibc 2.16, bug #463894. Fix error with ruby 19, bug #444808. Thanks to slepnoga.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/ChangeLog13
-rw-r--r--app-misc/hivex/files/1.3.7/0004-ruby_runpath_fix-1.3.5.patch11
-rw-r--r--app-misc/hivex/files/1.3.7/ruby1.9_fix_deprection.patch43
-rw-r--r--app-misc/hivex/hivex-1.3.2-r2.ebuild7
-rw-r--r--app-misc/hivex/hivex-1.3.3-r1.ebuild80
-rw-r--r--app-misc/hivex/hivex-1.3.7-r1.ebuild124
6 files changed, 193 insertions, 85 deletions
diff --git a/app-misc/hivex/ChangeLog b/app-misc/hivex/ChangeLog
index 309f461ae7a3..0ccf12c0e722 100644
--- a/app-misc/hivex/ChangeLog
+++ b/app-misc/hivex/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/hivex
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.21 2012/10/21 15:37:45 maksbotan Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.22 2013/03/31 09:03:29 maksbotan Exp $
+
+*hivex-1.3.7-r1 (31 Mar 2013)
+
+ 31 Mar 2013; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/1.3.7/0004-ruby_runpath_fix-1.3.5.patch,
+ +files/1.3.7/ruby1.9_fix_deprection.patch, +hivex-1.3.7-r1.ebuild,
+ -hivex-1.3.3-r1.ebuild, hivex-1.3.2-r2.ebuild:
+ Fix issue with glibc 2.16, bug #463894. Fix error with ruby 19, bug #444808.
+ Thanks to slepnoga.
*hivex-1.3.7 (21 Oct 2012)
diff --git a/app-misc/hivex/files/1.3.7/0004-ruby_runpath_fix-1.3.5.patch b/app-misc/hivex/files/1.3.7/0004-ruby_runpath_fix-1.3.5.patch
new file mode 100644
index 000000000000..25624c7104d1
--- /dev/null
+++ b/app-misc/hivex/files/1.3.7/0004-ruby_runpath_fix-1.3.5.patch
@@ -0,0 +1,11 @@
+--- ruby/Rakefile.in 2012-03-13 19:46:43.000000000 +0400
++++ ruby/Rakefile.in 2012-04-15 19:02:42.337118192 +0400
+@@ -38,7 +38,7 @@
+ # Build locally
+
+ file MAKEFILE => EXT_CONF do |t|
+- unless sh "top_srcdir=$(pwd)/@top_srcdir@; top_builddir=$(pwd)/@top_builddir@; export ARCHFLAGS=\"-arch $(uname -m)\"; mkdir -p @builddir@/ext/hivex; cd @builddir@/ext/hivex; @RUBY@ #{EXT_CONF} --with-_hivex-include=$top_srcdir/lib --with-_hivex-lib=$top_builddir/lib/.libs"
++ unless sh "top_srcdir=@top_srcdir@; top_builddir=@top_builddir@; export ARCHFLAGS=\"-arch $(uname -m)\"; mkdir -p @builddir@/ext/hivex; cd @builddir@/ext/hivex; @RUBY@ #{EXT_CONF} --with-_hivex-include=../../$top_srcdir/lib --with-_hivex-lib=../../$top_builddir/lib/.libs --with-ldflags=\"$LDFLAGS\""
+ $stderr.puts "Failed to run extconf"
+ break
+ end
diff --git a/app-misc/hivex/files/1.3.7/ruby1.9_fix_deprection.patch b/app-misc/hivex/files/1.3.7/ruby1.9_fix_deprection.patch
new file mode 100644
index 000000000000..defd14a4f700
--- /dev/null
+++ b/app-misc/hivex/files/1.3.7/ruby1.9_fix_deprection.patch
@@ -0,0 +1,43 @@
+diff --git a/ruby/Makefile.am b/ruby/Makefile.am
+--- a/ruby/Makefile.am
++++ b/ruby/Makefile.am
+@@ -44,11 +44,11 @@
+ RUBY=$(RUBY) RAKE=$(RAKE)
+
+ all:
+- $(RAKE) build
+- $(RAKE) rdoc
++ $(RAKE) -v build
++ $(RAKE) -v rdoc
+
+-RUBY_SITELIB := $(shell $(RUBY) -rrbconfig -e "puts Config::CONFIG['sitelibdir']")
+-RUBY_SITEARCH := $(shell $(RUBY) -rrbconfig -e "puts Config::CONFIG['sitearchdir']")
++RUBY_SITELIB := $(shell $(RUBY) -rrbconfig -e "puts RbConfig::CONFIG['sitelibdir']")
++RUBY_SITEARCH := $(shell $(RUBY) -rrbconfig -e "puts RbConfig::CONFIG['sitearchdir']")
+
+ install:
+ $(MKDIR_P) $(DESTDIR)$(RUBY_SITELIB)
+diff --git a/ruby/Rakefile.in b/ruby/Rakefile.in
+--- a/ruby/Rakefile.in
++++ b/ruby/Rakefile.in
+@@ -17,9 +17,9 @@
+ # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+ require 'rake/clean'
+-require 'rake/rdoctask'
++require 'rdoc/task'
+ require 'rake/testtask'
+-require 'rake/gempackagetask'
++require 'rubygems/package_task'
+
+ PKG_NAME='@PACKAGE_NAME@'
+ PKG_VERSION='@PACKAGE_VERSION@'
+@@ -108,7 +108,7 @@
+ EOF
+ end
+
+-Rake::GemPackageTask.new(SPEC) do |pkg|
++Gem::PackageTask.new(SPEC) do |pkg|
+ pkg.need_tar = true
+ pkg.need_zip = true
+ end
diff --git a/app-misc/hivex/hivex-1.3.2-r2.ebuild b/app-misc/hivex/hivex-1.3.2-r2.ebuild
index 4493a608affa..fbc702916f0e 100644
--- a/app-misc/hivex/hivex-1.3.2-r2.ebuild
+++ b/app-misc/hivex/hivex-1.3.2-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.2-r2.ebuild,v 1.2 2012/05/03 17:00:12 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.2-r2.ebuild,v 1.3 2013/03/31 09:03:29 maksbotan Exp $
-EAPI=4
+EAPI=5
WANT_AUTOMAKE="1.11"
AUTOTOOLS_IN_SOURCE_BUILD=1
@@ -51,6 +51,7 @@ pkg_setup() {
}
src_prepare() {
+ sed -i -e '/gets is a security/d' gnulib/lib/stdio.in.h || die "sed failed"
autotools-utils_src_prepare
}
diff --git a/app-misc/hivex/hivex-1.3.3-r1.ebuild b/app-misc/hivex/hivex-1.3.3-r1.ebuild
deleted file mode 100644
index 3ee596d14e97..000000000000
--- a/app-misc/hivex/hivex-1.3.3-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.3-r1.ebuild,v 1.1 2012/05/02 12:24:25 maksbotan Exp $
-
-EAPI=4
-
-WANT_AUTOMAKE="1.11"
-AUTOTOOLS_IN_SOURCE_BUILD=1
-AUTOTOOLS_AUTORECONF=1
-
-PYTHON_DEPEND="python? 2:2.6"
-inherit base autotools-utils perl-app python
-
-DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
-HOMEPAGE="http://libguestfs.org"
-SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ocaml readline perl python test static-libs ruby"
-
-RDEPEND="virtual/libiconv
- virtual/libintl
- dev-libs/libxml2:2
- ocaml? ( dev-lang/ocaml[ocamlopt]
- dev-ml/findlib[ocamlopt]
- )
- readline? ( sys-libs/readline )
- perl? ( dev-perl/IO-stringy )
- "
-
-DEPEND="${RDEPEND}
- dev-lang/perl
- perl? (
- test? ( dev-perl/Pod-Coverage
- dev-perl/Test-Pod-Coverage ) )
- ruby? ( dev-ruby/rake )
- "
-PATCHES=("${FILESDIR}"/"${PV}"/*.patch)
-DOCS=(README)
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- python_need_rebuild
- fi
-}
-
-src_prepare() {
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with readline)
- $(use_enable ocaml)
- $(use_enable perl)
- --enable-nls
- $(use_enable python)
- $(use_enable ruby)
- --disable-rpath )
-
- autotools-utils_src_configure
-}
-
-src_test() {
- autotools-utils_src_compile check
-}
-
-src_install() {
- strip-linguas -i po
-
- autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
-
- if use perl; then
- fixlocalpod
- fi
-}
diff --git a/app-misc/hivex/hivex-1.3.7-r1.ebuild b/app-misc/hivex/hivex-1.3.7-r1.ebuild
new file mode 100644
index 000000000000..e566fa83280b
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.7-r1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.7-r1.ebuild,v 1.1 2013/03/31 09:03:29 maksbotan Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+WANT_AUTOMAKE=1.11
+
+USE_RUBY="ruby19"
+RUBY_OPTIONAL=yes
+PYTHON_DEPEND="python? 2:2.6"
+SUPPORT_PYTHON_ABIS=1
+
+inherit base autotools autotools-utils eutils perl-app ruby-ng python
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline +perl python test static-libs ruby"
+
+RDEPEND="
+ virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline )
+ perl? ( dev-perl/IO-stringy )
+ ruby? ( $(ruby_implementations_depend) )
+ "
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage )
+ )
+ "
+
+ruby_add_bdepend "ruby? ( dev-ruby/rake )"
+ruby_add_bdepend "ruby? ( virtual/ruby-rdoc )"
+
+DOCS=(README)
+PATCHES=("${FILESDIR}"/"${PV}"/*.patch)
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+ if use perl; then
+ perl-module_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ base_src_prepare
+ eautomake
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ $(use_enable python)
+ $(use_enable ruby)
+ --disable-rpath )
+
+ autotools-utils_src_configure
+
+ if use perl; then
+ pushd perl
+ perl-app_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+src_test() {
+ if use perl;then
+ pushd perl
+ perl-app_src_install
+ popd
+ fi
+
+ autotools-utils_src_compile check
+}
+
+src_install() {
+ strip-linguas -i po
+
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ if use perl; then
+ fixlocalpod
+ fi
+ if use python; then
+ compile_and_install() {
+ emake -C python clean
+ emake -C python PYTHON_VERSION="${PYTHON_ABI}" \
+ PYTHON_INCLUDEDIR="$(python_get_includedir)" \
+ PYTHON_INSTALLDIR="$(python_get_sitedir)" \
+ DESTDIR="${ED}" install
+ }
+ python_execute_function compile_and_install
+ fi
+}