summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2009-11-01 16:14:19 +0000
committerRobert Buchholz <rbu@gentoo.org>2009-11-01 16:14:19 +0000
commitadbdc6fe2c47d052117288ec1c5815567c770265 (patch)
tree220e48ddf809dc01284f0ff9255408ec258e02f1 /app-misc/lcd-stuff
parentppc stable #290749 (diff)
downloadgentoo-2-adbdc6fe2c47d052117288ec1c5815567c770265.tar.gz
gentoo-2-adbdc6fe2c47d052117288ec1c5815567c770265.tar.bz2
gentoo-2-adbdc6fe2c47d052117288ec1c5815567c770265.zip
Version bump (#288114) and migrate to EAPI=2.
Also fixes curl compile error (#286901). (Portage version: 2.1.7.1/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/lcd-stuff')
-rw-r--r--app-misc/lcd-stuff/ChangeLog8
-rw-r--r--app-misc/lcd-stuff/lcd-stuff-0.1.6.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/app-misc/lcd-stuff/ChangeLog b/app-misc/lcd-stuff/ChangeLog
index f5eb8577b82f..5f4e48798728 100644
--- a/app-misc/lcd-stuff/ChangeLog
+++ b/app-misc/lcd-stuff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/lcd-stuff
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd-stuff/ChangeLog,v 1.15 2009/05/31 22:08:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd-stuff/ChangeLog,v 1.16 2009/11/01 16:14:19 rbu Exp $
+
+*lcd-stuff-0.1.6 (01 Nov 2009)
+
+ 01 Nov 2009; Robert Buchholz <rbu@gentoo.org> +lcd-stuff-0.1.6.ebuild:
+ Version bump (#288114) and migrate to EAPI=2.
+ Also fixes curl compile error (#286901).
31 May 2009; Markus Meier <maekke@gentoo.org> lcd-stuff-0.1.5.ebuild:
amd64 stable, bug #270722
diff --git a/app-misc/lcd-stuff/lcd-stuff-0.1.6.ebuild b/app-misc/lcd-stuff/lcd-stuff-0.1.6.ebuild
new file mode 100644
index 000000000000..7d112faec935
--- /dev/null
+++ b/app-misc/lcd-stuff/lcd-stuff-0.1.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd-stuff/lcd-stuff-0.1.6.ebuild,v 1.1 2009/11/01 16:14:19 rbu Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="lcd-stuff is a client for lcdproc that displays RSS, Weather, MPD and new mail."
+HOMEPAGE="http://lcd-stuff.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2" # and GPL-2 only
+
+RDEPEND="app-misc/lcdproc
+ net-misc/curl
+ dev-libs/glib
+ imap? ( net-libs/libetpan )
+ mpd? ( >=media-libs/libmpd-0.12.0 )
+ mp3? ( media-libs/taglib )
+ xml? ( net-libs/libnxml )
+ rss? ( net-libs/libmrss net-libs/libnxml )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+IUSE="imap mpd mp3 xml rss"
+
+src_configure() {
+ local XMLRSSLIB="$(use_enable rss mrss)"
+ if use rss ; then
+ # If we want rss, we must also have xml
+ XMLRSSLIB="${XMLRSSLIB} --enable-nxml"
+ else
+ XMLRSSLIB="${XMLRSSLIB} $(use_enable xml nxml)"
+ fi
+
+ econf \
+ $(use_enable imap libetpan) \
+ $(use_enable mpd libmpd) \
+ $(use_enable mp3 taglib_c) \
+ $XMLRSSLIB \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ insinto /etc
+ doins lcd-stuff.conf
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}-0.1.2-r1.initd" ${PN}
+
+ dodoc ChangeLog README
+}