summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-05-06 16:24:52 +0000
committerPacho Ramos <pacho@gentoo.org>2012-05-06 16:24:52 +0000
commit9636eb76ab5a9460c54e31c93bade04c42015c5c (patch)
tree20780d9a09514f49ecacb1d65839fc986096623e /app-misc/lcd4linux
parentalpha/ia64/s390/sh/sparc stable wrt #399305 (diff)
downloadgentoo-2-9636eb76ab5a9460c54e31c93bade04c42015c5c.tar.gz
gentoo-2-9636eb76ab5a9460c54e31c93bade04c42015c5c.tar.bz2
gentoo-2-9636eb76ab5a9460c54e31c93bade04c42015c5c.zip
Let it work with python3 as main interpreter and include missing header (#311529 by Ian Delaney).
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/lcd4linux')
-rw-r--r--app-misc/lcd4linux/ChangeLog8
-rw-r--r--app-misc/lcd4linux/files/lcd4linux-0.10.1_rc2-missing-header.patch12
-rw-r--r--app-misc/lcd4linux/lcd4linux-0.10.1_rc2-r2.ebuild31
3 files changed, 33 insertions, 18 deletions
diff --git a/app-misc/lcd4linux/ChangeLog b/app-misc/lcd4linux/ChangeLog
index 3c0603cf79a1..36cb77ac2cc3 100644
--- a/app-misc/lcd4linux/ChangeLog
+++ b/app-misc/lcd4linux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/lcd4linux
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd4linux/ChangeLog,v 1.40 2012/05/06 16:01:21 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd4linux/ChangeLog,v 1.41 2012/05/06 16:24:52 pacho Exp $
+
+ 06 May 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/lcd4linux-0.10.1_rc2-missing-header.patch,
+ lcd4linux-0.10.1_rc2-r2.ebuild:
+ Let it work with python3 as main interpreter and include missing header
+ (#311529 by Ian Delaney).
06 May 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
lcd herd is empty, drop old.
diff --git a/app-misc/lcd4linux/files/lcd4linux-0.10.1_rc2-missing-header.patch b/app-misc/lcd4linux/files/lcd4linux-0.10.1_rc2-missing-header.patch
new file mode 100644
index 000000000000..6b38dc038c4a
--- /dev/null
+++ b/app-misc/lcd4linux/files/lcd4linux-0.10.1_rc2-missing-header.patch
@@ -0,0 +1,12 @@
+diff -ur lcd4linux-0.10.1-RC2.orig/lcd4linux.c lcd4linux-0.10.1-RC2/lcdinux-0.10.1-RC2/lcd4linux.c
+--- lcd4linux.c 2007-03-22 15:10:41.000000000 +0900
++++ lcd4linux.c 2011-11-23 12:12:03.782869315 +0800
+@@ -26,7 +26,7 @@
+ */
+
+ #include "config.h"
+-
++#include <sys/stat.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
diff --git a/app-misc/lcd4linux/lcd4linux-0.10.1_rc2-r2.ebuild b/app-misc/lcd4linux/lcd4linux-0.10.1_rc2-r2.ebuild
index 558921377255..4ab5a78212e8 100644
--- a/app-misc/lcd4linux/lcd4linux-0.10.1_rc2-r2.ebuild
+++ b/app-misc/lcd4linux/lcd4linux-0.10.1_rc2-r2.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd4linux/lcd4linux-0.10.1_rc2-r2.ebuild,v 1.8 2010/03/05 23:26:14 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd4linux/lcd4linux-0.10.1_rc2-r2.ebuild,v 1.9 2012/05/06 16:24:52 pacho Exp $
+EAPI=4
+PYTHON_DEPEND="python? 2"
WANT_AUTOMAKE="1.9"
-inherit eutils multilib autotools
+inherit eutils multilib autotools python
MY_P=${P/_rc/-RC}
@@ -36,7 +38,6 @@ done
DEPEND="
mysql? ( virtual/mysql )
- python? ( dev-lang/python )
iconv? ( virtual/libiconv )
mpd? ( media-libs/libmpd )
@@ -59,26 +60,26 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- echo
elog "If you wish to compile only specific plugins, please use"
elog "the LCD4LINUX_PLUGINS environment variable. Plugins must be comma separated and can be either of:"
elog "apm cpuinfo diskstats dvb exec file i2c_sensors imon isdn kvv loadavg meminfo netdev pop3 ppp proc_stat seti statfs uname uptime wireless"
- echo
-}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+src_prepare() {
epatch "${FILESDIR}/${P}-warnings.patch"
epatch "${FILESDIR}/${P}-mpd.patch"
epatch "${FILESDIR}/${P}-nordtsc.patch"
epatch "${FILESDIR}/${P}-autoconf-2.65.patch"
-
+ epatch "${FILESDIR}/${P}-missing-header.patch"
eautoreconf
}
-src_compile() {
+src_configure() {
# This array contains the driver names required by configure --with-drivers=
# The positions must be the same as the corresponding use_expand flags
local DEVICE_DRIVERS=(BeckmannEgle BWCT CrystalFontz Curses Cwlinux
@@ -153,12 +154,10 @@ src_compile() {
|| die "econf failed"
sed -i.orig -e 's/-L -lX11/ -lX11 /g' Makefile || die "sed fixup failed"
-
- emake || die "make failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install
dodoc README ChangeLog
@@ -171,11 +170,9 @@ src_install() {
pkg_postinst() {
if use lcd_devices_lcdlinux; then
- echo
ewarn "To actually use the lcd-linux devices, you will need to install the lcd-linux kernel module."
ewarn "You can either do that yourself, see http://lcd-linux.sf.net or "
ewarn "checkout http://overlays.gentoo.org/dev/jokey/browser/trunk and emerge app-misc/lcd-linux"
- echo
fi
ewarn "If you are upgrading, please note that the default config file was moved to /etc/lcd4linux.conf"
}