summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-16 10:11:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-16 10:11:59 +0000
commitb80473083fd57b48994ce3dbe7d80ba9c7c54829 (patch)
tree36cbdb92a090c2d3ba2ed1a3ae1b06633bcbcd27 /app-misc/ledit
parentx11-libs/gtksourceview: Add version 2.1.0 (diff)
downloadgentoo-2-b80473083fd57b48994ce3dbe7d80ba9c7c54829.tar.gz
gentoo-2-b80473083fd57b48994ce3dbe7d80ba9c7c54829.tar.bz2
gentoo-2-b80473083fd57b48994ce3dbe7d80ba9c7c54829.zip
version bump, restrict installsources as ocamlduce kills the ocamlc -custom compiled binaries
(Portage version: 2.1.4)
Diffstat (limited to 'app-misc/ledit')
-rw-r--r--app-misc/ledit/ChangeLog8
-rw-r--r--app-misc/ledit/files/digest-ledit-1.173
-rw-r--r--app-misc/ledit/ledit-1.17.ebuild53
3 files changed, 63 insertions, 1 deletions
diff --git a/app-misc/ledit/ChangeLog b/app-misc/ledit/ChangeLog
index df5240a7b550..3cf75905b625 100644
--- a/app-misc/ledit/ChangeLog
+++ b/app-misc/ledit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/ledit
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.17 2008/01/02 19:34:33 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.18 2008/01/16 10:11:59 aballier Exp $
+
+*ledit-1.17 (16 Jan 2008)
+
+ 16 Jan 2008; Alexis Ballier <aballier@gentoo.org> +ledit-1.17.ebuild:
+ version bump, restrict installsources as ocamlduce kills the ocamlc -custom
+ compiled binaries
02 Jan 2008; Alexis Ballier <aballier@gentoo.org> -ledit-1.11.ebuild,
ledit-1.11-r1.ebuild:
diff --git a/app-misc/ledit/files/digest-ledit-1.17 b/app-misc/ledit/files/digest-ledit-1.17
new file mode 100644
index 000000000000..2b50dfde77d7
--- /dev/null
+++ b/app-misc/ledit/files/digest-ledit-1.17
@@ -0,0 +1,3 @@
+MD5 d4be627ca10ba4977bbf1e8c71dda342 ledit-1.17.tgz 18920
+RMD160 c3cf49d3a32607245d39e759ac14b41a17e5ba63 ledit-1.17.tgz 18920
+SHA256 59b1c30a4021041f97674565199a2794701c3959cd9e04e4108ce0d79aa2caa1 ledit-1.17.tgz 18920
diff --git a/app-misc/ledit/ledit-1.17.ebuild b/app-misc/ledit/ledit-1.17.ebuild
new file mode 100644
index 000000000000..a6671bedb423
--- /dev/null
+++ b/app-misc/ledit/ledit-1.17.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ledit-1.17.ebuild,v 1.1 2008/01/16 10:11:59 aballier Exp $
+
+inherit eutils
+
+EAPI="1"
+
+RESTRICT="installsources"
+IUSE="+ocamlopt"
+
+DESCRIPTION="A line editor to be used with interactive commands."
+SRC_URI="http://pauillac.inria.fr/~ddr/ledit/distrib/src/${P}.tgz"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/ledit/"
+
+DEPEND=">=dev-lang/ocaml-3.09 dev-ml/camlp5"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile()
+{
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 ledit.opt || die "make failed"
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install()
+{
+ if use ocamlopt; then
+ newbin ledit.opt ledit
+ else
+ newbin ledit.out ledit
+ fi
+ doman ledit.1
+ dodoc CHANGES README
+}