summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-05-07 19:45:10 +0000
committerMichael Januszewski <spock@gentoo.org>2006-05-07 19:45:10 +0000
commita8207e37a10084061083ebf85b80efcc04e39cdf (patch)
tree009d317a5ea604e66188051d7c87f9b8dd95c459 /app-misc/linux-logo
parentStable on ppc64; bug #89969 (diff)
downloadgentoo-2-a8207e37a10084061083ebf85b80efcc04e39cdf.tar.gz
gentoo-2-a8207e37a10084061083ebf85b80efcc04e39cdf.tar.bz2
gentoo-2-a8207e37a10084061083ebf85b80efcc04e39cdf.zip
Version bump.
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'app-misc/linux-logo')
-rw-r--r--app-misc/linux-logo/ChangeLog8
-rw-r--r--app-misc/linux-logo/files/digest-linux-logo-4.133
-rw-r--r--app-misc/linux-logo/linux-logo-4.13.ebuild68
3 files changed, 78 insertions, 1 deletions
diff --git a/app-misc/linux-logo/ChangeLog b/app-misc/linux-logo/ChangeLog
index f973339431f2..91dbb35e3f8b 100644
--- a/app-misc/linux-logo/ChangeLog
+++ b/app-misc/linux-logo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/linux-logo
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/linux-logo/ChangeLog,v 1.30 2006/04/27 13:15:17 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/linux-logo/ChangeLog,v 1.31 2006/05/07 19:45:10 spock Exp $
+
+*linux-logo-4.13 (07 May 2006)
+
+ 07 May 2006; Michał Januszewski <spock@gentoo.org>
+ +linux-logo-4.13.ebuild:
+ Version bump (bug #132466).
27 Apr 2006; Marien Zwart <marienz@gentoo.org>
files/digest-linux-logo-4.12, Manifest:
diff --git a/app-misc/linux-logo/files/digest-linux-logo-4.13 b/app-misc/linux-logo/files/digest-linux-logo-4.13
new file mode 100644
index 000000000000..4c429e56a85c
--- /dev/null
+++ b/app-misc/linux-logo/files/digest-linux-logo-4.13
@@ -0,0 +1,3 @@
+MD5 17af1e478ea9ac7dbcffd2e0a53aa5a6 linux_logo-4.13.tar.gz 91337
+RMD160 f14e6086440f3986048e6f094de6d16c61391a9e linux_logo-4.13.tar.gz 91337
+SHA256 ca0df027127ea7aa28f128284811f06fcfe648e6f131c879615e7114e149fdd0 linux_logo-4.13.tar.gz 91337
diff --git a/app-misc/linux-logo/linux-logo-4.13.ebuild b/app-misc/linux-logo/linux-logo-4.13.ebuild
new file mode 100644
index 000000000000..7e0ef35a48a8
--- /dev/null
+++ b/app-misc/linux-logo/linux-logo-4.13.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/linux-logo/linux-logo-4.13.ebuild,v 1.1 2006/05/07 19:45:10 spock Exp $
+
+inherit eutils
+
+MY_P=${PN/-/_}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A utility that displays an ANSI/ASCII logo and some system information"
+HOMEPAGE="http://www.deater.net/weave/vmwprod/linux_logo/"
+SRC_URI="http://www.deater.net/weave/vmwprod/linux_logo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo "./logos/gentoo.logo" >> logo_config
+ cp "${FILESDIR}"/gentoo.logo "${S}"/logos/
+
+ epatch "${FILESDIR}"/${PN}-4.07-gentoo-logo.patch
+ sed -i -e 's:.*Trying to open .*::' linux_logo.c
+
+ if ! use nls ; then
+ sed -i 's:cd po && $(MAKE):echo:' Makefile
+ fi
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ dobin linux_logo || die
+ doman linux_logo.1.gz
+
+ dodoc BUGS CHANGES README README.CUSTOM_LOGOS TODO USAGE LINUX_LOGO.FAQ
+
+ if use nls ; then
+ dodir /usr/share/locale
+ make INSTALLDIR="${D}"/usr/share/locale -C po install || die
+ fi
+
+ newinitd ${FILESDIR}/${PN}.initscript ${PN}
+ newconfd ${FILESDIR}/${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ echo
+ einfo "Linux_logo ebuild for Gentoo comes with two Gentoo logos."
+ einfo ""
+ einfo "To display the first Gentoo logo type: linux_logo -L 3"
+ einfo "To display the second Gentoo logo type: linux_logo -L 4"
+ einfo "To display all the logos available type: linux_logo -L list."
+ einfo ""
+ einfo "To start linux_logo on boot, please type:"
+ einfo " rc-update add linux-logo default"
+ einfo "which uses the settings found in"
+ einfo " /etc/conf.d/linux-logo"
+ echo
+}