summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2004-12-03 15:32:47 +0000
committerChris Bainbridge <chrb@gentoo.org>2004-12-03 15:32:47 +0000
commit5fb8adcad63fd49154e2c5b13cb28d8f7e0d323c (patch)
tree89e730cdba090d10d0a0119f4e4adb178d59c99d /app-misc/lirc
parentVersion bump at long last. :) (Manifest recommit) (diff)
downloadgentoo-2-5fb8adcad63fd49154e2c5b13cb28d8f7e0d323c.tar.gz
gentoo-2-5fb8adcad63fd49154e2c5b13cb28d8f7e0d323c.tar.bz2
gentoo-2-5fb8adcad63fd49154e2c5b13cb28d8f7e0d323c.zip
xbox support in -r1
Diffstat (limited to 'app-misc/lirc')
-rw-r--r--app-misc/lirc/ChangeLog8
-rw-r--r--app-misc/lirc/Manifest5
-rw-r--r--app-misc/lirc/files/digest-lirc-0.7.0-r11
-rw-r--r--app-misc/lirc/files/lirc-0.7.0-xbox.patch.bz2bin0 -> 10512 bytes
-rw-r--r--app-misc/lirc/lirc-0.7.0-r1.ebuild125
5 files changed, 137 insertions, 2 deletions
diff --git a/app-misc/lirc/ChangeLog b/app-misc/lirc/ChangeLog
index d883f9fdbfad..90c0591413d9 100644
--- a/app-misc/lirc/ChangeLog
+++ b/app-misc/lirc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/lirc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.52 2004/12/03 11:52:03 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.53 2004/12/03 15:32:47 chrb Exp $
+
+*lirc-0.7.0-r1 (03 Dec 2004)
+
+ 03 Dec 2004; Chris Bainbridge <chrb@gentoo.org>
+ +files/lirc-0.7.0-xbox.patch.bz2, +lirc-0.7.0-r1.ebuild:
+ Added xbox driver. Only used when the xbox profile is selected.
*lirc-0.7.0_pre8 (03 Dec 2004)
diff --git a/app-misc/lirc/Manifest b/app-misc/lirc/Manifest
index f0ba8d217266..34f2798948b2 100644
--- a/app-misc/lirc/Manifest
+++ b/app-misc/lirc/Manifest
@@ -1,6 +1,7 @@
-MD5 e3baa1aebab6527dcc58dca53592ed87 ChangeLog 7722
+MD5 338f31cae3dfb28de7d10b86fcb1b42d ChangeLog 7928
MD5 9addc749627c39db73047d512379735c lirc-0.7.0_pre8.ebuild 3327
MD5 9dec01b704006290727d5bf8d5c7fb3b lirc-0.7.0_pre3.ebuild 4430
+MD5 5621d534e76c8dfc2cdf6c1d2c91ed71 lirc-0.7.0-r1.ebuild 3676
MD5 6ea46a8f53247afcc0e5566e20a97270 lirc-0.7.0_pre6.ebuild 4619
MD5 6409d202b33858fe2babae36d09cff0c lirc-0.7.0_pre7.ebuild 3524
MD5 a9b4e7432c9154352e2db62a6f46cd06 lirc-0.7.0.ebuild 3696
@@ -20,3 +21,5 @@ MD5 54581835f791fe37a1285926c6d21b12 files/lircmd 466
MD5 ee2b49c33fb3b2a65122cfc698d9e100 files/xbox-lircd.conf 784
MD5 d874cf5e0b5c21cd211acea456f171d7 files/lirc-0.7.0-configure.in.patch 747
MD5 8fd71f6a7c4842bfbad1e2bfb67f187f files/lirc-0.7.0-streamzap.patch.bz2 16868
+MD5 1106aad81c744af1a4c82b0cb66b3513 files/lirc-0.7.0-xbox.patch.bz2 10512
+MD5 8b5ccb169d823795a11450a1c052da55 files/digest-lirc-0.7.0-r1 63
diff --git a/app-misc/lirc/files/digest-lirc-0.7.0-r1 b/app-misc/lirc/files/digest-lirc-0.7.0-r1
new file mode 100644
index 000000000000..dfe85f3b86c7
--- /dev/null
+++ b/app-misc/lirc/files/digest-lirc-0.7.0-r1
@@ -0,0 +1 @@
+MD5 4fbcc8b0d69ca5ecbdda40576964573f lirc-0.7.0.tar.bz2 464270
diff --git a/app-misc/lirc/files/lirc-0.7.0-xbox.patch.bz2 b/app-misc/lirc/files/lirc-0.7.0-xbox.patch.bz2
new file mode 100644
index 000000000000..89da6e685708
--- /dev/null
+++ b/app-misc/lirc/files/lirc-0.7.0-xbox.patch.bz2
Binary files differ
diff --git a/app-misc/lirc/lirc-0.7.0-r1.ebuild b/app-misc/lirc/lirc-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..e9f6421e89cf
--- /dev/null
+++ b/app-misc/lirc/lirc-0.7.0-r1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.7.0-r1.ebuild,v 1.1 2004/12/03 15:32:47 chrb Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="LIRC is a package that allows you to decode and send infra-red \
+ signals of many (but not all) commonly used remote controls."
+HOMEPAGE="http://www.lirc.org"
+
+# LIRC_OPTS = ???? v
+# This are the defaults. With this support for all supported remotes
+# will be build.
+# If you want other options then set the Environment variable to your needs.
+
+# Note: If you don't specify the driver configure becomes interactiv.
+
+# You have to know, which driver you want;
+# --with-driver=X
+
+# where X is one of:
+# none, any, animax, avermedia, avermedia98,
+# bestbuy, bestbuy2, caraca, chronos, comX,
+# cph03x, cph06x, creative, fly98, flyvideo,
+# hauppauge,hauppauge_dvb, ipaq, irdeo,
+# irdeo_remote, irman, irreal, it87, knc_one,
+# logitech, lptX, mediafocusI, packard_bell,
+# parallel, pctv, pixelview_bt878,
+# pixelview_pak, pixelview_pro, provideo,
+# realmagic, remotemaster, serial, silitek,
+# sir, slinke, streamzap tekram, winfast_tv2000
+
+# This could be usefull too
+
+# --with-port=port # port number for the lirc device.
+# --with-irq=irq # irq line for the lirc device.
+# --with-timer=value # timer value for the parallel driver
+# --with-tty=file # tty to use (Irman, RemoteMaster, etc.)
+# --without-soft-carrier # if your serial hw generates carrier
+# --with-transmitter # if you use a transmitter diode
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="debug doc streamzap"
+KEYWORDS="~x86 ~ppc ~alpha ~ia64 ~amd64 ~ppc64"
+
+DEPEND="virtual/linux-sources"
+
+SRC_URI="mirror://sourceforge/lirc/${P}.tar.bz2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use streamzap && epatch ${FILESDIR}/lirc-0.7.0-streamzap.patch.bz2
+ if [ "${PROFILE_ARCH}" == "xbox" ]; then
+ epatch ${FILESDIR}/lirc-0.7.0-xbox.patch.bz2
+ fi
+ sed -i -e "s:-O2 -g:${CFLAGS}:" configure configure.in
+}
+
+src_compile() {
+ # set default configure options
+ [ "x${LIRC_OPTS}" = x ] && [ "${PROFILE_ARCH}" == "xbox" ] && \
+ LIRC_OPTS="--with-driver=xboxusb"
+ [ "x${LIRC_OPTS}" = x ] && LIRC_OPTS="--with-driver=serial \
+ --with-port=0x3f8 --with-irq=4"
+
+ # remove parallel driver on SMP systems
+ if [ ! -z "`uname -v | grep SMP`" ]
+ then
+ sed -i -e "s:lirc_parallel::" drivers/Makefile
+ fi
+
+ # Patch bad configure for /usr/src/linux
+ sed -si "s|/usr/src/kernel\-source\-\`uname \-r\` /usr/src/linux\-\`uname \-r\` ||" \
+ acinclude.m4 aclocal.m4 configure || die "/usr/src/linux sed failed"
+
+ get_version
+ sed -si "s|\`uname \-r\`|${KV_FULL}|" configure configure.in setup.sh || \
+ die "/lib/modules sed failed"
+
+ unset ARCH
+ econf \
+ --disable-manage-devices \
+ --localstatedir=/var \
+ --with-syslog=LOG_DAEMON \
+ --enable-sandboxed \
+ `use_enable debug` \
+ ${LIRC_OPTS} || die "./configure failed"
+
+ convert_to_m ${S}/Makefile
+ emake || die
+
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/lircd
+ doexe ${FILESDIR}/lircmd
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/lircd.conf lircd
+
+ if use doc ; then
+ dohtml doc/html/*.html
+ insinto /usr/share/doc/${PF}/images
+ doins doc/images/*
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The lirc Linux Infrared Remote Control Package has been"
+ einfo "merged, please read the documentation, and if necessary"
+ einfo "add what is needed to /etc/modules.autoload or"
+ einfo "/etc/modules.d. If you need special compile options"
+ einfo "then read the comments at the begin of this"
+ einfo "ebuild (source) and set the LIRC_OPTS environment"
+ einfo "variable to your needs."
+ einfo
+
+ update_depmod
+}