summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-02-13 21:37:20 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-02-13 21:37:20 +0000
commit69fe65719448efa07d00c1c84bafc8dc1b029aab (patch)
tree3da82d222db65c6af0a0d0b4e1e7abadd79095f1 /app-misc/livecd-tools/livecd-tools-1.0.35.ebuild
parentCleanup (diff)
downloadgentoo-2-69fe65719448efa07d00c1c84bafc8dc1b029aab.tar.gz
gentoo-2-69fe65719448efa07d00c1c84bafc8dc1b029aab.tar.bz2
gentoo-2-69fe65719448efa07d00c1c84bafc8dc1b029aab.zip
Version bump to livecd-tools 1.0.35 with only a couple minor changes. First, we always try to return RC_COLDPLUG to its original state at boot. Second, we no longer manually run dhcpcd, but let udev/baselayout take care of it, entirely. Since this is a required fix for 2007.0, I am taking it straight to stable so it can make it into the snapshot in time. It is a very minor change, and I don't think anyone will object to having working release media.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-misc/livecd-tools/livecd-tools-1.0.35.ebuild')
-rw-r--r--app-misc/livecd-tools/livecd-tools-1.0.35.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/livecd-tools/livecd-tools-1.0.35.ebuild b/app-misc/livecd-tools/livecd-tools-1.0.35.ebuild
new file mode 100644
index 000000000000..5dea1b7ddb06
--- /dev/null
+++ b/app-misc/livecd-tools/livecd-tools-1.0.35.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/livecd-tools/livecd-tools-1.0.35.ebuild,v 1.1 2007/02/13 21:37:20 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo LiveCD tools for autoconfiguration of hardware"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/sources/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+#KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86"
+IUSE="opengl X"
+
+OPENGL_DEPEND="virtual/opengl
+ x11-misc/mkxf86config
+ || (
+ app-admin/eselect-opengl
+ >=x11-base/opengl-update-2.2.1 )"
+
+RDEPEND="dev-util/dialog
+ sys-apps/pciutils
+ sys-apps/gawk
+ alpha? ( opengl? ( ${OPENGL_DEPEND} )
+ X? ( >=x11-misc/mkxf86config-0.9.7 ) )
+ amd64? ( opengl? ( ${OPENGL_DEPEND} )
+ X? ( >=x11-misc/mkxf86config-0.9.2 ) )
+ x86? ( opengl? ( ${OPENGL_DEPEND} )
+ X? ( x11-misc/mkxf86config ) )
+ ppc? ( opengl? ( ${OPENGL_DEPEND} )
+ X? ( >=x11-misc/mkxf86config-0.9.7 ) )"
+
+src_install() {
+ doinitd autoconfig
+ newinitd spind.init spind
+ if use x86 || use amd64 || use ppc
+ then
+ if use opengl
+ then
+ dosbin x-setup openglify
+ newinitd x-setup.init x-setup
+ fi
+ fi
+ dosbin net-setup spind
+ into /
+ dobin bashlogin
+ dosbin livecd-functions.sh
+}