summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-02-15 11:33:39 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-02-15 11:33:39 +0000
commitf6457947b5049fffe6d56be740b8248d41ef6f0e (patch)
tree981d66251389b3a2dadc970a0160837f6fbf50fa /app-misc/mplinuxman
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-f6457947b5049fffe6d56be740b8248d41ef6f0e.tar.gz
gentoo-2-f6457947b5049fffe6d56be740b8248d41ef6f0e.tar.bz2
gentoo-2-f6457947b5049fffe6d56be740b8248d41ef6f0e.zip
A gtk2 frontend for mpman f50/55/60 mp3 players. Uses in-kernel USB modules to communicate with the device. Ebuild submitted by Alastair Murray <alastairmurray@hotmail.com> in bug #40615.
Diffstat (limited to 'app-misc/mplinuxman')
-rw-r--r--app-misc/mplinuxman/ChangeLog12
-rw-r--r--app-misc/mplinuxman/Manifest2
-rw-r--r--app-misc/mplinuxman/files/digest-mplinuxman-1.41
-rw-r--r--app-misc/mplinuxman/metadata.xml5
-rw-r--r--app-misc/mplinuxman/mplinuxman-1.4.ebuild43
5 files changed, 63 insertions, 0 deletions
diff --git a/app-misc/mplinuxman/ChangeLog b/app-misc/mplinuxman/ChangeLog
new file mode 100644
index 000000000000..93504fee88f8
--- /dev/null
+++ b/app-misc/mplinuxman/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-misc/mplinuxman
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mplinuxman/ChangeLog,v 1.1 2004/02/15 11:33:39 eradicator Exp $
+
+*mplinuxman-1.4 (15 Feb 2004)
+
+ 15 Feb 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ mplinuxman-1.4.ebuild:
+ A gtk2 frontend for mpman f50/55/60 mp3 players. Uses in-kernel USB modules to
+ communicate with the device. Ebuild submitted by Alastair Murray
+ <alastairmurray@hotmail.com> in bug #40615.
+
diff --git a/app-misc/mplinuxman/Manifest b/app-misc/mplinuxman/Manifest
new file mode 100644
index 000000000000..983ea5a2e4fa
--- /dev/null
+++ b/app-misc/mplinuxman/Manifest
@@ -0,0 +1,2 @@
+MD5 a0e0275c4123979a5a73e5833d8f17c6 mplinuxman-1.4.ebuild 1192
+MD5 42127f98c4194df34f0925f654180090 files/digest-mplinuxman-1.4 72
diff --git a/app-misc/mplinuxman/files/digest-mplinuxman-1.4 b/app-misc/mplinuxman/files/digest-mplinuxman-1.4
new file mode 100644
index 000000000000..c0c192500d9a
--- /dev/null
+++ b/app-misc/mplinuxman/files/digest-mplinuxman-1.4
@@ -0,0 +1 @@
+MD5 c830925640e3df96f5fa4a7f53b04e15 mplinuxman-source-1.4.tar.gz 95342
diff --git a/app-misc/mplinuxman/metadata.xml b/app-misc/mplinuxman/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/app-misc/mplinuxman/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/app-misc/mplinuxman/mplinuxman-1.4.ebuild b/app-misc/mplinuxman/mplinuxman-1.4.ebuild
new file mode 100644
index 000000000000..917710a353ae
--- /dev/null
+++ b/app-misc/mplinuxman/mplinuxman-1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mplinuxman/mplinuxman-1.4.ebuild,v 1.1 2004/02/15 11:33:39 eradicator Exp $
+
+DESCRIPTION="A gtk2 frontend and drivers for mpman f50/55/60 mp3 players."
+HOMEPAGE="http://mplinuxman.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="nls"
+DEPEND=">=x11-libs/gtk+-2.2.4-r1
+ >=sys-apps/sed-4
+ nls? ( >=sys-devel/gettext-0.12.1 )"
+
+S=${WORKDIR}/${PN}
+src_unpack() {
+ unpack ${A} && cd ${S} || die "unpack failed"
+ sed -i -e "s,^CFLAGS = ,CFLAGS = ${CFLAGS} ," makefile
+ sed -i -e "s,export LOCALE_DIR=/usr/local/share/locale,export LOCALE_DIR=${D}/usr/share/locale," makefile
+ if [ ! `use nls` ] ; then
+ sed -i -e "s,-D NLS=1,," makefile
+ fi
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin mplinuxman || die "dobin failed"
+ if [ `use nls` ] ; then
+ dodir /usr/share/locale/es/LC_MESSAGES
+ dodir /usr/share/locale/fr/LC_MESSAGES
+ dodir /usr/share/locale/ja/LC_MESSAGES
+ dodir /usr/share/locale/nl/LC_MESSAGES
+ dodir /usr/share/locale/de/LC_MESSAGES
+ DESTDIR="${D}" make install-po
+ fi
+ dodoc CHANGES COPYING README
+}