summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-02-09 12:15:28 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-02-09 12:15:28 +0000
commit42663c691ca0a43bc07ff979da3239240955cc0b (patch)
tree40a536e3f992a4207811362593d33cafa151cdbc /app-misc/oneko
parentadded SLOT to all net-im ebuilds, removed old version, and (diff)
downloadgentoo-2-42663c691ca0a43bc07ff979da3239240955cc0b.tar.gz
gentoo-2-42663c691ca0a43bc07ff979da3239240955cc0b.tar.bz2
gentoo-2-42663c691ca0a43bc07ff979da3239240955cc0b.zip
initial ebuild, with SLOT
Diffstat (limited to 'app-misc/oneko')
-rw-r--r--app-misc/oneko/files/digest-oneko-1.21
-rw-r--r--app-misc/oneko/oneko-1.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/oneko/files/digest-oneko-1.2 b/app-misc/oneko/files/digest-oneko-1.2
new file mode 100644
index 000000000000..9acbb89ea1e6
--- /dev/null
+++ b/app-misc/oneko/files/digest-oneko-1.2
@@ -0,0 +1 @@
+MD5 890a476b54e13bfd4ab21440c6a5a8e2 oneko-1.2.tar.gz 56353
diff --git a/app-misc/oneko/oneko-1.2.ebuild b/app-misc/oneko/oneko-1.2.ebuild
new file mode 100644
index 000000000000..c85fd982ad85
--- /dev/null
+++ b/app-misc/oneko/oneko-1.2.ebuild
@@ -0,0 +1,29 @@
+#Copyright 2002 Gentoo Technologies, Inc.
+#Distributed under the terms of the GNU General Public License v2
+#Author John Stalker <stalker@math.princeton.edu>
+#$Header: /var/cvsroot/gentoo-x86/app-misc/oneko/oneko-1.2.ebuild,v 1.1 2002/02/09 12:15:28 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A cat (or dog) which chases the mouse around the screen"
+SRC_URI="http://agtoys.sourceforge.net/oneko/${P}.tar.gz"
+HOMEPAGE="http://agtoys.sourceforge.net"
+SLOT="0"
+DEPEND="virtual/glibc
+ >=x11-base/xfree-4.1.0"
+
+src_compile() {
+
+ xmkmf -a || die
+ emake || die
+}
+
+src_install () {
+
+ into /usr
+ dobin oneko
+ mv oneko._man oneko.1x
+ doman oneko.1x
+ dodoc oneko.1x.html oneko.1.html README README-NEW
+}
+
+