summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-12 04:01:11 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-12 04:01:11 +0000
commit384608604286f62c878180ef074f7c85a6fce057 (patch)
tree6a8b899115beb86e2b07f34ca62d6cee8d002128 /app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild
parentold (diff)
downloadgentoo-2-384608604286f62c878180ef074f7c85a6fce057.tar.gz
gentoo-2-384608604286f62c878180ef074f7c85a6fce057.tar.bz2
gentoo-2-384608604286f62c878180ef074f7c85a6fce057.zip
Fix scanelf hang due to grep-style changes with stdin #128247 by Matteo Azzali.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild b/app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild
new file mode 100644
index 000000000000..81787b2a5e6e
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.1.11-r1.ebuild,v 1.1 2006/04/12 04:01:11 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="Various ELF related utils for ELF32, ELF64 binaries useful tools that can check files for security relevant properties"
+HOMEPAGE="http://hardened.gentoo.org/pax-utils.xml"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~flameeyes/dist/pax-utils-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="caps"
+
+DEPEND="caps? ( sys-libs/libcap )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_compile() {
+ use caps && append-flags -DWANT_SYSCAP
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" dumpelf scanelf || die
+ use caps && append-ldflags -lcap
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" pspax || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+}