summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 04:08:38 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 04:08:38 +0000
commitbc3e4093f4b7f3a63a4531462693e04b12e7dbd8 (patch)
tree0761b918a90dcb763c68eeb1ebec88813594f1b6 /app-misc/pax-utils
parent~mips (diff)
downloadgentoo-2-bc3e4093f4b7f3a63a4531462693e04b12e7dbd8.tar.gz
gentoo-2-bc3e4093f4b7f3a63a4531462693e04b12e7dbd8.tar.bz2
gentoo-2-bc3e4093f4b7f3a63a4531462693e04b12e7dbd8.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc/pax-utils')
-rw-r--r--app-misc/pax-utils/pax-utils-0.0.1.ebuild21
-rw-r--r--app-misc/pax-utils/pax-utils-0.0.2.ebuild21
2 files changed, 22 insertions, 20 deletions
diff --git a/app-misc/pax-utils/pax-utils-0.0.1.ebuild b/app-misc/pax-utils/pax-utils-0.0.1.ebuild
index 8562572a1679..f7cb3ef18dc5 100644
--- a/app-misc/pax-utils/pax-utils-0.0.1.ebuild
+++ b/app-misc/pax-utils/pax-utils-0.0.1.ebuild
@@ -1,27 +1,28 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.0.1.ebuild,v 1.6 2004/06/24 22:28:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.0.1.ebuild,v 1.7 2004/06/28 04:08:05 vapier Exp $
-S=${WORKDIR}/${PN}
-
-DESCRIPTION="Various PaX related utils for ELF32, ELF64 binaries."
+DESCRIPTION="Various PaX related utils for ELF32, ELF64 binaries"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened"
SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.gz
http://dev.gentoo.org/~solar/elf/pax-utils-${PV}.tar.gz
http://pageexec.virtualave.net/pax-utils-${PV}.tar.gz"
-HOMEPAGE="http://www.gentoo.org/proj/en/hardened"
-KEYWORDS="~x86 ~sparc ~ppc ~hppa ~amd64 ~ia64"
+
LICENSE="GPL-2"
SLOT="0"
-
+KEYWORDS="~x86 ~sparc ~ppc ~hppa ~amd64 ~ia64"
IUSE="debug"
-DEPEND="virtual/glibc"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${PN}
src_compile() {
use debug && export STRIP=touch
- MAKEOPTS=-j1 emake || die
+ emake -j1 || die
}
src_install() {
- emake DESTDIR=${D} install
+ emake DESTDIR=${D} install || die
dodoc README
}
diff --git a/app-misc/pax-utils/pax-utils-0.0.2.ebuild b/app-misc/pax-utils/pax-utils-0.0.2.ebuild
index 36242b1c4948..48286963741c 100644
--- a/app-misc/pax-utils/pax-utils-0.0.2.ebuild
+++ b/app-misc/pax-utils/pax-utils-0.0.2.ebuild
@@ -1,27 +1,28 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.0.2.ebuild,v 1.4 2004/06/24 22:28:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.0.2.ebuild,v 1.5 2004/06/28 04:08:05 vapier Exp $
-S=${WORKDIR}/${PN}
-
-DESCRIPTION="Various PaX related utils for ELF32, ELF64 binaries."
+DESCRIPTION="Various PaX related utils for ELF32, ELF64 binaries"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened"
SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.gz
http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.gz
http://pageexec.virtualave.net/pax-utils-${PV}.tar.gz"
-HOMEPAGE="http://www.gentoo.org/proj/en/hardened"
-KEYWORDS="x86 sparc ~ppc ~hppa ~amd64 ~ia64"
+
LICENSE="GPL-2"
SLOT="0"
-
+KEYWORDS="x86 ~ppc sparc ~hppa ~amd64 ~ia64"
IUSE="debug"
-DEPEND="virtual/glibc"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${PN}
src_compile() {
use debug && export STRIP=touch
- MAKEOPTS=-j1 emake CFLAGS="${CFLAGS}" || die
+ emake -j1 CFLAGS="${CFLAGS}" || die
}
src_install() {
- emake DESTDIR=${D} install
+ make DESTDIR=${D} install || die
dodoc README
}