summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 04:13:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 04:13:52 +0000
commit1946ff5663a89304da65e5d134eed6477794c342 (patch)
treef25735bdc6c43575a0f6f591c81bba6adf18575d /app-misc/sl
parentdont apply query_user_context patch with USE=livecd (Manifest recommit) (diff)
downloadgentoo-2-1946ff5663a89304da65e5d134eed6477794c342.tar.gz
gentoo-2-1946ff5663a89304da65e5d134eed6477794c342.tar.bz2
gentoo-2-1946ff5663a89304da65e5d134eed6477794c342.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc/sl')
-rw-r--r--app-misc/sl/sl-3.03.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/app-misc/sl/sl-3.03.ebuild b/app-misc/sl/sl-3.03.ebuild
index 8112af16f15f..632bcfb10988 100644
--- a/app-misc/sl/sl-3.03.ebuild
+++ b/app-misc/sl/sl-3.03.ebuild
@@ -1,16 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sl/sl-3.03.ebuild,v 1.4 2004/06/24 22:33:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sl/sl-3.03.ebuild,v 1.5 2004/06/28 04:13:13 vapier Exp $
inherit eutils
-IUSE="cjk"
-
SL_PATCH="sl5-1.patch"
-DESCRIPTION="SL is a sophisticated graphical program which corrects your miss typing"
-HOMEPAGE="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/
- http://www.linet.gr.jp/~izumi/sl/"
+DESCRIPTION="sophisticated graphical program which corrects your miss typing"
+HOMEPAGE="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/ http://www.linet.gr.jp/~izumi/sl/"
SRC_URI="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/sl/${PN}.tar
http://www.linet.gr.jp/~izumi/sl/${SL_PATCH}
http://www.sodan.ecc.u-tokyo.ac.jp/~okayama/sl/${PN}.en.1.gz"
@@ -18,17 +15,17 @@ SRC_URI="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/sl/${PN}.tar
LICENSE="freedist"
SLOT="0"
KEYWORDS="x86 alpha ~sparc"
+IUSE="cjk"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/ncurses
cjk? ( app-i18n/nkf )"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
sys-libs/ncurses"
S=${WORKDIR}/${PN}
src_unpack() {
-
unpack ${PN}.tar
cd ${S}
epatch ${DISTDIR}/${SL_PATCH}
@@ -37,7 +34,6 @@ src_unpack() {
}
src_compile() {
-
emake CFLAGS="${CFLAGS}" LDFLAGS="-lncurses" || die
if use cjk; then
nkf -e sl.1 > sl.ja.1
@@ -45,8 +41,7 @@ src_compile() {
}
src_install() {
-
- dobin sl
+ dobin sl || die
newman sl.en.1 sl.1
dodoc README* sl.txt
if use cjk ; then