summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-04 06:54:09 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-04 06:54:09 +0000
commit81ea686c358490285eba496c18eab599ea4aaf5c (patch)
tree078dc7a4fbf8977a54c6cd2d27b162d0d484e5cc /app-misc/when
parentUpdated to latest upstream release; closes bug 338961. (diff)
downloadgentoo-2-81ea686c358490285eba496c18eab599ea4aaf5c.tar.gz
gentoo-2-81ea686c358490285eba496c18eab599ea4aaf5c.tar.bz2
gentoo-2-81ea686c358490285eba496c18eab599ea4aaf5c.zip
Version Bump, 339636
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/when')
-rw-r--r--app-misc/when/ChangeLog7
-rw-r--r--app-misc/when/when-1.1.21.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/app-misc/when/ChangeLog b/app-misc/when/ChangeLog
index d23af519d330..633d65728b4b 100644
--- a/app-misc/when/ChangeLog
+++ b/app-misc/when/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/when
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/when/ChangeLog,v 1.37 2010/07/23 02:45:38 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/when/ChangeLog,v 1.38 2010/10/04 06:54:09 jlec Exp $
+
+*when-1.1.21 (04 Oct 2010)
+
+ 04 Oct 2010; Justin Lecher <jlec@gentoo.org> +when-1.1.21.ebuild:
+ Version Bump, 339636
*when-1.1.20 (23 Jul 2010)
diff --git a/app-misc/when/when-1.1.21.ebuild b/app-misc/when/when-1.1.21.ebuild
new file mode 100644
index 000000000000..e7a505137834
--- /dev/null
+++ b/app-misc/when/when-1.1.21.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/when/when-1.1.21.ebuild,v 1.1 2010/10/04 06:54:09 jlec Exp $
+
+EAPI=3
+
+inherit eutils prefix
+
+DESCRIPTION="Extremely simple personal calendar program aimed at the Unix geek who wants something minimalistic"
+HOMEPAGE="http://www.lightandmatter.com/when/when.html"
+SRC_URI="http://www.lightandmatter.com/when/when.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/when_dist
+
+src_prepare() {
+ # Fix path for tests
+ sed -i 's,^ when, ./when,' Makefile
+}
+
+src_compile() { :; }
+
+src_test() {
+ # The when command requires these files, or attempts to run setup function.
+ mkdir "${HOME}"/.when
+ touch "${HOME}"/.when/{calendar,preferences}
+ emake test || die "emake test failed"
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+ doman ${PN}.1 || die "doman failed"
+ dodoc README || die
+}