summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-21 14:09:44 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-21 14:09:44 +0000
commit155b405325116f5b11d51c15085b1d68971dc983 (patch)
treefde76c4ea402ed5a245209e87191b84f43f5887e /app-misc
parentamd64 stable wrt bug #551814 (diff)
downloadgentoo-2-155b405325116f5b11d51c15085b1d68971dc983.tar.gz
gentoo-2-155b405325116f5b11d51c15085b1d68971dc983.tar.bz2
gentoo-2-155b405325116f5b11d51c15085b1d68971dc983.zip
Add patch for format-security; bump to EAPI=5
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/cw/ChangeLog8
-rw-r--r--app-misc/cw/cw-1.0.16-r3.ebuild63
-rw-r--r--app-misc/cw/files/1.0.16-format-security.patch16
3 files changed, 86 insertions, 1 deletions
diff --git a/app-misc/cw/ChangeLog b/app-misc/cw/ChangeLog
index d73be1c1adb6..129b2099c147 100644
--- a/app-misc/cw/ChangeLog
+++ b/app-misc/cw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/cw
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cw/ChangeLog,v 1.34 2015/06/09 11:38:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cw/ChangeLog,v 1.35 2015/06/21 14:09:44 jlec Exp $
+
+*cw-1.0.16-r3 (21 Jun 2015)
+
+ 21 Jun 2015; Justin Lecher <jlec@gentoo.org> +cw-1.0.16-r3.ebuild,
+ +files/1.0.16-format-security.patch:
+ Add patch for format-security; bump to EAPI=5
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/app-misc/cw/cw-1.0.16-r3.ebuild b/app-misc/cw/cw-1.0.16-r3.ebuild
new file mode 100644
index 000000000000..b88a14e31d7c
--- /dev/null
+++ b/app-misc/cw/cw-1.0.16-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cw/cw-1.0.16-r3.ebuild,v 1.1 2015/06/21 14:09:44 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A non-intrusive real-time ANSI color wrapper for common unix-based commands"
+HOMEPAGE="http://cwrapper.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cwrapper/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-path.patch \
+ "${FILESDIR}"/${PV}-collision.patch \
+ "${FILESDIR}"/${PV}-format-security.patch
+ tc-export CC
+}
+
+src_compile() {
+ emake local
+}
+
+src_install() {
+ insinto /usr/share/cw
+ doins etc/*
+
+ exeinto /usr/libexec/cw
+ doexe def/*
+
+ doman man/cwu*
+ newman man/cw.* color-wrapper
+ dodoc CHANGES CONTRIB INSTALL README PLATFORM doc/README*
+
+ dobin bin/{cwu,colorcfg}
+ # app-misc/color currently conflicts; hopefully 'colors' is safe
+ newbin bin/color colors
+ # media-radio/unixcw currently conflicts;
+ newbin bin/cw color-wrapper
+}
+
+pkg_postinst() {
+ ebegin "Updating definition files"
+ cwu /usr/libexec/cw /usr/bin/color-wrapper # >/dev/null
+ eend $?
+
+ elog "To enable color-wrapper, as your user, run:"
+ elog " colorcfg [1|2|3]"
+ elog "to add relevant environment variables to your ~/.bash_profile"
+ elog "Run colorcfg without options to see what [1|2|3] means."
+ elog
+ elog "After sourcing your ~/.bash_profile, commands for which definitions"
+ elog "are provided should have colored output."
+ elog
+ elog "To enable/disable colored output, run: 'colors [on|off]'."
+}
diff --git a/app-misc/cw/files/1.0.16-format-security.patch b/app-misc/cw/files/1.0.16-format-security.patch
new file mode 100644
index 000000000000..20f0b1d06b1e
--- /dev/null
+++ b/app-misc/cw/files/1.0.16-format-security.patch
@@ -0,0 +1,16 @@
+ src/cw.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/cw.c b/src/cw.c
+index d7b4875..3ec1ac1 100644
+--- a/src/cw.c
++++ b/src/cw.c
+@@ -643,7 +643,7 @@ void sighandler(signed int sig){
+ else if(sig==SIGUSR1)ext=1;
+ else if(sig==SIGALRM)ext=2;
+ else if(sig==SIGPIPE||sig==SIGINT){
+- fprintf(stderr,pal2[16]);
++ fprintf(stderr,"%s", pal2[16]);
+ fflush(stderr);
+ cwexit(0,0);
+ }