summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-10-04 18:48:29 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-10-04 18:48:29 +0000
commit719f1f4c8fb2ecb2351319ed6450f26618b8ff52 (patch)
treea4a90cd38a0a4bc226a1501cdeea7e76a944cf08 /app-misc
parentStable on alpha, bug #286279 (diff)
downloadgentoo-2-719f1f4c8fb2ecb2351319ed6450f26618b8ff52.tar.gz
gentoo-2-719f1f4c8fb2ecb2351319ed6450f26618b8ff52.tar.bz2
gentoo-2-719f1f4c8fb2ecb2351319ed6450f26618b8ff52.zip
Revision bump that will fix some new and some old issues:
* Merge mceusb and mceusb2 driver (bug 286269 by candrews AT integralblue DOT com) * New init.d file that will keep the old socket location so we don't break all applications (thanks to Oldrich Jedlicka <oldium DOT pro AT seznam DOT cz> in bug 286451) * Add new ene0100 device * Correct entry for iguanaIR device (bug 208785 by MasterC <MasterCLC AT gmail DOT com>) * Fix DEPEND and RDEPEND relations (Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/lirc/ChangeLog19
-rw-r--r--app-misc/lirc/files/lircd-0.8.639
-rw-r--r--app-misc/lirc/lirc-0.8.5.ebuild4
-rw-r--r--app-misc/lirc/lirc-0.8.6-r1.ebuild (renamed from app-misc/lirc/lirc-0.8.6.ebuild)62
4 files changed, 87 insertions, 37 deletions
diff --git a/app-misc/lirc/ChangeLog b/app-misc/lirc/ChangeLog
index 3e89307cead3..f9c52877b8a5 100644
--- a/app-misc/lirc/ChangeLog
+++ b/app-misc/lirc/ChangeLog
@@ -1,9 +1,24 @@
# ChangeLog for app-misc/lirc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.208 2009/10/04 13:41:14 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.209 2009/10/04 18:48:28 fauli Exp $
+
+*lirc-0.8.6-r1 (04 Oct 2009)
+
+ 04 Oct 2009; Christian Faulhammer <fauli@gentoo.org> +files/lircd-0.8.6,
+ -lirc-0.8.6.ebuild, +lirc-0.8.6-r1.ebuild:
+ Revision bump that will fix some new and some old issues:
+ * Merge mceusb and mceusb2 driver (bug 286269 by candrews AT integralblue
+ DOT com)
+ * New init.d file that will keep the old socket location so we don't break
+ all applications (thanks to Oldrich Jedlicka <oldium DOT pro AT seznam DOT
+ cz> in bug 286451)
+ * Add new ene0100 device
+ * Correct entry for iguanaIR device (bug 208785 by MasterC <MasterCLC AT
+ gmail DOT com>)
+ * Fix DEPEND and RDEPEND relations
04 Oct 2009; Christian Faulhammer <fauli@gentoo.org> lirc-0.8.5.ebuild:
- read stable keywords that have been accidentally removed
+ readd stable keywords that have been accidentally removed
03 Oct 2009; Christian Faulhammer <fauli@gentoo.org> lirc-0.8.5.ebuild:
Rework dependencies:
diff --git a/app-misc/lirc/files/lircd-0.8.6 b/app-misc/lirc/files/lircd-0.8.6
new file mode 100644
index 000000000000..0a775a5e4b2e
--- /dev/null
+++ b/app-misc/lirc/files/lircd-0.8.6
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/files/lircd-0.8.6,v 1.1 2009/10/04 18:48:29 fauli Exp $
+
+PIDFILE=/var/run/lirc/${SVCNAME}.pid
+LIRCD_SYMLINKFILE=/dev/lircd
+LIRCD_SOCKET=/var/run/lirc/lircd
+
+depend() {
+ provide lirc
+}
+
+start() {
+ local retval
+ ebegin "Starting lircd"
+ rm -f ${LIRCD_SOCKET} && ln -s ${LIRCD_SOCKET} ${LIRCD_SYMLINKFILE}
+ if [ $? -ne 0 ]; then
+ eend $? "Unable to create symbolic link ${LIRCD_SYMLINKFILE}"
+ return 1
+ fi
+
+ start-stop-daemon --start --quiet --pidfile "${PIDFILE}" --exec /usr/sbin/lircd -- \
+ -P "${PIDFILE}" ${LIRCD_OPTS}
+ retval=$?
+
+ if [ ${retval} -ne 0 ]; then
+ rm -f ${LIRCD_SOCKET}
+ fi
+
+ eend ${retval}
+}
+
+stop() {
+ ebegin "Stopping lircd"
+ rm -f ${LIRCD_SYMLINKFILE}
+ start-stop-daemon --stop --quiet --pidfile "${PIDFILE}" --exec /usr/sbin/lircd
+ eend $?
+}
diff --git a/app-misc/lirc/lirc-0.8.5.ebuild b/app-misc/lirc/lirc-0.8.5.ebuild
index e045ea0e2519..b29026946a33 100644
--- a/app-misc/lirc/lirc-0.8.5.ebuild
+++ b/app-misc/lirc/lirc-0.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.5.ebuild,v 1.7 2009/10/04 13:41:14 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.5.ebuild,v 1.8 2009/10/04 18:48:28 fauli Exp $
inherit eutils linux-mod flag-o-matic autotools
@@ -44,7 +44,7 @@ IUSE_LIRC_DEVICES_DIRECT="
devinput digimatrix dsp dvico ea65
exaudio flyvideo ftdi gvbctv5pci hauppauge
hauppauge_dvb hercules_smarttv_stereo i2cuser
- igorplugusb iguana imon imon_24g imon_knob
+ igorplugusb iguanaIR imon imon_24g imon_knob
imon_lcd imon_pad imon_rsc irdeo irdeo_remote
irlink irman irreal it87 ite8709
knc_one kworld leadtek_0007 leadtek_0010
diff --git a/app-misc/lirc/lirc-0.8.6.ebuild b/app-misc/lirc/lirc-0.8.6-r1.ebuild
index 254c243bf405..67519e10c066 100644
--- a/app-misc/lirc/lirc-0.8.6.ebuild
+++ b/app-misc/lirc/lirc-0.8.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.6.ebuild,v 1.1 2009/09/23 14:45:06 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.6-r1.ebuild,v 1.1 2009/10/04 18:48:28 fauli Exp $
inherit eutils linux-mod flag-o-matic autotools
@@ -17,7 +17,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="debug doc X hardware-carrier transmitter"
S="${WORKDIR}/${MY_P}"
@@ -41,16 +41,16 @@ IUSE_LIRC_DEVICES_DIRECT="
avermedia98 awlibusb bestbuy bestbuy2 breakoutbox
bte bw6130 caraca chronos commandir
cph06x creative creative_infracd
- devinput digimatrix dsp dvico ea65
+ devinput digimatrix dsp dvico ea65 ene0100
exaudio flyvideo ftdi gvbctv5pci hauppauge
hauppauge_dvb hercules_smarttv_stereo i2cuser
- igorplugusb iguana imon imon_24g imon_knob
+ igorplugusb iguanaIR imon imon_24g imon_knob
imon_lcd imon_pad imon_rsc irdeo irdeo_remote
irlink irman irreal it87 ite8709
knc_one kworld leadtek_0007 leadtek_0010
leadtek_pvr2000 livedrive_midi
livedrive_seq logitech macmini mceusb
- mceusb2 mediafocusI mouseremote
+ mediafocusI mouseremote
mouseremote_ps2 mp3anywhere mplay nslu2
packard_bell parallel pcmak pcmak_usb
pctv pixelview_bt878 pixelview_pak
@@ -72,25 +72,23 @@ IUSE_LIRC_DEVICES="${IUSE_LIRC_DEVICES_DIRECT} ${IUSE_LIRC_DEVICES_SPECIAL}"
#device-driver which use libusb
LIBUSB_USED_BY_DEV="
all atilibusb awlibusb sasem igorplugusb imon imon_lcd imon_pad
- imon_rsc streamzap mceusb mceusb2 xboxusb irlink commandir"
+ imon_rsc streamzap mceusb xboxusb irlink commandir"
for dev in ${LIBUSB_USED_BY_DEV}; do
- RDEPEND="${RDEPEND} lirc_devices_${dev}? ( dev-libs/libusb )"
+ DEPEND="${DEPEND} lirc_devices_${dev}? ( dev-libs/libusb )"
done
-RDEPEND="${RDEPEND}
- lirc_devices_ftdi? ( dev-embedded/libftdi )"
-
# adding only compile-time depends
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND} ${DEPEND}
virtual/linux-sources
+ lirc_devices_ftdi? ( dev-embedded/libftdi )
lirc_devices_all? ( dev-embedded/libftdi )"
# adding only run-time depends
RDEPEND="${RDEPEND}
lirc_devices_usbirboy? ( app-misc/usbirboy )
lirc_devices_inputlirc? ( app-misc/inputlircd )
- lirc_devices_iguana? ( app-misc/iguanaIR )"
+ lirc_devices_iguanaIR? ( app-misc/iguanaIR )"
# add all devices to IUSE
for dev in ${IUSE_LIRC_DEVICES}; do
@@ -124,6 +122,12 @@ add_device() {
pkg_setup() {
+ if use lirc_devices_mceusb2
+ then
+ ewarn "The mceusb2 driver has been merged into the mceusb."
+ ewarn "Please only use the latter now."
+ fi
+
ewarn "If your LIRC device requires modules, you'll need MODULE_UNLOAD"
ewarn "support in your kernel."
@@ -280,7 +284,7 @@ src_unpack() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- newinitd "${FILESDIR}"/lircd-0.8.3 lircd
+ newinitd "${FILESDIR}"/lircd-0.8.6 lircd
newinitd "${FILESDIR}"/lircmd lircmd
newconfd "${FILESDIR}"/lircd.conf.2 lircd
@@ -298,41 +302,33 @@ src_install() {
insinto /usr/share/lirc/remotes
doins -r remotes/*
+
+ keepdir /var/run/lirc
}
pkg_preinst() {
linux-mod_pkg_preinst
local dir="${ROOT}/etc/modprobe.d"
- if [[ -a ${dir}/lirc && ! -a ${dir}/lirc.conf ]]; then
+ if [[ -a "${dir}"/lirc && ! -a "${dir}"/lirc.conf ]]; then
elog "Renaming ${dir}/lirc to lirc.conf"
mv -f "${dir}/lirc" "${dir}/lirc.conf"
fi
# stop portage from deleting this file
- if [[ -f ${ROOT}/etc/lircd.conf && ! -f ${D}/etc/lircd.conf ]]; then
- cp "${ROOT}"/etc/lircd.conf "${D}"/etc/lircd.conf
+ if [[ -f "${ROOT}"/etc/lirc/lircd.conf && ! -f "${D}"/etc/lirc/lircd.conf ]]; then
+ cp "${ROOT}"/etc/lirc/lircd.conf "${D}"/etc/lirc/lircd.conf
fi
}
pkg_postinst() {
linux-mod_pkg_postinst
- echo
- elog "The lirc Linux Infrared Remote Control Package has been"
- elog "merged, please read the documentation at http://www.lirc.org"
- echo
-
- if kernel_is ge 2 6 22 ; then
- # Bug #187418
- ewarn
- ewarn "The lirc_gpio driver will not work with Kernels 2.6.22+"
- ewarn "You need to switch over to /dev/input/event? if you need gpio"
- ewarn "This device can than then be used via lirc's dev/input driver."
- ewarn
- fi
+ ewarn
+ ewarn "The lirc_gpio driver will not work with Kernels 2.6.22+"
+ ewarn "You need to switch over to /dev/input/event? if you need gpio"
+ ewarn "This device can than then be used via lirc's dev/input driver."
+ ewarn
+ ewarn "The new default location for lircd.conf is inside of"
+ ewarn "/etc/lirc/ directory"
- elog
- elog "lirc now uses normal config-protection for lircd.conf."
- elog "If you need any other lircd.conf you may have a look at"
- elog "the directory /usr/share/lirc/remotes"
}