summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-16 15:27:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-16 15:27:38 +0000
commit723eaf03ca4681fb331a99e70d5a0c10b26c8e02 (patch)
treefb6ef85eecf11ebb91f5dc74d18173b65c90f3b0 /app-misc
parentsparc stable wrt #440288 (diff)
downloadgentoo-2-723eaf03ca4681fb331a99e70d5a0c10b26c8e02.tar.gz
gentoo-2-723eaf03ca4681fb331a99e70d5a0c10b26c8e02.tar.bz2
gentoo-2-723eaf03ca4681fb331a99e70d5a0c10b26c8e02.zip
Version bump for Gnome 3.6.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gnote/ChangeLog7
-rw-r--r--app-misc/gnote/gnote-3.6.1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/app-misc/gnote/ChangeLog b/app-misc/gnote/ChangeLog
index 2766c91625ef..c54d894651fe 100644
--- a/app-misc/gnote/ChangeLog
+++ b/app-misc/gnote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gnote
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.25 2012/11/22 08:15:23 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.26 2012/12/16 15:27:38 eva Exp $
+
+*gnote-3.6.1 (16 Dec 2012)
+
+ 16 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org> +gnote-3.6.1.ebuild:
+ Version bump for Gnome 3.6.
22 Nov 2012; Gilles Dartiguelongue <eva@gentoo.org> -gnote-0.7.4.ebuild,
-gnote-0.8.3.ebuild:
diff --git a/app-misc/gnote/gnote-3.6.1.ebuild b/app-misc/gnote/gnote-3.6.1.ebuild
new file mode 100644
index 000000000000..85f0991524fe
--- /dev/null
+++ b/app-misc/gnote/gnote-3.6.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-3.6.1.ebuild,v 1.1 2012/12/16 15:27:38 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://live.gnome.org/Gnote"
+
+LICENSE="GPL-3+"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="debug"
+
+# Automagic glib-2.32 dep
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=dev-cpp/glibmm-2.28:2
+ >=dev-cpp/gtkmm-3.4:3.0
+ >=dev-libs/boost-1.34
+ >=dev-libs/glib-2.32
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16
+ >=x11-libs/gtk+-3:3
+ x11-libs/libX11
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ app-text/yelp-tools"
+fi
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable debug)"
+ [[ ${PV} != 9999 ]] && G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
+
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+}