summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-01-17 18:48:48 +0000
committerChris Reffett <creffett@gentoo.org>2014-01-17 18:48:48 +0000
commit88abb3dd32592557e8026265cdb14b6859b48aa7 (patch)
treebfb686abd10ccf46b230906c35158362e8b7dd0d /app-misc
parentversion bump (diff)
downloadgentoo-2-88abb3dd32592557e8026265cdb14b6859b48aa7.tar.gz
gentoo-2-88abb3dd32592557e8026265cdb14b6859b48aa7.tar.bz2
gentoo-2-88abb3dd32592557e8026265cdb14b6859b48aa7.zip
Revision bump: Add patch to fix compile and not force CFLAGS, EAPI bump, remove prepalldocs call
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/g15mpd/ChangeLog12
-rw-r--r--app-misc/g15mpd/files/g15mpd-1.0.0-cflags-and-lib-fix.patch18
-rw-r--r--app-misc/g15mpd/g15mpd-1.0.0-r1.ebuild (renamed from app-misc/g15mpd/g15mpd-1.0.0.ebuild)14
3 files changed, 36 insertions, 8 deletions
diff --git a/app-misc/g15mpd/ChangeLog b/app-misc/g15mpd/ChangeLog
index c831e6ebb713..878edeaab040 100644
--- a/app-misc/g15mpd/ChangeLog
+++ b/app-misc/g15mpd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/g15mpd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15mpd/ChangeLog,v 1.4 2013/05/13 03:12:00 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15mpd/ChangeLog,v 1.5 2014/01/17 18:48:48 creffett Exp $
+
+*g15mpd-1.0.0-r1 (17 Jan 2014)
+
+ 17 Jan 2014; Chris Reffett <creffett@gentoo.org>
+ +files/g15mpd-1.0.0-cflags-and-lib-fix.patch, +g15mpd-1.0.0-r1.ebuild,
+ -g15mpd-1.0.0.ebuild:
+ Revision bump: Add patch to fix compile and not force CFLAGS, EAPI bump,
+ remove prepalldocs call
13 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove removed lcd herd from metadata
diff --git a/app-misc/g15mpd/files/g15mpd-1.0.0-cflags-and-lib-fix.patch b/app-misc/g15mpd/files/g15mpd-1.0.0-cflags-and-lib-fix.patch
new file mode 100644
index 000000000000..5bdb1261f367
--- /dev/null
+++ b/app-misc/g15mpd/files/g15mpd-1.0.0-cflags-and-lib-fix.patch
@@ -0,0 +1,18 @@
+diff -ruN g15mpd-1.0.0/Makefile.am g15mpd-1.0.0-patched/Makefile.am
+--- g15mpd-1.0.0/Makefile.am 2014-01-17 13:43:28.536056492 -0500
++++ g15mpd-1.0.0-patched/Makefile.am 2014-01-17 13:43:31.596056410 -0500
+@@ -1,12 +1,12 @@
+ AM_CPPFLAGS = @libmpd_CFLAGS@
+-AM_CFLAGS = -O3 -Wall @CFLAGS@ -I$(top_builddir) -I$(top_srcdir)
++AM_CFLAGS = @CFLAGS@ -I$(top_builddir) -I$(top_srcdir)
+ METASOURCES = AUTO
+ bin_PROGRAMS = g15mpd
+
+ docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
+ doc_DATA = README ChangeLog AUTHORS NEWS COPYING
+
+-LIBS = -lg15daemon_client -lg15render -lX11 -lXtst @libmpd_LIBS@
++LIBS = -lpthread -lg15daemon_client -lg15render -lX11 -lXtst @libmpd_LIBS@
+ IMCLUDES = -I
+ g15mpd_LDFLAGS = -avoid-version
+ g15mpd_SOURCES = g15mpd.c
diff --git a/app-misc/g15mpd/g15mpd-1.0.0.ebuild b/app-misc/g15mpd/g15mpd-1.0.0-r1.ebuild
index 4ca029385503..bc48f937709b 100644
--- a/app-misc/g15mpd/g15mpd-1.0.0.ebuild
+++ b/app-misc/g15mpd/g15mpd-1.0.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15mpd/g15mpd-1.0.0.ebuild,v 1.2 2009/05/20 17:17:51 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15mpd/g15mpd-1.0.0-r1.ebuild,v 1.1 2014/01/17 18:48:48 creffett Exp $
-EAPI=2
+EAPI=5
inherit autotools eutils
DESCRIPTION="MPD (music player daemon) plugin to G15daemon"
@@ -14,24 +14,26 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND=">=app-misc/g15daemon-1.9
+RDEPEND="
+ >=app-misc/g15daemon-1.9
dev-libs/libg15
dev-libs/libg15render
>=media-libs/libmpd-0.17
sys-libs/zlib
x11-libs/libX11
- x11-libs/libXtst"
+ x11-libs/libXtst
+"
DEPEND="${RDEPEND}
x11-proto/xproto
x11-proto/xextproto"
src_prepare() {
epatch "${FILESDIR}"/${P}-libmpd.patch
+ epatch "${FILESDIR}/${PN}-1.0.0-cflags-and-lib-fix.patch"
eautoreconf
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
rm "${D}"/usr/share/doc/${P}/{COPYING,NEWS}
- prepalldocs
}