summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2010-04-24 18:02:42 +0000
committerFabio Erculiani <lxnay@gentoo.org>2010-04-24 18:02:42 +0000
commit933fda3dedec8af718fdb1abda85db5bd39e1b1e (patch)
tree585a150bd0f9fb95f0bd09386d25b300bddc9880 /app-misc
parentMarked ~sparc-solaris, bug #314093 (diff)
downloadgentoo-2-933fda3dedec8af718fdb1abda85db5bd39e1b1e.tar.gz
gentoo-2-933fda3dedec8af718fdb1abda85db5bd39e1b1e.tar.bz2
gentoo-2-933fda3dedec8af718fdb1abda85db5bd39e1b1e.zip
fix compilation issue against sqlite, close #306313
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/beagle/ChangeLog6
-rw-r--r--app-misc/beagle/beagle-0.3.9-r1.ebuild6
-rw-r--r--app-misc/beagle/beagle-0.3.9-r2.ebuild6
-rw-r--r--app-misc/beagle/files/beagle-0.3.9-sqlite.patch93
4 files changed, 108 insertions, 3 deletions
diff --git a/app-misc/beagle/ChangeLog b/app-misc/beagle/ChangeLog
index 83358b6b312a..276b89af47e6 100644
--- a/app-misc/beagle/ChangeLog
+++ b/app-misc/beagle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/beagle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/ChangeLog,v 1.105 2010/02/10 20:51:09 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/ChangeLog,v 1.106 2010/04/24 18:02:42 lxnay Exp $
+
+ 24 Apr 2010; Fabio Erculiani <lxnay@gentoo.org> beagle-0.3.9-r1.ebuild,
+ beagle-0.3.9-r2.ebuild, +files/beagle-0.3.9-sqlite.patch:
+ fix compilation issue against sqlite, close #306313
10 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
beagle-0.3.9-r1.ebuild, beagle-0.3.9-r2.ebuild:
diff --git a/app-misc/beagle/beagle-0.3.9-r1.ebuild b/app-misc/beagle/beagle-0.3.9-r1.ebuild
index 9b9ff8ce8aee..ce875b8b46b0 100644
--- a/app-misc/beagle/beagle-0.3.9-r1.ebuild
+++ b/app-misc/beagle/beagle-0.3.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/beagle-0.3.9-r1.ebuild,v 1.7 2010/02/10 20:51:09 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/beagle-0.3.9-r1.ebuild,v 1.8 2010/04/24 18:02:42 lxnay Exp $
EAPI=2
@@ -98,6 +98,10 @@ pkg_setup() {
}
src_prepare() {
+
+ # Fix upstream bug, Gentoo bug #306313
+ epatch "${FILESDIR}"/${P}-sqlite.patch
+
#Fix bug 248703
sed -i -e 's:VALID_EPIPHANY_VERSIONS=":VALID_EPIPHANY_VERSIONS="2.26 2.25 2.24 :' \
configure || die "epiphany sed failed"
diff --git a/app-misc/beagle/beagle-0.3.9-r2.ebuild b/app-misc/beagle/beagle-0.3.9-r2.ebuild
index 2b9e000bfa0f..4bd178adce3c 100644
--- a/app-misc/beagle/beagle-0.3.9-r2.ebuild
+++ b/app-misc/beagle/beagle-0.3.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/beagle-0.3.9-r2.ebuild,v 1.4 2010/02/10 20:51:09 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/beagle-0.3.9-r2.ebuild,v 1.5 2010/04/24 18:02:42 lxnay Exp $
EAPI=2
@@ -96,6 +96,10 @@ pkg_setup() {
}
src_prepare() {
+
+ #Fix upstream bug, Gentoo bug #306313
+ epatch "${FILESDIR}"/${P}-sqlite.patch
+
#Fix bug 248703
sed -i -e 's:VALID_EPIPHANY_VERSIONS=":VALID_EPIPHANY_VERSIONS="2.26 2.25 2.24 :' \
configure.in || die "epiphany sed failed"
diff --git a/app-misc/beagle/files/beagle-0.3.9-sqlite.patch b/app-misc/beagle/files/beagle-0.3.9-sqlite.patch
new file mode 100644
index 000000000000..251b5517752f
--- /dev/null
+++ b/app-misc/beagle/files/beagle-0.3.9-sqlite.patch
@@ -0,0 +1,93 @@
+From 59f63233908b8ccee70251f698351014546d5765 Mon Sep 17 00:00:00 2001
+From: Gabriel Burt <gabriel.burt@gmail.com>
+Date: Thu, 07 Jan 2010 01:08:34 +0000
+Subject: Update to build against Mono.Data.Sqlite 2.x
+
+---
+diff --git a/beagle/Util/FSpotTools.cs b/beagle/Util/FSpotTools.cs
+index 9470a0a..82f7752 100644
+--- a/beagle/Util/FSpotTools.cs
++++ b/beagle/Util/FSpotTools.cs
+@@ -85,8 +85,12 @@ namespace Beagle.Util {
+ while (reader == null) {
+ try {
+ reader = command.ExecuteReader ();
+- } catch (SqliteBusyException) {
+- Thread.Sleep (50);
++ } catch (SqliteException e) {
++ if (e.ErrorCode == SQLiteErrorCode.Busy) {
++ Thread.Sleep (50);
++ } else {
++ throw;
++ }
+ }
+ }
+ reader.Close ();
+diff --git a/beagle/beagled/SqliteUtils.cs b/beagle/beagled/SqliteUtils.cs
+index f4be4c6..f747db5 100644
+--- a/beagle/beagled/SqliteUtils.cs
++++ b/beagle/beagled/SqliteUtils.cs
+@@ -55,8 +55,13 @@ namespace Beagle.Util {
+ try {
+ ret = command.ExecuteNonQuery ();
+ break;
+- } catch (SqliteBusyException ex) {
+- Thread.Sleep (50);
++ } catch (SqliteException ex) {
++ if (ex.ErrorCode == SQLiteErrorCode.Busy) {
++ Thread.Sleep (50);
++ } else {
++ Log.Error (ex, "SQL that caused the exception: {0}", command_text);
++ throw;
++ }
+ } catch (Exception e) {
+ Log.Error (e, "SQL that caused the exception: {0}", command_text);
+ throw;
+@@ -79,8 +84,13 @@ namespace Beagle.Util {
+ try {
+ ret = command.ExecuteNonQuery ();
+ break;
+- } catch (SqliteBusyException ex) {
+- Thread.Sleep (50);
++ } catch (SqliteException ex) {
++ if (ex.ErrorCode == SQLiteErrorCode.Busy) {
++ Thread.Sleep (50);
++ } else {
++ Log.Error (ex, "SQL that caused the exception: {0}", command.CommandText);
++ throw;
++ }
+ } catch (Exception e) {
+ Log.Error ( e, "SQL that caused the exception: {0}", command.CommandText);
+ throw;
+@@ -96,8 +106,12 @@ namespace Beagle.Util {
+ while (reader == null) {
+ try {
+ reader = command.ExecuteReader ();
+- } catch (SqliteBusyException ex) {
+- Thread.Sleep (50);
++ } catch (SqliteException ex) {
++ if (ex.ErrorCode == SQLiteErrorCode.Busy) {
++ Thread.Sleep (50);
++ } else {
++ throw;
++ }
+ }
+ }
+ return reader;
+@@ -108,8 +122,12 @@ namespace Beagle.Util {
+ while (true) {
+ try {
+ return reader.Read ();
+- } catch (SqliteBusyException ex) {
+- Thread.Sleep (50);
++ } catch (SqliteException ex) {
++ if (ex.ErrorCode == SQLiteErrorCode.Busy) {
++ Thread.Sleep (50);
++ } else {
++ throw;
++ }
+ }
+ }
+ }
+--
+cgit v0.8.3.1