summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2007-09-15 07:30:25 +0000
committerTorsten Veller <tove@gentoo.org>2007-09-15 07:30:25 +0000
commit94fd30eef0a742d953b984197056cc0cb633a193 (patch)
tree7a40e059d2de4f07417ef844bc0c9069d994f3a9 /app-misc
parentInitial version of gentoo-syntax for XEmacs (diff)
downloadgentoo-2-94fd30eef0a742d953b984197056cc0cb633a193.tar.gz
gentoo-2-94fd30eef0a742d953b984197056cc0cb633a193.tar.bz2
gentoo-2-94fd30eef0a742d953b984197056cc0cb633a193.zip
Version bump. Fixes bug #190733
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/wyrd/ChangeLog7
-rw-r--r--app-misc/wyrd/files/digest-wyrd-1.4.3b3
-rw-r--r--app-misc/wyrd/wyrd-1.4.3b.ebuild39
3 files changed, 48 insertions, 1 deletions
diff --git a/app-misc/wyrd/ChangeLog b/app-misc/wyrd/ChangeLog
index 1e48f3529d21..9463bda6d817 100644
--- a/app-misc/wyrd/ChangeLog
+++ b/app-misc/wyrd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/wyrd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/ChangeLog,v 1.14 2007/09/01 12:37:12 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/ChangeLog,v 1.15 2007/09/15 07:30:24 tove Exp $
+
+*wyrd-1.4.3b (15 Sep 2007)
+
+ 15 Sep 2007; Torsten Veller <tove@gentoo.org> +wyrd-1.4.3b.ebuild:
+ Version bump. Fixes bug #190733
01 Sep 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing twp from metadata due to his retirement (see #190561 for reference).
diff --git a/app-misc/wyrd/files/digest-wyrd-1.4.3b b/app-misc/wyrd/files/digest-wyrd-1.4.3b
new file mode 100644
index 000000000000..1c5e251764ec
--- /dev/null
+++ b/app-misc/wyrd/files/digest-wyrd-1.4.3b
@@ -0,0 +1,3 @@
+MD5 d428191d81769894cf773b8de6cae7ac wyrd-1.4.3b.tar.gz 226447
+RMD160 2a85a1bdeb3c22d3b7c8f283c6cbb80088343c5e wyrd-1.4.3b.tar.gz 226447
+SHA256 81104370307151dba1dbf5130f11ba03cc5a40d4704563f9e4085ce1ebc00bd3 wyrd-1.4.3b.tar.gz 226447
diff --git a/app-misc/wyrd/wyrd-1.4.3b.ebuild b/app-misc/wyrd/wyrd-1.4.3b.ebuild
new file mode 100644
index 000000000000..698d5e904734
--- /dev/null
+++ b/app-misc/wyrd/wyrd-1.4.3b.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.4.3b.ebuild,v 1.1 2007/09/15 07:30:24 tove Exp $
+
+inherit eutils
+
+DESCRIPTION="Text-based front-end to Remind"
+HOMEPAGE="http://www.eecs.umich.edu/~pelzlpj/wyrd/"
+SRC_URI="http://www.eecs.umich.edu/~pelzlpj/wyrd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="unicode"
+
+DEPEND=">=dev-lang/ocaml-3.08
+ sys-libs/ncurses
+ >=x11-misc/remind-03.01"
+
+pkg_setup() {
+ use unicode || return 0
+ if ! built_with_use sys-libs/ncurses unicode ; then
+ eerror "To use unicode in wyrd you must build sys-libs/ncurses"
+ eerror "with unicode support."
+ die "Please rebuilt sys-libs/ncurses with unicode in USE!"
+ fi
+}
+
+src_compile() {
+ econf $(use_enable unicode utf8 ) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install died"
+
+ dodoc ChangeLog || die "dodoc failed"
+ dohtml doc/manual.html || die "dohtml failed"
+}