summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-28 19:41:29 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-28 19:41:29 +0000
commit9f82b94f3bcc820e86167fa41470780b99232740 (patch)
tree0259e722d33a976de448470f54c54fa0c6337740 /app-misc
parentRespect LDFLAGS (bug #337229), more CFLAGS. (diff)
downloadgentoo-2-9f82b94f3bcc820e86167fa41470780b99232740.tar.gz
gentoo-2-9f82b94f3bcc820e86167fa41470780b99232740.tar.bz2
gentoo-2-9f82b94f3bcc820e86167fa41470780b99232740.zip
Respect LDFLAGS (bug #337306), more CFLAGS. Do not hard-wire env var values in Makefile.
(Portage version: 2.2_rc86/cvs/Linux i686)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tprint/ChangeLog10
-rw-r--r--app-misc/tprint/tprint-1.1.0-r1.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/app-misc/tprint/ChangeLog b/app-misc/tprint/ChangeLog
index ed952b732b23..76e3ce50a47e 100644
--- a/app-misc/tprint/ChangeLog
+++ b/app-misc/tprint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/tprint
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tprint/ChangeLog,v 1.6 2008/12/30 20:31:38 angelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tprint/ChangeLog,v 1.7 2010/09/28 19:41:29 jer Exp $
+
+*tprint-1.1.0-r1 (28 Sep 2010)
+
+ 28 Sep 2010; Jeroen Roovers <jer@gentoo.org> +tprint-1.1.0-r1.ebuild:
+ Respect LDFLAGS (bug #337306), more CFLAGS. Do not hard-wire env var
+ values in Makefile.
30 Dec 2008; Christoph Mende <angelos@gentoo.org> tprint-1.1.0.ebuild:
QA: Respect CC (bug 243680)
diff --git a/app-misc/tprint/tprint-1.1.0-r1.ebuild b/app-misc/tprint/tprint-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..fac4b2144a33
--- /dev/null
+++ b/app-misc/tprint/tprint-1.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tprint/tprint-1.1.0-r1.ebuild,v 1.1 2010/09/28 19:41:29 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Transparent Print Utility for terminals"
+HOMEPAGE="http://sourceforge.net/projects/tprint/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's:cc:$(CC):g' \
+ -e 's:-g -O2:$(CFLAGS) $(LDFLAGS):g' \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ dodir /etc/tprint
+ insinto /etc/tprint
+ doins tprint.conf
+ exeinto /usr/bin
+ doexe tprint || die "doexe failed"
+
+ dodoc INSTALL README
+}