summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-02-13 11:32:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-02-13 11:32:40 +0000
commitc86ac9fb9d5a6475bec1df8357f5c0d015f821be (patch)
treee2e9a1a97f9a3a18632dc125923b70c435f28639 /app-misc
parentRevert unwanted modification from 0.2.12 ebuild. (diff)
downloadgentoo-2-c86ac9fb9d5a6475bec1df8357f5c0d015f821be.tar.gz
gentoo-2-c86ac9fb9d5a6475bec1df8357f5c0d015f821be.tar.bz2
gentoo-2-c86ac9fb9d5a6475bec1df8357f5c0d015f821be.zip
Fix FEATURES=test on arm and alpha (bug #403343 by Markus Meier).
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/mc/ChangeLog7
-rw-r--r--app-misc/mc/files/mc-4.8.1-fix-vfs-test.patch184
-rw-r--r--app-misc/mc/files/mc-4.8.1-muldefs-in.patch54
-rw-r--r--app-misc/mc/files/mc-4.8.1-muldefs.patch45
-rw-r--r--app-misc/mc/mc-4.8.1-r1.ebuild10
-rw-r--r--app-misc/mc/mc-4.8.1-r2.ebuild4
6 files changed, 300 insertions, 4 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index d6d662079d93..0cecdc7a3620 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/mc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.243 2012/02/11 19:54:32 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.244 2012/02/13 11:32:40 slyfox Exp $
+
+ 13 Feb 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/mc-4.8.1-fix-vfs-test.patch, +files/mc-4.8.1-muldefs-in.patch,
+ +files/mc-4.8.1-muldefs.patch, mc-4.8.1-r1.ebuild, mc-4.8.1-r2.ebuild:
+ Fix FEATURES=test on arm and alpha (bug #403343 by Markus Meier).
11 Feb 2012; Sergei Trofimovich <slyfox@gentoo.org> mc-9999.ebuild:
Upstream moved main tree to github leaving old one as read-only mirror.
diff --git a/app-misc/mc/files/mc-4.8.1-fix-vfs-test.patch b/app-misc/mc/files/mc-4.8.1-fix-vfs-test.patch
new file mode 100644
index 000000000000..f3a7c047c6b8
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.1-fix-vfs-test.patch
@@ -0,0 +1,184 @@
+commit 931819039e78d7b1465077709988a611df4752c2
+Author: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Mon Feb 13 14:14:50 2012 +0300
+
+ Ticket #2732: fix vfs test build failure on alpha
+
+ The test fails to compile on alpha:
+
+ > CC vfs_parse_ls_lga.o
+ > vfs_parse_ls_lga.c: In function ‘test_vfs_parse_ls_lga’:
+ > vfs_parse_ls_lga.c:174:9: error: unknown field ‘st_atime’ specified in initializer
+ > vfs_parse_ls_lga.c:175:9: error: unknown field ‘st_mtime’ specified in initializer
+
+ as st_atime on alpha in not just a field name:
+
+ struct stat {
+ ...
+ __extension__ union { struct timespec st_atim; struct { __time_t st_atime; unsigned long st_atimensec; }; };
+ __extension__ union { struct timespec st_mtim; struct { __time_t st_mtime; unsigned long st_mtimensec; }; };
+ __extension__ union { struct timespec st_ctim; struct { __time_t st_ctime; unsigned long st_ctimensec; }; };
+ };
+
+ The fix switches to old-style struct initialization.
+
+ Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+
+diff --git a/tests/lib/vfs/vfs_parse_ls_lga.c b/tests/lib/vfs/vfs_parse_ls_lga.c
+index f44559d..d16711e 100644
+--- a/tests/lib/vfs/vfs_parse_ls_lga.c
++++ b/tests/lib/vfs/vfs_parse_ls_lga.c
+@@ -155,90 +155,88 @@ START_TEST (test_vfs_parse_ls_lga)
+ {
+ size_t filepos = 0;
+
++ struct stat etalon_stat;
++
++ etalon_stat.st_dev = 0;
++ etalon_stat.st_ino = 0;
++ etalon_stat.st_mode = 0x41fd;
++ etalon_stat.st_nlink = 10;
++ etalon_stat.st_uid = 500;
++ etalon_stat.st_gid = 500;
++ etalon_stat.st_rdev = 0;
++ etalon_stat.st_size = 4096;
++ etalon_stat.st_blksize = 512;
++ etalon_stat.st_blocks = 8;
++ etalon_stat.st_atime = 1308838140;
++ etalon_stat.st_mtime = 1308838140;
++ etalon_stat.st_ctime = 1308838140;
++
+ vfs_parse_ls_lga_init();
+
+ check_vfs_parse_ls_lga_call(
+ "drwxrwxr-x 10 500 500 4096 Jun 23 17:09 build_root",
+- 1, "build_root", NULL, (struct stat)
+- {
+- .st_dev = 0,
+- .st_ino = 0,
+- .st_mode = 0x41fd,
+- .st_nlink = 10,
+- .st_uid = 500,
+- .st_gid = 500,
+- .st_rdev = 0,
+- .st_size = 4096,
+- .st_blksize = 512,
+- .st_blocks = 8,
+- .st_atime = 1308838140,
+- .st_mtime = 1308838140,
+- .st_ctime = 1308838140
+- },
++ 1, "build_root", NULL, etalon_stat,
+ NULL
+ );
+
++ etalon_stat.st_dev = 0;
++ etalon_stat.st_ino = 0;
++ etalon_stat.st_mode = 0xa1ff;
++ etalon_stat.st_nlink = 10;
++ etalon_stat.st_uid = 500;
++ etalon_stat.st_gid = 500;
++ etalon_stat.st_rdev = 0;
++ etalon_stat.st_size = 11;
++ etalon_stat.st_blksize = 512;
++ etalon_stat.st_blocks = 1;
++ etalon_stat.st_atime = 1268431200;
++ etalon_stat.st_mtime = 1268431200;
++ etalon_stat.st_ctime = 1268431200;
++
+ check_vfs_parse_ls_lga_call(
+ "lrwxrwxrwx 1 500 500 11 Mar 13 2010 COPYING -> doc/COPYING",
+- 1, "COPYING", "doc/COPYING",
+- (struct stat)
+- {
+- .st_dev = 0,
+- .st_ino = 0,
+- .st_mode = 0xa1ff,
+- .st_nlink = 10,
+- .st_uid = 500,
+- .st_gid = 500,
+- .st_rdev = 0,
+- .st_size = 11,
+- .st_blksize = 512,
+- .st_blocks = 1,
+- .st_atime = 1268431200,
+- .st_mtime = 1268431200,
+- .st_ctime = 1268431200
+- },
++ 1, "COPYING", "doc/COPYING", etalon_stat,
+ NULL
+ );
+
++ etalon_stat.st_dev = 0;
++ etalon_stat.st_ino = 0;
++ etalon_stat.st_mode = 0x41fd;
++ etalon_stat.st_nlink = 10;
++ etalon_stat.st_uid = 500;
++ etalon_stat.st_gid = 500;
++ etalon_stat.st_rdev = 0;
++ etalon_stat.st_size = 4096;
++ etalon_stat.st_blksize = 512;
++ etalon_stat.st_blocks = 8;
++ etalon_stat.st_atime = 1308838140;
++ etalon_stat.st_mtime = 1308838140;
++ etalon_stat.st_ctime = 1308838140;
++
+ check_vfs_parse_ls_lga_call(
+ "drwxrwxr-x 10 500 500 4096 Jun 23 17:09 ..",
+- 1, "..", NULL, (struct stat)
+- {
+- .st_dev = 0,
+- .st_ino = 0,
+- .st_mode = 0x41fd,
+- .st_nlink = 10,
+- .st_uid = 500,
+- .st_gid = 500,
+- .st_rdev = 0,
+- .st_size = 4096,
+- .st_blksize = 512,
+- .st_blocks = 8,
+- .st_atime = 1308838140,
+- .st_mtime = 1308838140,
+- .st_ctime = 1308838140
+- },
++ 1, "..", NULL, etalon_stat,
+ &filepos
+ );
+
++
++ etalon_stat.st_dev = 0;
++ etalon_stat.st_ino = 0;
++ etalon_stat.st_mode = 0x41fd;
++ etalon_stat.st_nlink = 10;
++ etalon_stat.st_uid = 500;
++ etalon_stat.st_gid = 500;
++ etalon_stat.st_rdev = 0;
++ etalon_stat.st_size = 4096;
++ etalon_stat.st_blksize = 512;
++ etalon_stat.st_blocks = 8;
++ etalon_stat.st_atime = 1308838140;
++ etalon_stat.st_mtime = 1308838140;
++ etalon_stat.st_ctime = 1308838140;
++
+ check_vfs_parse_ls_lga_call(
+ "drwxrwxr-x 10 500 500 4096 Jun 23 17:09 build_root",
+- 1, "build_root", NULL, (struct stat)
+- {
+- .st_dev = 0,
+- .st_ino = 0,
+- .st_mode = 0x41fd,
+- .st_nlink = 10,
+- .st_uid = 500,
+- .st_gid = 500,
+- .st_rdev = 0,
+- .st_size = 4096,
+- .st_blksize = 512,
+- .st_blocks = 8,
+- .st_atime = 1308838140,
+- .st_mtime = 1308838140,
+- .st_ctime = 1308838140
+- },
++ 1, "build_root", NULL, etalon_stat,
+ &filepos
+ );
+
diff --git a/app-misc/mc/files/mc-4.8.1-muldefs-in.patch b/app-misc/mc/files/mc-4.8.1-muldefs-in.patch
new file mode 100644
index 000000000000..2f0a9068dbcc
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.1-muldefs-in.patch
@@ -0,0 +1,54 @@
+Just to avoid running autotools.
+Real fix is in 'mc-4.8.1-muldefs.patch' patch.
+diff --git a/tests/lib/mcconfig/Makefile.in b/tests/lib/mcconfig/Makefile.in
+index 1e180ce..d224786 100644
+--- a/tests/lib/mcconfig/Makefile.in
++++ b/tests/lib/mcconfig/Makefile.in
+@@ -339,7 +339,7 @@ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AM_CFLAGS = $(GLIB_CFLAGS) -I$(top_srcdir) @CHECK_CFLAGS@ \
+- -DWORKDIR=\"$(abs_builddir)\" -z muldefs
++ -DWORKDIR=\"$(abs_builddir)\"
+
+ AM_LDFLAGS = -z muldefs
+ config_string_SOURCES = \
+diff --git a/tests/lib/vfs/Makefile.in b/tests/lib/vfs/Makefile.in
+index 1d08d8d..864d79d 100644
+--- a/tests/lib/vfs/Makefile.in
++++ b/tests/lib/vfs/Makefile.in
+@@ -380,7 +380,7 @@ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AM_CFLAGS = -I$(top_srcdir)/lib/vfs $(GLIB_CFLAGS) -I$(top_srcdir) @CHECK_CFLAGS@ \
+- -DTEST_SHARE_DIR=\"$(abs_srcdir)\" -z muldefs
++ -DTEST_SHARE_DIR=\"$(abs_srcdir)\"
+
+ AM_LDFLAGS = -z muldefs
+ EXTRA_DIST = mc.charsets
+diff --git a/tests/lib/mcconfig/Makefile.in b/tests/lib/mcconfig/Makefile.in
+index d224786..739c2ba 100644
+--- a/tests/lib/mcconfig/Makefile.in
++++ b/tests/lib/mcconfig/Makefile.in
+@@ -341,7 +341,7 @@ top_srcdir = @top_srcdir@
+ AM_CFLAGS = $(GLIB_CFLAGS) -I$(top_srcdir) @CHECK_CFLAGS@ \
+ -DWORKDIR=\"$(abs_builddir)\"
+
+-AM_LDFLAGS = -z muldefs
++AM_LDFLAGS = -Wl,-z,muldefs
+ config_string_SOURCES = \
+ config_string.c
+
+diff --git a/tests/lib/vfs/Makefile.in b/tests/lib/vfs/Makefile.in
+index 864d79d..57c1ab5 100644
+--- a/tests/lib/vfs/Makefile.in
++++ b/tests/lib/vfs/Makefile.in
+@@ -382,7 +382,7 @@ top_srcdir = @top_srcdir@
+ AM_CFLAGS = -I$(top_srcdir)/lib/vfs $(GLIB_CFLAGS) -I$(top_srcdir) @CHECK_CFLAGS@ \
+ -DTEST_SHARE_DIR=\"$(abs_srcdir)\"
+
+-AM_LDFLAGS = -z muldefs
++AM_LDFLAGS = -Wl,-z,muldefs
+ EXTRA_DIST = mc.charsets
+ canonicalize_pathname_SOURCES = \
+ canonicalize_pathname.c
diff --git a/app-misc/mc/files/mc-4.8.1-muldefs.patch b/app-misc/mc/files/mc-4.8.1-muldefs.patch
new file mode 100644
index 000000000000..2155391a2b31
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.1-muldefs.patch
@@ -0,0 +1,45 @@
+commit 3e4d6d6b760e6f7043f26ee65ba415db7e9d47b2
+Author: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Mon Feb 13 11:35:52 2012 +0300
+
+ Ticket #2732: tests/lib/vfs/Makefile.am: drop muldefs from CFLAGS
+
+ Otherwise gcc on alpha/arm will break in gcc -c phase:
+
+ CC config_string.o
+ armv5tel-softfloat-linux-gnueabi-gcc <skip> -z muldefs -c config_string.c
+ armv5tel-softfloat-linux-gnueabi-gcc: muldefs: No such file or directory
+ make[4]: *** [config_string.o] Error 1
+
+ Gentoo-bug: http://bugs.gentoo.org/403343
+ Reported-by: Markus Meier
+ Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+
+diff --git a/tests/lib/mcconfig/Makefile.am b/tests/lib/mcconfig/Makefile.am
+index fba2a7b..c706003 100644
+--- a/tests/lib/mcconfig/Makefile.am
++++ b/tests/lib/mcconfig/Makefile.am
+@@ -1,7 +1,7 @@
+ AM_CFLAGS = $(GLIB_CFLAGS) -I$(top_srcdir) @CHECK_CFLAGS@ \
+- -DWORKDIR=\"$(abs_builddir)\" -z muldefs
++ -DWORKDIR=\"$(abs_builddir)\"
+
+-AM_LDFLAGS = -z muldefs
++AM_LDFLAGS = -Wl,-z,muldefs
+
+ LIBS=@CHECK_LIBS@ $(top_builddir)/lib/libmc.la
+
+diff --git a/tests/lib/vfs/Makefile.am b/tests/lib/vfs/Makefile.am
+index bf440ee..8c50d28 100644
+--- a/tests/lib/vfs/Makefile.am
++++ b/tests/lib/vfs/Makefile.am
+@@ -1,7 +1,7 @@
+ AM_CFLAGS = -I$(top_srcdir)/lib/vfs $(GLIB_CFLAGS) -I$(top_srcdir) @CHECK_CFLAGS@ \
+- -DTEST_SHARE_DIR=\"$(abs_srcdir)\" -z muldefs
++ -DTEST_SHARE_DIR=\"$(abs_srcdir)\"
+
+-AM_LDFLAGS = -z muldefs
++AM_LDFLAGS = -Wl,-z,muldefs
+
+ EXTRA_DIST = mc.charsets
+
diff --git a/app-misc/mc/mc-4.8.1-r1.ebuild b/app-misc/mc/mc-4.8.1-r1.ebuild
index 9f95caeca062..708985a40318 100644
--- a/app-misc/mc/mc-4.8.1-r1.ebuild
+++ b/app-misc/mc/mc-4.8.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.8.1-r1.ebuild,v 1.7 2012/02/01 17:24:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.8.1-r1.ebuild,v 1.8 2012/02/13 11:32:40 slyfox Exp $
EAPI=4
-inherit base flag-o-matic
+inherit eutils flag-o-matic
MY_P=${P/_/-}
@@ -39,6 +39,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.8.1-muldefs.patch #403343
+ epatch "${FILESDIR}"/${PN}-4.8.1-muldefs-in.patch #403343
+ epatch "${FILESDIR}"/${PN}-4.8.1-fix-vfs-test.patch #403343
+}
+
src_configure() {
local myscreen=ncurses
use slang && myscreen=slang
diff --git a/app-misc/mc/mc-4.8.1-r2.ebuild b/app-misc/mc/mc-4.8.1-r2.ebuild
index 527d0b10a6f4..951a86a75aab 100644
--- a/app-misc/mc/mc-4.8.1-r2.ebuild
+++ b/app-misc/mc/mc-4.8.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.8.1-r2.ebuild,v 1.1 2012/01/27 20:26:43 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.8.1-r2.ebuild,v 1.2 2012/02/13 11:32:40 slyfox Exp $
EAPI=4
@@ -41,6 +41,8 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
epatch "${FILESDIR}"/${PN}-4.8.1-fix-fallocate-xBSD.patch
+ epatch "${FILESDIR}"/${PN}-4.8.1-muldefs.patch #403343
+ epatch "${FILESDIR}"/${PN}-4.8.1-fix-vfs-test.patch #403343
# patch above changed .m4 bits
eautoreconf