summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-03-02 06:41:49 +0000
committerTim Harder <radhermit@gentoo.org>2013-03-02 06:41:49 +0000
commitd443262448956b27635e9bee393ccaf9206d9931 (patch)
tree5b6dfe7b3f29b570bc37c1c59bac32d6167048e2 /app-misc
parentVersion bump. (diff)
downloadgentoo-2-d443262448956b27635e9bee393ccaf9206d9931.tar.gz
gentoo-2-d443262448956b27635e9bee393ccaf9206d9931.tar.bz2
gentoo-2-d443262448956b27635e9bee393ccaf9206d9931.zip
Combine live ebuild and latest release.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ranger/ChangeLog6
-rw-r--r--app-misc/ranger/ranger-1.6.0.ebuild13
-rw-r--r--app-misc/ranger/ranger-9999.ebuild23
3 files changed, 28 insertions, 14 deletions
diff --git a/app-misc/ranger/ChangeLog b/app-misc/ranger/ChangeLog
index 0c0a2072044a..0acb52f20c46 100644
--- a/app-misc/ranger/ChangeLog
+++ b/app-misc/ranger/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/ranger
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ranger/ChangeLog,v 1.23 2013/03/02 06:36:38 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ranger/ChangeLog,v 1.24 2013/03/02 06:41:49 radhermit Exp $
+
+ 02 Mar 2013; Tim Harder <radhermit@gentoo.org> ranger-1.6.0.ebuild,
+ ranger-9999.ebuild:
+ Combine live ebuild and latest release.
*ranger-1.6.0 (02 Mar 2013)
diff --git a/app-misc/ranger/ranger-1.6.0.ebuild b/app-misc/ranger/ranger-1.6.0.ebuild
index 30d7d5a850e6..e2c24d9da62b 100644
--- a/app-misc/ranger/ranger-1.6.0.ebuild
+++ b/app-misc/ranger/ranger-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ranger/ranger-1.6.0.ebuild,v 1.1 2013/03/02 06:36:38 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ranger/ranger-1.6.0.ebuild,v 1.2 2013/03/02 06:41:49 radhermit Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
@@ -8,13 +8,18 @@ PYTHON_REQ_USE="ncurses"
inherit distutils-r1
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/ranger.git"
+ inherit git-2
+else
+ SRC_URI="http://nongnu.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
DESCRIPTION="A vim-inspired file manager for the console"
HOMEPAGE="http://ranger.nongnu.org/"
-SRC_URI="http://nongnu.org/${PN}/${P}.tar.gz"
-
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
RDEPEND="virtual/pager"
diff --git a/app-misc/ranger/ranger-9999.ebuild b/app-misc/ranger/ranger-9999.ebuild
index 16d8225c231a..345261546a35 100644
--- a/app-misc/ranger/ranger-9999.ebuild
+++ b/app-misc/ranger/ranger-9999.ebuild
@@ -1,26 +1,31 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ranger/ranger-9999.ebuild,v 1.3 2013/01/11 22:25:09 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ranger/ranger-9999.ebuild,v 1.4 2013/03/02 06:41:49 radhermit Exp $
-EAPI="5"
+EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
PYTHON_REQ_USE="ncurses"
-inherit distutils-r1 git-2
+inherit distutils-r1
-EGIT_REPO_URI="git://git.savannah.nongnu.org/ranger.git"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/ranger.git"
+ inherit git-2
+else
+ SRC_URI="http://nongnu.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="A vim-inspired file manager for the console"
HOMEPAGE="http://ranger.nongnu.org/"
-
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE=""
RDEPEND="virtual/pager"
pkg_postinst() {
- elog "Ranger has many optional dependencies to support enhanced file previews."
- elog "See the README or homepage for more details."
+ if ! has_version ${CATEGORY}/${PN} ; then
+ elog "Ranger has many optional dependencies to support enhanced file previews."
+ elog "See the README or homepage for more details."
+ fi
}