summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-22 17:35:50 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-22 17:35:50 +0000
commitd53ed9a5a5d94eccc6f64dd1b3d3422d3367da1a (patch)
treec8b56727661e0021ec07567f5a714d4077fbba9e /app-misc
parentremove vulnerable ebuilds (diff)
downloadgentoo-2-d53ed9a5a5d94eccc6f64dd1b3d3422d3367da1a.tar.gz
gentoo-2-d53ed9a5a5d94eccc6f64dd1b3d3422d3367da1a.tar.bz2
gentoo-2-d53ed9a5a5d94eccc6f64dd1b3d3422d3367da1a.zip
QA, fixes #342219
(Portage version: 2.2_rc99/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tdl/ChangeLog6
-rw-r--r--app-misc/tdl/tdl-1.5.2-r1.ebuild8
-rw-r--r--app-misc/tdl/tdl-1.5.2.ebuild31
3 files changed, 28 insertions, 17 deletions
diff --git a/app-misc/tdl/ChangeLog b/app-misc/tdl/ChangeLog
index e6a77ea61a99..f9852e742544 100644
--- a/app-misc/tdl/ChangeLog
+++ b/app-misc/tdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/tdl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/ChangeLog,v 1.24 2010/10/22 16:56:04 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/ChangeLog,v 1.25 2010/10/22 17:35:50 jlec Exp $
+
+ 22 Oct 2010; Justin Lecher <jlec@gentoo.org> tdl-1.5.2.ebuild,
+ tdl-1.5.2-r1.ebuild:
+ QA, fixes #342219
22 Oct 2010; Markos Chandras <hwoarang@gentoo.org> tdl-1.5.2-r1.ebuild:
Stable on amd64 wrt bug #342139
diff --git a/app-misc/tdl/tdl-1.5.2-r1.ebuild b/app-misc/tdl/tdl-1.5.2-r1.ebuild
index 93873246758f..e1037594f9b4 100644
--- a/app-misc/tdl/tdl-1.5.2-r1.ebuild
+++ b/app-misc/tdl/tdl-1.5.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/tdl-1.5.2-r1.ebuild,v 1.2 2010/10/22 16:56:04 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/tdl-1.5.2-r1.ebuild,v 1.3 2010/10/22 17:35:49 jlec Exp $
EAPI="3"
@@ -36,7 +36,7 @@ src_configure() {
sed -i 's#\($(LIB_READLINE)\)#\1 -lncurses##g' "${S}"/Makefile.in
fi
- sed -i 's#-ltermcap#-lncurses#g' "${S}"/configure
+ sed -i 's#-ltermcap#-lncurses#g' "${S}"/configure || die
# XXX: do not replace with econf.
"${S}"/configure ${myconf} || die "configure failed, sorry!"
@@ -44,7 +44,9 @@ src_configure() {
src_compile() {
emake all tdl.info tdl.html tdl.txt || die
- use doc && emake tdl.dvi tdl.ps tdl.pdf
+ if use doc; then
+ emake tdl.dvi tdl.ps tdl.pdf || die
+ fi
}
src_install() {
diff --git a/app-misc/tdl/tdl-1.5.2.ebuild b/app-misc/tdl/tdl-1.5.2.ebuild
index bc1ceb16f57c..ac7e0d1fcddb 100644
--- a/app-misc/tdl/tdl-1.5.2.ebuild
+++ b/app-misc/tdl/tdl-1.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/tdl-1.5.2.ebuild,v 1.18 2009/04/13 02:32:19 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/tdl-1.5.2.ebuild,v 1.19 2010/10/22 17:35:49 jlec Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -13,7 +13,8 @@ SLOT="0"
KEYWORDS="x86 alpha ppc amd64"
IUSE="doc readline"
-RDEPEND=">=sys-libs/readline-4.3
+RDEPEND="
+ >=sys-libs/readline-4.3
sys-libs/ncurses"
DEPEND="${RDEPEND}
sys-apps/texinfo
@@ -29,29 +30,33 @@ src_compile() {
sed -i 's#\($(LIB_READLINE)\)#\1 -lncurses##g' "${S}"/Makefile.in
fi
- sed -i 's#-ltermcap#-lncurses#g' "${S}"/configure
+ sed -i 's#-ltermcap#-lncurses#g' "${S}"/configure || die
# XXX: do not replace with econf.
"${S}"/configure ${myconf} || die "configure failed, sorry!"
emake all tdl.info tdl.html tdl.txt || die
- use doc && emake tdl.dvi tdl.ps tdl.pdf
+ if use doc; then
+ emake tdl.dvi tdl.ps tdl.pdf || die
+ fi
}
src_install() {
local i
- dodoc README NEWS tdl.txt "${FILESDIR}/screenshot.png"
- doinfo tdl.info
- dohtml tdl.html
+ dodoc README NEWS tdl.txt "${FILESDIR}/screenshot.png" || die
+ doinfo tdl.info || die
+ dohtml tdl.html || die
- dobin tdl
- doman tdl.1
+ dobin tdl || die
+ doman tdl.1 || die
for i in tdl{a,l,d,g}
do
- dosym tdl /usr/bin/${i}
- dosym tdl.1 /usr/share/man/man1/${i}.1
+ dosym tdl /usr/bin/${i} || die
+ dosym tdl.1 /usr/share/man/man1/${i}.1 || die
done
- use doc && dodoc tdl.dvi tdl.ps tdl.pdf
+ if use doc; then
+ dodoc tdl.dvi tdl.ps tdl.pdf || die
+ fi
}