summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-07-02 18:46:26 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-07-02 18:46:26 +0000
commitd5e0be51b3e0ba24c384c0dda3e8f522fe7a77e9 (patch)
tree1ca25c79374fdacab787ca8e3690c1dd9f518f79 /app-misc
parentRename PepperFlash plugin if CPU does not support SSE2. Bug 424147. (diff)
downloadgentoo-2-d5e0be51b3e0ba24c384c0dda3e8f522fe7a77e9.tar.gz
gentoo-2-d5e0be51b3e0ba24c384c0dda3e8f522fe7a77e9.tar.bz2
gentoo-2-d5e0be51b3e0ba24c384c0dda3e8f522fe7a77e9.zip
Fix build failure with gcc-4.7 due to missing include (bug #424317, thanks to Diego Elio Pettenò).
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gnote/ChangeLog7
-rw-r--r--app-misc/gnote/files/gnote-0.8.2-signal_idle-header.patch24
-rw-r--r--app-misc/gnote/gnote-0.8.2-r10.ebuild6
-rw-r--r--app-misc/gnote/gnote-0.8.2.ebuild6
4 files changed, 38 insertions, 5 deletions
diff --git a/app-misc/gnote/ChangeLog b/app-misc/gnote/ChangeLog
index 02146019474b..e7f210506133 100644
--- a/app-misc/gnote/ChangeLog
+++ b/app-misc/gnote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gnote
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.21 2012/05/22 11:31:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.22 2012/07/02 18:46:26 tetromino Exp $
+
+ 02 Jul 2012; Alexandre Rostovtsev <tetromino@gentoo.org> gnote-0.8.2.ebuild,
+ gnote-0.8.2-r10.ebuild, +files/gnote-0.8.2-signal_idle-header.patch:
+ Fix build failure with gcc-4.7 due to missing include (bug #424317, thanks to
+ Diego Elio Pettenò).
22 May 2012; Agostino Sarubbo <ago@gentoo.org> gnote-0.8.2.ebuild:
Stable for amd64, wrt bug #414983
diff --git a/app-misc/gnote/files/gnote-0.8.2-signal_idle-header.patch b/app-misc/gnote/files/gnote-0.8.2-signal_idle-header.patch
new file mode 100644
index 000000000000..fdc905489144
--- /dev/null
+++ b/app-misc/gnote/files/gnote-0.8.2-signal_idle-header.patch
@@ -0,0 +1,24 @@
+From 7364a6fd55c46db5c5dbae6df6ac377d48919fa9 Mon Sep 17 00:00:00 2001
+From: Hub Figuiere <hub@figuiere.net>
+Date: Thu, 5 Jan 2012 21:19:49 -0800
+Subject: [PATCH] Fix missing header for Glib::signal_idle. Closes #667349
+
+---
+ src/notebuffer.cpp | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/src/notebuffer.cpp b/src/notebuffer.cpp
+index 48bca2d..df223f3 100644
+--- a/src/notebuffer.cpp
++++ b/src/notebuffer.cpp
+@@ -23,6 +23,7 @@
+ #include <algorithm>
+ #include <tr1/array>
+
++#include <glibmm/main.h>
+
+ #include "debug.hpp"
+ #include "notebuffer.hpp"
+--
+1.7.8.6
+
diff --git a/app-misc/gnote/gnote-0.8.2-r10.ebuild b/app-misc/gnote/gnote-0.8.2-r10.ebuild
index a4db803e6b5e..c090aae0ff31 100644
--- a/app-misc/gnote/gnote-0.8.2-r10.ebuild
+++ b/app-misc/gnote/gnote-0.8.2-r10.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.8.2-r10.ebuild,v 1.2 2012/05/20 20:52:50 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.8.2-r10.ebuild,v 1.3 2012/07/02 18:46:26 tetromino Exp $
EAPI="4"
GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="Desktop note-taking application"
HOMEPAGE="http://live.gnome.org/Gnote"
@@ -42,6 +42,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${P}-signal_idle-header.patch" #424317
+
gnome2_src_prepare
# Do not set idiotic defines in a released tarball, bug #311979
diff --git a/app-misc/gnote/gnote-0.8.2.ebuild b/app-misc/gnote/gnote-0.8.2.ebuild
index 548634df20e7..bc0c330c0cf5 100644
--- a/app-misc/gnote/gnote-0.8.2.ebuild
+++ b/app-misc/gnote/gnote-0.8.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.8.2.ebuild,v 1.5 2012/05/22 11:31:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.8.2.ebuild,v 1.6 2012/07/02 18:46:26 tetromino Exp $
EAPI="4"
GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="Desktop note-taking application"
HOMEPAGE="http://live.gnome.org/Gnote"
@@ -42,6 +42,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${P}-signal_idle-header.patch" #424317
+
gnome2_src_prepare
# Do not set idiotic defines in a released tarball, bug #311979