summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-12-10 17:36:37 +0000
committerJonathan Callen <abcd@gentoo.org>2009-12-10 17:36:37 +0000
commitd5f661e8fd7caf87722376f1cf603ab3fb4580dd (patch)
treef031a01ef21bffebe756fea3100e70b517a965e6 /app-misc
parentx86 stable, bug 292455 (diff)
downloadgentoo-2-d5f661e8fd7caf87722376f1cf603ab3fb4580dd.tar.gz
gentoo-2-d5f661e8fd7caf87722376f1cf603ab3fb4580dd.tar.bz2
gentoo-2-d5f661e8fd7caf87722376f1cf603ab3fb4580dd.zip
Convert mycmakeargs to an array (required due to usage in src_test)
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/strigi/ChangeLog6
-rw-r--r--app-misc/strigi/strigi-0.6.5.ebuild26
-rw-r--r--app-misc/strigi/strigi-0.7.0.ebuild16
3 files changed, 30 insertions, 18 deletions
diff --git a/app-misc/strigi/ChangeLog b/app-misc/strigi/ChangeLog
index ae3064db7f3f..d89cbcdec5fb 100644
--- a/app-misc/strigi/ChangeLog
+++ b/app-misc/strigi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/strigi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.42 2009/11/30 04:35:20 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.43 2009/12/10 17:36:37 abcd Exp $
+
+ 10 Dec 2009; Jonathan Callen <abcd@gentoo.org> strigi-0.6.5.ebuild,
+ strigi-0.7.0.ebuild:
+ Convert mycmakeargs to an array (required due to usage in src_test)
30 Nov 2009; Joseph Jezak <josejx@gentoo.org> strigi-0.7.0.ebuild:
Marked ppc/ppc64 stable.
diff --git a/app-misc/strigi/strigi-0.6.5.ebuild b/app-misc/strigi/strigi-0.6.5.ebuild
index 3e28829bd619..221f5e2e4bcd 100644
--- a/app-misc/strigi/strigi-0.6.5.ebuild
+++ b/app-misc/strigi/strigi-0.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.6.5.ebuild,v 1.3 2009/05/18 12:56:46 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.6.5.ebuild,v 1.4 2009/12/10 17:36:37 abcd Exp $
EAPI="2"
@@ -55,29 +55,33 @@ src_configure() {
# is just silly, so we forcefully disable linking to expat.
# Enabled: POLLING (only reliable way to check for files changed.)
- mycmakeargs="${mycmakeargs}
+ mycmakeargs=(
-DENABLE_EXPAT=OFF -DENABLE_POLLING=ON
-DFORCE_DEPS=ON -DENABLE_CPPUNIT=OFF
-DENABLE_REGENERATEXSD=OFF
- $(cmake-utils_use_enable clucene CLUCENE)
- $(cmake-utils_use_enable dbus DBUS)
+ $(cmake-utils_use_enable clucene)
+ $(cmake-utils_use_enable dbus)
$(cmake-utils_use_enable exif EXIV2)
- $(cmake-utils_use_enable fam FAM)
- $(cmake-utils_use_enable hyperestraier HYPERESTRAIER)
- $(cmake-utils_use_enable inotify INOTIFY)
+ $(cmake-utils_use_enable fam)
+ $(cmake-utils_use_enable hyperestraier)
+ $(cmake-utils_use_enable inotify)
$(cmake-utils_use_enable log LOG4CXX)
- $(cmake-utils_use_enable qt4 DBUS)
- $(cmake-utils_use_enable qt4 QT4)"
+ $(cmake-utils_use_enable qt4)
+ )
+
+ if use qt4; then
+ mycmakeargs+=(-DENABLE_DBUS=ON)
+ fi
if ! use clucene && ! use hyperestraier; then
- mycmakeargs="${mycmakeargs} -DENABLE_CLUCENE=ON"
+ mycmakeargs+=(-DENABLE_CLUCENE=ON)
fi
cmake-utils_src_configure
}
src_test() {
- mycmakeargs="${mycmakeargs} -DENABLE_CPPUNIT=ON"
+ mycmakeargs+=(-DENABLE_CPPUNIT=ON)
cmake-utils_src_configure
cmake-utils_src_compile
diff --git a/app-misc/strigi/strigi-0.7.0.ebuild b/app-misc/strigi/strigi-0.7.0.ebuild
index 3dc140194f6f..b372e5f3b2ba 100644
--- a/app-misc/strigi/strigi-0.7.0.ebuild
+++ b/app-misc/strigi/strigi-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.7.0.ebuild,v 1.5 2009/11/30 04:35:20 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.7.0.ebuild,v 1.6 2009/12/10 17:36:37 abcd Exp $
EAPI="2"
@@ -55,7 +55,7 @@ src_configure() {
# is just silly, so we forcefully disable linking to expat.
# Enabled: POLLING (only reliable way to check for files changed.)
- mycmakeargs="${mycmakeargs}
+ mycmakeargs=(
-DENABLE_EXPAT=OFF -DENABLE_POLLING=ON
-DFORCE_DEPS=ON -DENABLE_CPPUNIT=OFF
-DENABLE_REGENERATEXSD=OFF
@@ -66,18 +66,22 @@ src_configure() {
$(cmake-utils_use_enable hyperestraier)
$(cmake-utils_use_enable inotify)
$(cmake-utils_use_enable log LOG4CXX)
- $(cmake-utils_use_enable qt4 DBUS)
- $(cmake-utils_use_enable qt4)"
+ $(cmake-utils_use_enable qt4)
+ )
+
+ if use qt4; then
+ mycmakeargs+=(-DENABLE_DBUS)
+ fi
if ! use clucene && ! use hyperestraier; then
- mycmakeargs="${mycmakeargs} -DENABLE_CLUCENE=ON"
+ mycmakeargs+=(-DENABLE_CLUCENE=ON)
fi
cmake-utils_src_configure
}
src_test() {
- mycmakeargs="${mycmakeargs} -DENABLE_CPPUNIT=ON"
+ mycmakeargs+=(-DENABLE_CPPUNIT=ON)
cmake-utils_src_configure
cmake-utils_src_compile