summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-04 19:03:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-04 19:03:07 +0000
commite2c5cc5ba9e1f65b05f944c58e2bf04517deec74 (patch)
treed194076149b6224112b59afdbeb69a2ca5cee67e /app-misc
parentBump, fixes #297472 (diff)
downloadgentoo-2-e2c5cc5ba9e1f65b05f944c58e2bf04517deec74.tar.gz
gentoo-2-e2c5cc5ba9e1f65b05f944c58e2bf04517deec74.tar.bz2
gentoo-2-e2c5cc5ba9e1f65b05f944c58e2bf04517deec74.zip
Bump, fixes #295292
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/beanstalkd/ChangeLog9
-rw-r--r--app-misc/beanstalkd/beanstalkd-1.4.3.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/app-misc/beanstalkd/ChangeLog b/app-misc/beanstalkd/ChangeLog
index 80bcbe721582..e66a89fa2b1c 100644
--- a/app-misc/beanstalkd/ChangeLog
+++ b/app-misc/beanstalkd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/beanstalkd
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/ChangeLog,v 1.5 2009/10/23 19:20:30 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/ChangeLog,v 1.6 2010/01/04 19:03:07 patrick Exp $
+
+*beanstalkd-1.4.3 (04 Jan 2010)
+
+ 04 Jan 2010; Patrick Lauer <patrick@gentoo.org> +beanstalkd-1.4.3.ebuild:
+ Bump, fixes #295292
*beanstalkd-1.4.2 (23 Oct 2009)
diff --git a/app-misc/beanstalkd/beanstalkd-1.4.3.ebuild b/app-misc/beanstalkd/beanstalkd-1.4.3.ebuild
new file mode 100644
index 000000000000..0389c6b14840
--- /dev/null
+++ b/app-misc/beanstalkd/beanstalkd-1.4.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/beanstalkd-1.4.3.ebuild,v 1.1 2010/01/04 19:03:07 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="A fast, distributed, in-memory workqueue service"
+HOMEPAGE="http://xph.us/software/beanstalkd/"
+SRC_URI="http://xph.us/dist/beanstalkd/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libevent-1.4.7"
+DEPEND="${RDEPEND}
+ test? ( net-analyzer/netcat )"
+
+IUSE="test"
+
+pkg_preinst() {
+ enewuser beanstalk -1 -1 /dev/null daemon
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ DATADIR=/var/lib/${PN}
+ dodir "${DATADIR}" || die "Install failed"
+ fowners beanstalk:daemon "${DATADIR}"
+
+ dodoc README TODO doc/*.txt
+
+ newconfd "${FILESDIR}/conf-1.4.2" beanstalkd
+ newinitd "${FILESDIR}/init-1.4.2" beanstalkd
+}