summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-08-30 23:52:45 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-08-30 23:52:45 +0000
commitfc05facfb3a992c3c4731a7845c0fabcdbf4fdd1 (patch)
treeae083db45b44abce4474de8d5f7b5a4952a312bb /app-misc
parentMask screefetch live ebuild (diff)
downloadgentoo-2-fc05facfb3a992c3c4731a7845c0fabcdbf4fdd1.tar.gz
gentoo-2-fc05facfb3a992c3c4731a7845c0fabcdbf4fdd1.tar.bz2
gentoo-2-fc05facfb3a992c3c4731a7845c0fabcdbf4fdd1.zip
Version bump. Bug #481702. Thanks to Ari Malinen and Jeroen Roovers
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/screenfetch/ChangeLog9
-rw-r--r--app-misc/screenfetch/screenfetch-3.0.5.ebuild33
-rw-r--r--app-misc/screenfetch/screenfetch-9999.ebuild33
3 files changed, 74 insertions, 1 deletions
diff --git a/app-misc/screenfetch/ChangeLog b/app-misc/screenfetch/ChangeLog
index edc4a14c6806..5ac0750210dd 100644
--- a/app-misc/screenfetch/ChangeLog
+++ b/app-misc/screenfetch/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/screenfetch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screenfetch/ChangeLog,v 1.8 2013/06/02 20:42:14 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screenfetch/ChangeLog,v 1.9 2013/08/30 23:52:45 hwoarang Exp $
+
+*screenfetch-9999 (30 Aug 2013)
+*screenfetch-3.0.5 (30 Aug 2013)
+
+ 30 Aug 2013; Markos Chandras <hwoarang@gentoo.org> +screenfetch-3.0.5.ebuild,
+ +screenfetch-9999.ebuild:
+ Version bump. Bug #481702. Thanks to Ari Malinen and Jeroen Roovers
02 Jun 2013; Markos Chandras <hwoarang@gentoo.org> screenfetch-2.7.7.ebuild:
Stable on amd64/x86
diff --git a/app-misc/screenfetch/screenfetch-3.0.5.ebuild b/app-misc/screenfetch/screenfetch-3.0.5.ebuild
new file mode 100644
index 000000000000..75c2795c54d7
--- /dev/null
+++ b/app-misc/screenfetch/screenfetch-3.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screenfetch/screenfetch-3.0.5.ebuild,v 1.1 2013/08/30 23:52:45 hwoarang Exp $
+
+EAPI=4
+
+MY_PN="${PN/f/F}"
+DESCRIPTION="A Bash Screenshot Information Tool"
+HOMEPAGE="https://github.com/KittyKatt/screenFetch"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> \
+ ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="media-gfx/scrot
+ x11-apps/xdpyinfo"
+
+src_install() {
+ dobin ${PN}-dev
+ # also known as screenfetch
+ dosym ${PN}-dev /usr/bin/${PN}
+ dodoc CHANGELOG README.mkdn TODO
+}
diff --git a/app-misc/screenfetch/screenfetch-9999.ebuild b/app-misc/screenfetch/screenfetch-9999.ebuild
new file mode 100644
index 000000000000..ee4adcf9ab83
--- /dev/null
+++ b/app-misc/screenfetch/screenfetch-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screenfetch/screenfetch-9999.ebuild,v 1.1 2013/08/30 23:52:45 hwoarang Exp $
+
+EAPI=4
+
+MY_PN="${PN/f/F}"
+DESCRIPTION="A Bash Screenshot Information Tool"
+HOMEPAGE="https://github.com/KittyKatt/screenFetch"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> \
+ ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="media-gfx/scrot
+ x11-apps/xdpyinfo"
+
+src_install() {
+ dobin ${PN}-dev
+ # also known as screenfetch
+ dosym ${PN}-dev /usr/bin/${PN}
+ dodoc CHANGELOG README.mkdn TODO
+}