summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-05 22:44:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-05 22:44:34 +0000
commit85a733ef50d3ad093c8c99d886c8503f8b84e64b (patch)
tree5ce60201fe025ca04566e317aaeeec2aab81c805 /app-mobilephone/vmoconv
parentRespect user's CFLAGS (bug #240128). (diff)
downloadgentoo-2-85a733ef50d3ad093c8c99d886c8503f8b84e64b.tar.gz
gentoo-2-85a733ef50d3ad093c8c99d886c8503f8b84e64b.tar.bz2
gentoo-2-85a733ef50d3ad093c8c99d886c8503f8b84e64b.zip
Extend patch to actually build with glibc 2.8. Closes bug #239611.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-mobilephone/vmoconv')
-rw-r--r--app-mobilephone/vmoconv/ChangeLog6
-rw-r--r--app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch12
2 files changed, 17 insertions, 1 deletions
diff --git a/app-mobilephone/vmoconv/ChangeLog b/app-mobilephone/vmoconv/ChangeLog
index 2849b66ea9a7..8680e573cb68 100644
--- a/app-mobilephone/vmoconv/ChangeLog
+++ b/app-mobilephone/vmoconv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-mobilephone/vmoconv
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/vmoconv/ChangeLog,v 1.5 2008/06/20 23:05:36 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/vmoconv/ChangeLog,v 1.6 2008/10/05 22:44:34 flameeyes Exp $
+
+ 05 Oct 2008; Diego Pettenò <flameeyes@gentoo.org>
+ files/vmoconv-1.0-glibc28.patch:
+ Extend patch to actually build with glibc 2.8. Closes bug #239611.
20 Jun 2008; Alin Năstac <mrness@gentoo.org>
+files/vmoconv-1.0-glibc28.patch, vmoconv-1.0.ebuild:
diff --git a/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch b/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch
index 5f3269cc4f8c..ec957b40c5cd 100644
--- a/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch
+++ b/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch
@@ -10,3 +10,15 @@ diff -Naur vmoconv-1.0.orig/src/gsm2vmo.c vmoconv-1.0/src/gsm2vmo.c
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+diff -Naur vmoconv-1.0.orig/src/vmo2gsm.c vmoconv-1.0/src/vmo2gsm.c
+--- vmoconv-1.0.orig/src/vmo2gsm.c 2008-06-15 12:57:07.000000000 -0400
++++ vmoconv-1.0/src/vmo2gsm.c 2008-06-15 12:57:36.000000000 -0400
+@@ -27,7 +27,7 @@
+ * 12 bit header and 260 bits standard GSM frame, as described
+ * in GSM 06.10 and GSM 06.12. The header is 0x2010 always.
+ */
+-
++#include <limits.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>