summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-03-04 10:43:32 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-03-04 10:43:32 +0000
commit26d20eb1e03924f2fb3546e9216c1451e9cd612a (patch)
tree440c0bc884a1ea4c9e6054e0ec2007b1d2714b6d /app-mobilephone
parentAdd upstream metadata. (diff)
downloadgentoo-2-26d20eb1e03924f2fb3546e9216c1451e9cd612a.tar.gz
gentoo-2-26d20eb1e03924f2fb3546e9216c1451e9cd612a.tar.bz2
gentoo-2-26d20eb1e03924f2fb3546e9216c1451e9cd612a.zip
Version bump. Remove old.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/ganyremote/ChangeLog8
-rw-r--r--app-mobilephone/ganyremote/ganyremote-6.1.ebuild23
-rw-r--r--app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild56
3 files changed, 63 insertions, 24 deletions
diff --git a/app-mobilephone/ganyremote/ChangeLog b/app-mobilephone/ganyremote/ChangeLog
index 28fd04f759a9..ffd8219b96df 100644
--- a/app-mobilephone/ganyremote/ChangeLog
+++ b/app-mobilephone/ganyremote/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/ganyremote
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/ganyremote/ChangeLog,v 1.28 2015/03/04 10:27:46 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/ganyremote/ChangeLog,v 1.29 2015/03/04 10:43:32 kensington Exp $
+
+*ganyremote-6.3.3 (04 Mar 2015)
+
+ 04 Mar 2015; Michael Palimaka <kensington@gentoo.org>
+ +ganyremote-6.3.3.ebuild, -ganyremote-6.1.ebuild:
+ Version bump. Remove old.
04 Mar 2015; Michael Palimaka <kensington@gentoo.org> metadata.xml:
Add upstream metadata.
diff --git a/app-mobilephone/ganyremote/ganyremote-6.1.ebuild b/app-mobilephone/ganyremote/ganyremote-6.1.ebuild
deleted file mode 100644
index 620058649b60..000000000000
--- a/app-mobilephone/ganyremote/ganyremote-6.1.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/ganyremote/ganyremote-6.1.ebuild,v 1.1 2013/03/14 09:00:40 tomwij Exp $
-
-EAPI="5"
-
-inherit base eutils
-
-DESCRIPTION="Gnome frontend to Anyremote"
-HOMEPAGE="http://anyremote.sourceforge.net/"
-SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bluetooth"
-
-DEPEND=">=app-mobilephone/anyremote-6.0[bluetooth=]
- dev-python/pygtk
- bluetooth? ( dev-python/pybluez )"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
diff --git a/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild b/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild
new file mode 100644
index 000000000000..d5c0c1111e38
--- /dev/null
+++ b/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild,v 1.1 2015/03/04 10:43:32 kensington Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-r1
+
+DESCRIPTION="Gnome frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-mobilephone/anyremote-6.5[bluetooth=]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ "${T}"/gettextize -f --no-changelog > /dev/null || die
+
+ # remove deprecated entry
+ sed -e "/Encoding=UTF-8/d" \
+ -i ganyremote.desktop || die "fixing .desktop file failed"
+
+ # fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am || die
+ eautoreconf
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i ganyremote || die
+ fi
+}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/ganyremote
+}