summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-12-20 06:43:47 +0000
committerAlin Năstac <mrness@gentoo.org>2007-12-20 06:43:47 +0000
commit49569f387d3288e2851ae828e082e5ae75fa6234 (patch)
treee294b1d6c8d55f9a8cfb4c495490c5726b78d349 /app-mobilephone
parentVersion bump (#202149) (diff)
downloadgentoo-2-49569f387d3288e2851ae828e082e5ae75fa6234.tar.gz
gentoo-2-49569f387d3288e2851ae828e082e5ae75fa6234.tar.bz2
gentoo-2-49569f387d3288e2851ae828e082e5ae75fa6234.zip
Version bump (#202149)
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/wammu/ChangeLog7
-rw-r--r--app-mobilephone/wammu/files/digest-wammu-0.253
-rw-r--r--app-mobilephone/wammu/wammu-0.25.ebuild76
3 files changed, 85 insertions, 1 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index 09676532d7a8..ace68c4a7332 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.27 2007/12/01 10:03:48 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.28 2007/12/20 06:43:46 mrness Exp $
+
+*wammu-0.25 (20 Dec 2007)
+
+ 20 Dec 2007; Alin Năstac <mrness@gentoo.org> +wammu-0.25.ebuild:
+ Version bump (#202149).
*wammu-0.24 (01 Dec 2007)
diff --git a/app-mobilephone/wammu/files/digest-wammu-0.25 b/app-mobilephone/wammu/files/digest-wammu-0.25
new file mode 100644
index 000000000000..4fb3a9d17e9d
--- /dev/null
+++ b/app-mobilephone/wammu/files/digest-wammu-0.25
@@ -0,0 +1,3 @@
+MD5 4a4153d835ecf8607f2e72ada9703b96 wammu-0.25.tar.bz2 347758
+RMD160 e1337f217a82a75aba752e76b22eb0fe09a5e8f6 wammu-0.25.tar.bz2 347758
+SHA256 ec66568ff6bc35b6c700f5957f2f208278b3e097886b718137f0707447e4bb0e wammu-0.25.tar.bz2 347758
diff --git a/app-mobilephone/wammu/wammu-0.25.ebuild b/app-mobilephone/wammu/wammu-0.25.ebuild
new file mode 100644
index 000000000000..a571d2a580d8
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.25.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.25.ebuild,v 1.1 2007/12/20 06:43:46 mrness Exp $
+
+inherit distutils eutils versionator
+
+DESCRIPTION="front-end for gammu (Nokia and other mobiles)"
+HOMEPAGE="http://www.cihar.com/gammu/wammu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bluetooth"
+
+RDEPEND="=dev-python/wxpython-2.6*
+ >=dev-python/python-gammu-0.24
+ bluetooth? (
+ || (
+ dev-python/pybluez
+ net-wireless/gnome-bluetooth
+ )
+ )"
+DEPEND="${RDEPEND}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af ca cs de es et fi fr hu it ko nl pl pt_BR ru sk sv zh_CN"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_unpack() {
+ unpack ${A}
+
+ # Select the suitable wxpython versions
+ local wxpy_pkg wxpy_slot MY_WXPYTHON_SLOTS
+ for wxpy_pkg in $(portageq match "${ROOT}" '=dev-python/wxpython-2.6*'); do
+ if built_with_use --hidden --missing false =${wxpy_pkg} unicode ; then
+ wxpy_slot=$(get_version_component_range 1-2 ${wxpy_pkg#*/*-})
+ if [ -z "${MY_WXPYTHON_SLOTS}" ]; then
+ MY_WXPYTHON_SLOTS="'${wxpy_slot}'"
+ else
+ MY_WXPYTHON_SLOTS="${MY_WXPYTHON_SLOTS}, '${wxpy_slot}'"
+ fi
+ fi
+ done
+ if [ -z "${MY_WXPYTHON_SLOTS}" ]; then
+ eerror "None of the dev-python/wxpython installed versions have been built with Unicode support."
+ eerror "Install wxpython with unicode USE flag enabled and try again."
+ die "dev-python/wxpython is missing Unicode support"
+ fi
+
+ cd "${S}"
+ sed -e "s/WXPYTHON_VER/${MY_WXPYTHON_SLOTS}/" \
+ "${FILESDIR}"/${PN}-wxversion.patch \
+ > "${T}"/${PN}-wxversion.patch
+ epatch "${T}"/${PN}-wxversion.patch
+
+ cd locale || die "locale directory not found"
+ local lang
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -r ${lang}
+ fi
+ done
+}
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ NEWS"
+ SKIPWXCHECK=yes distutils_src_install
+}